手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师把两个指标合并一个指标

[通达信]
设置
1091 2 青铜韭菜 Lv.2 发表于 · 2020-8-2 20:29 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
指标一

C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
圣:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
灵:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
石:=SMA(灵,13,8);
仙:=CEILING(SMA(石,13,8));
编著:=SMA(圣,21,8);
AABB:=IF(L,CONST(L),DRAWNULL);
启动:STICKLINE(仙-编著>75,AABB,AABB*0.99,15,1),COLOR0000FF;
{VARZT:=BARSLAST(平台启动);}
{DRAWTEXT(VARZT=1,0.99*(AABB+AABB*0.98)/2,'平台启动'),COLORYELLOW;}
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN;
STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,'成立'),COLORYELLOW;
{WWW.GPXIAZAI.COM 股票软件下载网_最新股票指标公式}
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
上轨:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORBLUE,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
下轨:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1;
ZGSTAR:=(上轨+下轨)/2;
ZGEND:=CONST((上轨+下轨)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖'),COLORGREEN;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);
ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:=EMA(VAR7,5)*2, , COLORFF00FF;
D:=EMA(K,5), , COLORWHITE;
J:=K*3-D*2, ,COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
HS:=VOL/CAPITAL*100, , COLORGREEN;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'机构进场'),LINETHICK1,COLORFF00FF;
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大顶(底)') COLORWHITE;
指标王:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)- LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)<20;
{指标王主力建仓:出现的主力建仓时,放心的买入,安心等待上涨。只求失败,指标王!}
DRAWTEXT(指标王,L,'主力建仓'),COLORYELLOW;
DRAWTEXT(VAR1,L*0.98,'★短买'),COLORYELLOW;
DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1) AND C>O,L*0.98,'★加仓'),COLORMAGENTA;
下降压力线:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2;
STICKLINE(CURRBARSCOUNT=2,L,L,10,0),COLORGREEN,;
DRAWNUMBER(ISLASTBAR,REF(L,1),REF(L,1));





指标二

VAR2:=REF(LOW,1);

VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;

VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);

VAR5:=LLV(LOW,38);

VAR6:=HHV(VAR4,38);

VAR7:=IF(LLV(LOW,90),1,0);

VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;

有庄的影子: STICKLINE(VAR8,0,VAR8,6,1) , COLORLIRED;

趋势线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORAABBDD;
AHC1:=CLOSE*VOL;

AHC22:=EMA((EXPMA(AHC1,23)/EXPMA(VOL,23)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);

通道:=1.0668*AHC22,COLOR9F5F9F,LINETHICK3;

起爆:=CROSS(C,通道) AND REF(C,1)*1.05-C<0.008 AND C>O*0.5;

RRF:=起爆,STICK;

STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR000088;

STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000AA;

STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000CC;

STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000EE;

STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000EE;

STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLORLIMAGENTA;

STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLOR770077;

STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLOR990099;

STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORBB00BB;

STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORDD00DD;

STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORFF00FF;

STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORDD00DD;

STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR003300;

STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR005500;

STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR007700;

STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR009900;

STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR00CC00;

STICKLINE(RRF,0,3,3,0),COLOR008888;

STICKLINE(RRF,0,3,3,0),COLOR00AAAA;

STICKLINE(RRF,0,3,3,0),COLOR00CCCC;

STICKLINE(RRF,0,3,3,0),COLOR00FFFF;

DRAWTEXT(RRF,10.5,'游'),COLORYELLOW;

DRAWTEXT(RRF,7.5,'资'),COLORYELLOW;

DRAWTEXT(RRF,4.5,'来'),COLORRED;

DRAWTEXT(RRF,1.5,'了'),COLORRED;

小信号:-13,COLORYELLOW;

中机会:-21,COLORMAGENTA;

砸锅卖铁:-34,COLORGREEN;
X_1:=IF(NAMELIKE(7),0,1);
X_2:=DYNAINFO(8)>0;
X_3:=IF(NAMELIKE(8),0,1);
X_4:=X_1 AND X_2 AND X_3;
X_5:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
X_6:=SMA(X_5,9,1);
X_7:=SMA(X_6,9,1);
X_8:=CROSS(X_6,X_7);
X_9:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
X_10:=COUNT(X_8,21)>=2;
X_11:=X_6<20;
X_12:=MA(CLOSE,10)>REF(MA(CLOSE,10),1);
X_13:=COUNT(X_9<(-8),20)>=1 AND X_9<=0 AND COUNT(X_9<=0,4)>=2;
X_14:=X_10 AND X_11 AND X_12 AND X_13;
X_15:=X_14 AND COUNT(X_14,10)=1;
X_16:=REF(CLOSE,1);
X_17:=SMA(MAX(CLOSE-X_16,0),7,1)/SMA(ABS(CLOSE-X_16),7,1)*100;
X_18:=SMA(MAX(CLOSE-X_16,0),13,1)/SMA(ABS(CLOSE-X_16),13,1)*100;
X_19:=BARSLAST(X_18<20)<=3 AND CROSS(X_17,X_18);
X_20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100<(-12.5);
X_21:=LLV(LOW,5);
X_22:=HHV(HIGH,5);
X_23:=EMA((CLOSE-X_21)/(X_22-X_21)*100,4);
X_24:=EMA(0.667*REF(X_23,1)+0.333*X_23,2);
X_25:=X_19 AND X_20 AND CROSS(X_23,X_24) AND X_23<=25;
X_26:=DMA(EMA(CLOSE,14),SUM(VOL,5)/3/CAPITAL);
X_27:=(CLOSE-X_26)/X_26*100;
X_28:=X_27<(-38);
X_29:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
X_30:=(CLOSE-X_29)/X_29*100;
X_31:=REF(X_30,1)<(-37) AND X_30>REF(X_30,1) AND REF(X_30,1)<REF(X_30,2) AND REF(X_30,2)-REF(X_30,1)>1;
X_32:=X_28 OR X_31 AND VOL/CAPITAL*100<6;
X_33:=X_32 AND COUNT(X_32,10)=1;
X_34:=(HIGH-LOW)/HIGH*100+(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_35:=EMA(MA(X_34,50),5);
X_36:=X_35>LLV(X_35,5)*1.01 AND REF(X_35,1)<REF(LLV(X_35,5),1)*1.01 AND LLV(X_35,50)=LLV(X_35,5);
X_37:=LLV(LOW,5)=LLV(LOW,50) AND LLV(LOW,5)<HHV(LOW,70)*0.5;
X_38:=X_36 AND X_37;
X_39:=X_15 OR X_25 OR X_33 OR X_38 AND X_4;
STICKLINE(X_39,0,90,1,0),COLORBROWN;
STICKLINE(X_39,0,90,0.1,0),COLORRED;

X_40:=CLOSE/REF(CLOSE,1)>1.05 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_41:=FILTER(X_40,28)*100;
X_42:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1),91,0);
X_43:=FILTER(X_42>90,45) AND FILTER(X_42>90,35) AND X_41>0;
X_44:=X_43 AND COUNT(X_43,60)=1;
STICKLINE(X_44,75,66,1,0),COLORRED;
STICKLINE(X_44,66,57,1,0),COLORMAGENTA;
STICKLINE(X_44,57,48,2,0),COLORGREEN;
STICKLINE(X_44,48,39,2,0),COLORBLUE;
STICKLINE(X_44,30,21,3,0),COLORBROWN;
STICKLINE(X_44,39,30,3,0),COLORCYAN;
STICKLINE(X_44,21,12,4,0),COLORYELLOW;
STICKLINE(X_44,12,3,4,0),COLORWHITE;

DRAWICON(X_44,70,13);

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-8-2 21:22 复制 查看全部楼层
青铜韭菜 发表于 2020-8-2 20:37
麻烦把 第三个指标的   红柱  一起加上去

C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
圣:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
灵:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
石:=SMA(灵,13,8);
仙:=CEILING(SMA(石,13,8));
编著:=SMA(圣,21,8);
AABB:=IF(L,CONST(L),DRAWNULL);
启动:STICKLINE(仙-编著>75,AABB,AABB*0.99,15,1),COLOR0000FF;
{VARZT:=BARSLAST(平台启动);}
{DRAWTEXT(VARZT=1,0.99*(AABB+AABB*0.98)/2,'平台启动'),COLORYELLOW;}
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN;
STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,'成立'),COLORYELLOW;
{WWW.GPXIAZAI.COM 股票软件下载网_最新股票指标公式}
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
上轨:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORBLUE,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
下轨:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1;
ZGSTAR:=(上轨+下轨)/2;
ZGEND:=CONST((上轨+下轨)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖'),COLORGREEN;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);
ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:=EMA(VAR7,5)*2, , COLORFF00FF;
D:=EMA(K,5), , COLORWHITE;
J:=K*3-D*2, ,COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
HS:=VOL/CAPITAL*100, , COLORGREEN;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'机构进场'),LINETHICK1,COLORFF00FF;
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大顶(底)') COLORWHITE;
指标王:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)- LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)<20;
{指标王主力建仓:出现的主力建仓时,放心的买入,安心等待上涨。只求失败,指标王!}
DRAWTEXT(指标王,L,'主力建仓'),COLORYELLOW;
DRAWTEXT(VAR1,L*0.98,'★短买'),COLORYELLOW;
DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1) AND C>O,L*0.98,'★加仓'),COLORMAGENTA;
下降压力线:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2;
STICKLINE(CURRBARSCOUNT=2,L,L,10,0),COLORGREEN,;
DRAWNUMBER(ISLASTBAR,REF(L,1),REF(L,1));
{指标二}
VAR22:=REF(LOW,1);
VAR23:=SMA(ABS(LOW-VAR22),3,1)/SMA(MAX(LOW-VAR22,0),3,1)*100;
VAR24:=EMA(IF(CLOSE*1.2,VAR23*10,VAR23/10),3);
VAR25:=LLV(LOW,38);
VAR26:=HHV(VAR24,38);
VAR27:=IF(LLV(LOW,90),1,0);
VAR28:=EMA(IF(LOW<=VAR25,(VAR24+VAR26*2)/2,0),3)/618*VAR27;
有庄的影子: STICKLINE(VAR28,0,VAR28,6,1) , COLORLIRED;
趋势线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORAABBDD;
AHC1:=CLOSE*VOL;
AHC22:=EMA((EXPMA(AHC1,23)/EXPMA(VOL,23)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
通道:=1.0668*AHC22,COLOR9F5F9F,LINETHICK3;
起爆:=CROSS(C,通道) AND REF(C,1)*1.05-C<0.008 AND C>O*0.5;
RRF:=起爆,STICK;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR000088;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000AA;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000CC;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000EE;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000EE;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLORLIMAGENTA;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLOR770077;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLOR990099;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORBB00BB;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORDD00DD;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORFF00FF;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORDD00DD;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR003300;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR005500;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR007700;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR009900;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR00CC00;
STICKLINE(RRF,0,3,3,0),COLOR008888;
STICKLINE(RRF,0,3,3,0),COLOR00AAAA;
STICKLINE(RRF,0,3,3,0),COLOR00CCCC;
STICKLINE(RRF,0,3,3,0),COLOR00FFFF;
DRAWTEXT(RRF,10.5,'游'),COLORYELLOW;
DRAWTEXT(RRF,7.5,'资'),COLORYELLOW;
DRAWTEXT(RRF,4.5,'来'),COLORRED;
DRAWTEXT(RRF,1.5,'了'),COLORRED;
小信号:-13,COLORYELLOW;
中机会:-21,COLORMAGENTA;
砸锅卖铁:-34,COLORGREEN;
X_1:=IF(NAMELIKE(7),0,1);
X_2:=DYNAINFO(8)>0;
X_3:=IF(NAMELIKE(8),0,1);
X_4:=X_1 AND X_2 AND X_3;
X_5:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
X_6:=SMA(X_5,9,1);
X_7:=SMA(X_6,9,1);
X_8:=CROSS(X_6,X_7);
X_9:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
X_10:=COUNT(X_8,21)>=2;
X_11:=X_6<20;
X_12:=MA(CLOSE,10)>REF(MA(CLOSE,10),1);
X_13:=COUNT(X_9<(-8),20)>=1 AND X_9<=0 AND COUNT(X_9<=0,4)>=2;
X_14:=X_10 AND X_11 AND X_12 AND X_13;
X_15:=X_14 AND COUNT(X_14,10)=1;
X_16:=REF(CLOSE,1);
X_17:=SMA(MAX(CLOSE-X_16,0),7,1)/SMA(ABS(CLOSE-X_16),7,1)*100;
X_18:=SMA(MAX(CLOSE-X_16,0),13,1)/SMA(ABS(CLOSE-X_16),13,1)*100;
X_19:=BARSLAST(X_18<20)<=3 AND CROSS(X_17,X_18);
X_20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100<(-12.5);
X_21:=LLV(LOW,5);
X_22:=HHV(HIGH,5);
X_23:=EMA((CLOSE-X_21)/(X_22-X_21)*100,4);
X_24:=EMA(0.667*REF(X_23,1)+0.333*X_23,2);
X_25:=X_19 AND X_20 AND CROSS(X_23,X_24) AND X_23<=25;
X_26:=DMA(EMA(CLOSE,14),SUM(VOL,5)/3/CAPITAL);
X_27:=(CLOSE-X_26)/X_26*100;
X_28:=X_27<(-38);
X_29:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
X_30:=(CLOSE-X_29)/X_29*100;
X_31:=REF(X_30,1)<(-37) AND X_30>REF(X_30,1) AND REF(X_30,1)<REF(X_30,2) AND REF(X_30,2)-REF(X_30,1)>1;
X_32:=X_28 OR X_31 AND VOL/CAPITAL*100<6;
X_33:=X_32 AND COUNT(X_32,10)=1;
X_34:=(HIGH-LOW)/HIGH*100+(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_35:=EMA(MA(X_34,50),5);
X_36:=X_35>LLV(X_35,5)*1.01 AND REF(X_35,1)<REF(LLV(X_35,5),1)*1.01 AND LLV(X_35,50)=LLV(X_35,5);
X_37:=LLV(LOW,5)=LLV(LOW,50) AND LLV(LOW,5)<HHV(LOW,70)*0.5;
X_38:=X_36 AND X_37;
X_39:=X_15 OR X_25 OR X_33 OR X_38 AND X_4;
STICKLINE(X_39,0,90,1,0),COLORBROWN;
STICKLINE(X_39,0,90,0.1,0),COLORRED;
X_40:=CLOSE/REF(CLOSE,1)>1.05 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_41:=FILTER(X_40,28)*100;
X_42:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1),91,0);
X_43:=FILTER(X_42>90,45) AND FILTER(X_42>90,35) AND X_41>0;
X_44:=X_43 AND COUNT(X_43,60)=1;
STICKLINE(X_44,75,66,1,0),COLORRED;
STICKLINE(X_44,66,57,1,0),COLORMAGENTA;
STICKLINE(X_44,57,48,2,0),COLORGREEN;
STICKLINE(X_44,48,39,2,0),COLORBLUE;
STICKLINE(X_44,30,21,3,0),COLORBROWN;
STICKLINE(X_44,39,30,3,0),COLORCYAN;
STICKLINE(X_44,21,12,4,0),COLORYELLOW;
STICKLINE(X_44,12,3,4,0),COLORWHITE;
DRAWICON(X_44,70,13);
VAR77:=CLOSE-REF(CLOSE,1);
VAR88:=100*EMA(EMA(VAR77,6),6)/EMA(EMA(ABS(VAR77),6),6);
VAR99:=EMA(CLOSE,5);
VAR100:=EMA(CLOSE,13);
VAR111:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(VAR100,VAR99))+1),LLV(LOW,BARSLAST(CROSS(VAR100,VAR9))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(VAR99,VAR100))+1),HHV(HIGH,BARSLAST(CROSS(VAR99,VAR100))+1),0);
VAR122:=DRAWLINE(HIGH=HHV(HIGH,BARSLAST(CROSS(VAR99,VAR100))+1),HHV(HIGH,BARSLAST(CROSS(VAR99,VAR100))+1),LOW=LLV(LOW,BARSLAST(CROSS(VAR100,VAR99))+1),LLV(LOW,BARSLAST(CROSS(VAR100,VAR99))+1),0);
BT:LLV(VAR88,2)=LLV(VAR88,7) AND COUNT(VAR88<0,2) AND CROSS(VAR88,MA(VAR88,2)) AND REF(VAR122,1)<REF(VAR122,2) AND VAR111>REF(VAR122,1);
DRAWTEXT(BT,3,57),COLORRED;

举报

点亮(2) 扔鸡蛋(0) 回复

青铜韭菜
Lv.2
发表于 2020-8-2 20:37 复制 查看全部楼层
本帖最后由 青铜韭菜 于 2020-8-2 20:40 编辑

麻烦把 第三个指标的   红柱  一起加上去


VAR1:=5;
VAR2:=10;
VAR3:=REF(CLOSE,1);
VAR4:=(2*CLOSE+HIGH+LOW)/4;
VAR5:=MA(VAR4,3)>REF(MA(VAR4,3),1);
安全线:2,POINTDOT,COLORRED,LINETHICK4;
VAR6:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
K:MA(3*SMA(VAR6,6,1)-2*SMA(SMA(VAR6,5,1),5,1),3),COLORF00FF0;
D:MA(K,3),COLORBLUE;
J:3*K-2*D,COLORF00FF0;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
VAR7:=CLOSE-REF(CLOSE,1);
VAR8:=100*EMA(EMA(VAR7,6),6)/EMA(EMA(ABS(VAR7),6),6);
VAR9:=EMA(CLOSE,5);
VAR10:=EMA(CLOSE,13);
VAR11:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),0);
VAR12:=DRAWLINE(HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),0);
BT:LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) AND CROSS(VAR8,MA(VAR8,2)) AND REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1);
底线:0,COLORMAGENTA;
顶线:10,COLORBLUE;
STICKLINE(VAR11,0,0.2,3,0),COLORRED;
STICKLINE(VAR12,0,0.2,3,0),COLORGREEN;
STICKLINE(BT,0,3,2,0),COLOR000088;
STICKLINE(BT,0,3,1,0),COLOR0000CC;
STICKLINE(BT,0,3,0.22,0),COLORRED;
DRAWTEXT(BT,3,57),COLORRED;
TJ1:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<HHV(HIGH,21)*0.82;
STICKLINE(TJ1,0,2,3,0),COLOR880088;
STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;

VAR13:=HHV(HIGH,55);
VAR14:=LLV(LOW,55);
VAR15:=VAR13*VAR14;
VAR16:=SQRT(VAR15);
TJ2:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<VAR16;
STICKLINE(TJ2,0,1,5,0),COLOR008888;
STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;

VAR17:=REF(VAR11,1)>REF(VAR11,2) AND VAR12<REF(VAR11,1);
STICKLINE(VAR17,10,9,5,0),COLOR008800;
STICKLINE(VAR17,10,9,2,0),COLOR00AA00;
STICKLINE(VAR17,10,9,1,0),COLOR00CC00;
STICKLINE(VAR17,10,9,0.2,0),COLORGREEN;
DRAWTEXT(VAR17,9,4),COLORGREEN;
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:EMA(DIFF,9),COLORCYAN;
VAR18:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:REF(CLOSE,VAR18+1)>CLOSE AND DIFF>REF(DIFF,VAR18+1) AND CROSS(DIFF,DEA);
VAR19:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:REF(CLOSE,VAR19+1)<CLOSE AND REF(DIFF,VAR19+1)>DIFF AND CROSS(DEA,DIFF);

买入:ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3),COLORRED;
卖出:ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3),COLORGREEN;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表