手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做二个预警选股指标(1.笑脸 2.哭脸)

[通达信]
设置
1157 2 牛牛牛0910 Lv.2 发表于 · 2020-8-2 20:47 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
上轨:EMA(H,25),COLORGREEN,LINETHICK2;
下轨:EMA(L,25),COLORGREEN,LINETHICK2;
NA1:=PLOYLINE(C>上轨,上轨);
IF(C>上轨,NA1,DRAWNULL),COLORRED,LINETHICK2;
NB1:=PLOYLINE(C>下轨,下轨);
IF(C>下轨,NB1,DRAWNULL),COLORRED,LINETHICK2;
{变色K线}
QS:=(C+上轨+下轨)/3;
STICKLINE(C>REF(QS,1) AND O>=C,C,O,-1,0),COLORRED;
STICKLINE(C>REF(QS,1) AND O>=C,L,H,0,0),COLORRED;
STICKLINE(C<=REF(QS,1) AND O<=C,O,C,-1,1),COLORCYAN;
STICKLINE(C<=REF(QS,1) AND O<=C,O,L,0,1),COLORCYAN;
STICKLINE(C==REF(QS,1) AND O<=C,C,H,0,1),COLORCYAN;
{涨停K线}
ZT_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
ZT_2:=ZT_1>=0.099 AND CLOSE=HIGH AND LOW!=HIGH;
STICKLINE(ZT_2,OPEN,CLOSE,2,0),COLORYELLOW;
{KDJ测顶底}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
{文字或图标任换一种:}
{DRAWTEXT(CROSS(100,J),H*1.02,'顶'),COLORGREEN;
DRAWTEXT(CROSS(J,0),L*0.97,'底'),COLORRED;}
{2.∧∨图标}
{DRAWICON(CROSS(J,0),L*0.98,34);
DRAWICON(CROSS(100,J),H*1.02,35);}
{3.笑哭图标}
DRAWICON(CROSS(J,0),L*0.98,5);
DRAWICON(CROSS(100,J),H*1.02,6);
{九转}
A1:=C>REF(C,4);
A2:=C<REF(C,4);
T1:=A2 AND REF(A1,1);
T2:=A2 AND REF(T1,1);
T3:=A2 AND REF(T2,1);
T4:=A2 AND REF(T3,1);
T5:=A2 AND REF(T4,1);
T6:=A2 AND REF(T5,1);
T7:=A2 AND REF(T6,1);
T8:=A2 AND REF(T7,1);
T9:=A2 AND REF(T8,1);
DRAWTEXT(T6,L*0.99,'6'),COLORGREEN;
DRAWTEXT(T7,L*0.99,'7'),COLORGREEN;脸·
DRAWTEXT(T8,L*0.99,'8'),COLORGREEN;
DRAWTEXT(T9,L*0.99,'9'),COLORGREEN;
B1:=C<REF(C,4);
B2:=C>REF(C,4);
D1:=B2 AND REF(B1,1);
D2:=B2 AND REF(D1,1);
D3:=B2 AND REF(D2,1);
D4:=B2 AND REF(D3,1);
D5:=B2 AND REF(D4,1);
D6:=B2 AND REF(D5,1);
D7:=B2 AND REF(D6,1);
D8:=B2 AND REF(D7,1);
D9:=B2 AND REF(D8,1);
DRAWTEXT(D6,H*1.01,'6'),COLORYELLOW;
DRAWTEXT(D7,H*1.01,'7'),COLORYELLOW;
DRAWTEXT(D8,H*1.01,'8'),COLORYELLOW;
DRAWTEXT(D9,H*1.01,'9'),COLORYELLOW;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-8-2 20:55 复制 查看全部楼层
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
笑脸:CROSS(J,0);





RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
苦脸:CROSS(100,J);
查看全部打赏
  • 快乐398+6理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-8-2 20:53 复制 查看全部楼层
{KDJ测顶底}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;

{3.笑哭图标}
TJ1:=CROSS(J,0);
TJ2:CROSS(100,J);




































{KDJ测顶底}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;

{3.笑哭图标}
TJ1:CROSS(J,0);



查看全部打赏
  • 快乐398+6理想币 : 点赞,知识的价值在于分享,谢谢!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表