手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个波谷的选股公式

[通达信]
设置
1147 1 我心依旧佳 Lv.3 发表于 · 2020-8-5 10:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{大波段操作公式源码}
VAR1:=IF(DATE<1340830 AND DATE>900101,1,0);
VAR2:=IF(MONTH<12,1,100000);
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,34);
VAR5:=HHV(HIGH,34);
DIF:EMA((VAR3-VAR4)/(VAR5-VAR4)*100,13),LINETHICK2;
DEA:EMA(0.667*REF(DIF,1)+0.333*DIF,2),LINETHICK1;
QS:IF(CROSS(DIF,DEA) AND DIF<40,25,10),COLORRED;
买入:QS=25 AND CROSS(MA(CLOSE,5),MA(CLOSE,10)),LINETHICK0;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<22,20,'波谷'),COLORGREEN;
DRAWICON(CROSS(DIF,DEA) AND DIF<22,25,1);
DRAWTEXT(CROSS(DIF,30) AND DEA<DIF,40,'初波段'),COLORWHITE;
DRAWICON(CROSS(DIF,30) AND DEA<DIF,35,1);
DRAWTEXT(CROSS(DIF,65) AND DEA<DIF,55,'中波段'),COLORFF00FF;
DRAWICON(CROSS(DIF,65) AND DEA<DIF,70,2);
DRAWTEXT(CROSS(DIF,75) AND DEA<DIF,67,'高波段'),COLORYELLOW;
DRAWICON(CROSS(DIF,75) AND DEA<DIF,80,2);
DRAWTEXT(CROSS(DEA,DIF) AND DEA>75,80,'波峰'),COLORRED;
DRAWICON(CROSS(DEA,DIF) AND DEA>75,85,2);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-8-5 10:22 复制 查看全部楼层
VAR1:=IF(DATE<1340830 AND DATE>900101,1,0);
VAR2:=IF(MONTH<12,1,100000);
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,34);
VAR5:=HHV(HIGH,34);
DIF:=EMA((VAR3-VAR4)/(VAR5-VAR4)*100,13),LINETHICK2;
DEA:=EMA(0.667*REF(DIF,1)+0.333*DIF,2),LINETHICK1;
QS:=IF(CROSS(DIF,DEA) AND DIF<40,25,10),COLORRED;
买入:=QS=25 AND CROSS(MA(CLOSE,5),MA(CLOSE,10)),LINETHICK0;
波谷:CROSS(DIF,DEA) AND DIF<22;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表