手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助用这两个指标做两个选股,一根线即将穿越另一根线的两个选股

[通达信]
设置
1902 9 书的 Lv.2 发表于 · 2020-8-13 12:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR1:=5;
VAR2:=10;
VAR3:=REF(CLOSE,1);
VAR4:=(2*CLOSE+HIGH+LOW)/4;
VAR5:=MA(VAR4,3)>REF(MA(VAR4,3),1);

安全线:2,POINTDOT,COLORRED,LINETHICK4;

VAR6:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;

K:MA(3*SMA(VAR6,6,1)-2*SMA(SMA(VAR6,5,1),5,1),3),COLORF00FF0;

D:MA(K,3),COLORBLUE;
J:3*K-2*D,COLORF00FF0;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));

VAR7:=CLOSE-REF(CLOSE,1);
VAR8:=100*EMA(EMA(VAR7,6),6)/EMA(EMA(ABS(VAR7),6),6);

VAR9:=EMA(CLOSE,5);
VAR10:=EMA(CLOSE,13);
VAR11:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),0);

VAR12:=DRAWLINE(HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),0);

BT:LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) AND CROSS(VAR8,MA(VAR8,2)) AND REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1);

底线:0,COLORMAGENTA;
顶线:10,COLORBLUE;
STICKLINE(VAR11,0,0.2,3,0),COLORRED;

STICKLINE(VAR12,0,0.2,3,0),COLORGREEN;

STICKLINE(BT,0,3,2,0),COLOR000088;

STICKLINE(BT,0,3,1,0),COLOR0000CC;

STICKLINE(BT,0,3,0.22,0),COLORRED;

DRAWTEXT(BT,3,57),COLORRED;
TJ1:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<HHV(HIGH,21)*0.82;

STICKLINE(TJ1,0,2,3,0),COLOR880088;

STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;

STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;

STICKLINE(TJ1,0,2,0.2,0),COLORMAGENTA;

DRAWTEXT(TJ1,2,58),COLORMAGENTA;

VAR13:=HHV(HIGH,55);
VAR14:=LLV(LOW,55);
VAR15:=VAR13*VAR14;
VAR16:=SQRT(VAR15);
TJ2:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<VAR16;

STICKLINE(TJ2,0,1,5,0),COLOR008888;

STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;

STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;

STICKLINE(TJ2,0,1,0.2,0),COLORYELLOW;

DRAWTEXT(TJ2,1,59),COLORYELLOW;

VAR17:=REF(VAR11,1)>REF(VAR11,2) AND VAR12<REF(VAR11,1);

STICKLINE(VAR17,10,9,5,0),COLOR008800;

STICKLINE(VAR17,10,9,2,0),COLOR00AA00;

STICKLINE(VAR17,10,9,1,0),COLOR00CC00;

STICKLINE(VAR17,10,9,0.2,0),COLORGREEN;

DRAWTEXT(VAR17,9,4),COLORGREEN;

DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);

DEA:EMA(DIFF,9),COLORCYAN;
VAR18:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:REF(CLOSE,VAR18+1)>CLOSE AND DIFF>REF(DIFF,VAR18+1) AND CROSS(DIFF,DEA);

DRAWTEXT(底背离,(-0.6),60),COLORWHITE;

VAR19:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:REF(CLOSE,VAR19+1)<CLOSE AND REF(DIFF,VAR19+1)>DIFF AND CROSS(DEA,DIFF);

DRAWTEXT(顶背离,11,61),COLORWHITE;

买入:ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3),COLORRED;

卖出:ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3),COLORGREEN;










XA_1:=DATE>901224;
趋势线:XA_1*((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50),COLOR586FDE;
XA_2:=(2*CLOSE+HIGH+LOW+OPEN)/5;
XA_3:=LLV(LOW,34);
XA_4:=HHV(HIGH,34);
SK:EMA((XA_2-XA_3)/(XA_4-XA_3)*100,13)*XA_1,COLORMAGENTA;
SD:EMA(SK,2)*XA_1,COLOR95ECFF;
XA_5:=EMA(CLOSE,12)-EMA(CLOSE,26);
XA_6:=XA_1*EMA(XA_5,9);
XA_7:=XA_1*CLOSE*1.236<MA(CLOSE,60);
XA_8:=CLOSE/REF(CLOSE,1)>1.0213;
XA_9:=(HIGH-CLOSE)*1.36<=CLOSE-OPEN;
XA_10:=(MA(CLOSE,120)-CLOSE)/CLOSE*100;
XA_11:=ABS(XA_5-XA_6);
XA_12:=STD(CLOSE,90)*10;
XA_13:=COUNT((REF(CLOSE,15)-CLOSE)/CLOSE*100>45,5);
买91:XA_1*(XA_7 AND XA_8 AND XA_9 AND XA_12<25 AND CLOSE<8 AND XA_10<114 AND XA_11<=0.23)*35,STICK,COLORDD22DD;
XA_14:=SLOPE(CLOSE,40);
XA_15:=COUNT((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<(-0.098),90);
XA_16:=(MA(CLOSE,120)-CLOSE)/CLOSE*100;
XA_17:=XA_1*STD(CLOSE,63)*10;
XA_18:=XA_1*(MA(CLOSE,76)-MA(CLOSE,13)/3);
XA_19:=XA_1*MA((CLOSE-XA_18)/XA_18,1);
买87:XA_1*IF(CROSS(XA_19,(-0.008)) AND XA_14>(-0.618) AND XA_16<114 AND XA_17<23.6 AND XA_15<8 AND LOW/REF(HIGH,1)<1.145 OR REF(XA_19,2)=LLV(XA_19,20) AND REF(XA_19,2)<0.042 AND XA_15<8 AND REF(XA_19,2)<REF(XA_19,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND XA_19>(-0.368) AND CLOSE>REF(CLOSE,1),68,0),STICK,COLORYELLOW;
XA_20:=XA_1*(HIGH+LOW+CLOSE)/3;
XA_21:=(XA_20-MA(XA_20,14))/(0.015*AVEDEV(XA_20,14));
XA_22:=CLOSE/MA(CLOSE,40)*100<76;
XA_23:=CLOSE/MA(CLOSE,60)*100<74;
XA_24:=HIGH>LOW*1.051;
XA_25:=XA_24 AND COUNT(XA_24,5)>1;
买94:XA_1*(XA_25 AND (XA_22 OR XA_23) AND MA(CLOSE,27)/CLOSE>1.169 AND MA(CLOSE,17)/CLOSE>1.158 AND CLOSE<MA(CLOSE,120) AND MA(CLOSE,60)<MA(CLOSE,120) AND MA(CLOSE,60)>MA(CLOSE,30) AND XA_21>(-210) AND MA(VOL,60)>MA(VOL,30) AND (CLOSE>OPEN OR CLOSE<OPEN) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>(-0.07))*52,STICK,COLOR2222FF;
XA_26:=MA(CLOSE,5);
XA_27:=MA(CLOSE,10);
XA_28:=XA_1*MA(CLOSE,20);
XA_29:=MA(CLOSE,30);
XA_30:=MA(CLOSE,60);
XA_31:=MA(CLOSE,150);
XA_32:=MA(CLOSE,250);
XA_33:=XA_1*VOL/CAPITAL*100;
XA_34:=(CLOSE-XA_32)/XA_32*100;
XA_35:=XA_1*(CLOSE/REF(CLOSE,1)-1)*100;
XA_36:=XA_1*PWINNER(1,CLOSE);
XA_37:=IF(XA_1>0.75 AND XA_1<0.901,0.618,1);
牛97:IF(XA_26>XA_27 AND XA_27>XA_28 AND XA_28>XA_29 AND XA_28>XA_30 AND XA_31>XA_32 AND (XA_36>=0.9 OR XA_36>0.76 AND XA_36<0.901 AND XA_35>5 AND XA_33>5) AND XA_35>1.8 AND XA_34<40 AND CLOSE>3 AND (CLOSE-XA_30)/XA_30<0.25 AND XA_33<=6 AND XA_4*XA_33>=1 AND CLOSE<18.5,76,0),STICK,COLORRED,LINETHICK3;
XA_38:=XA_1*(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
XA_39:=(MA(CLOSE,48)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
XA_40:=XA_1*(MA(CLOSE,12)+MA(CLOSE,24)+MA(CLOSE,48)+MA(CLOSE,96))/4;
XA_41:=XA_1*MA(CLOSE,250);
XA_42:=XA_1*MA(CLOSE,125);
牛:IF(SD>18 AND SK<75 AND CROSS(XA_38,XA_39) AND (XA_40-XA_41)/XA_41<0.1613 AND REF(SK,3)<SK AND REF(XA_40,1)<XA_40,95,0),STICK,COLOR33AADD;
XA_43:=CLOSE/MA(CLOSE,3)>=1.05 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
XA_44:=REF(CLOSE,1);
XA_45:=SMA(MAX(CLOSE-XA_44,0),5,1)/SMA(ABS(CLOSE-XA_44),5,1)*100;
XA_46:=XA_1*COUNT(XA_45<25,20)>=1;
XA_47:=(HIGH-LOW)/HIGH*100+(CLOSE-XA_44)/XA_44*100;
XA_48:=EMA(MA(XA_47,41),6);
XA_49:=XA_48>LLV(XA_48,6)*1.02 AND REF(XA_48,1)<REF(LLV(XA_48,6),1)*1.02 AND LLV(XA_48,29)=LLV(XA_48,6);
XA_50:=XA_1*(LLV(LOW,6)=LLV(LOW,41) AND LLV(LOW,6)<HHV(LOW,41)*(100-29)/100)*XA_1;
XA_51:=HIGH>LOW*1.033;
从此反转:XA_1*((XA_50>0 AND XA_51)*16+81.5)*XA_1,COLORFF99FF;
买入:IF(CROSS(趋势线,21),50,18.5)*XA_1,COLORRED;
卖出:IF(CROSS(87,趋势线),50,81.5)*XA_1,COLORFFF000;
DRAWTEXT(XA_50>0 AND XA_51,88,1),COLORGREEN;
XA_52:=IF(CROSS(SK,SD),25,18.5);
XA_53:=IF(CROSS(SD,SK),75,81.5);
卖线:XA_53*XA_1,COLORFFF000;
买线:XA_52*XA_1,COLOR33FF66;

附件

即将穿越

即将穿越

即将穿越

即将穿越

相关股票

举报

扔鸡蛋(0) 回复

书的
Lv.2
发表于 2020-8-14 11:17 复制 查看全部楼层
谢谢老师了,刚才试了试老师改的选股特别好,非常感谢老师,祝老师股市天天大红

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-14 08:31 复制 查看全部楼层
书的 发表于 2020-8-13 17:51
老师不是这个线穿越是这个的下面还有两根线,老师在找几个股看看是不是下面还有两根线,谢谢老师

找到了。
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
CROSS(DIFF,DEA);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 书的+8理想币 +1共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

书的
Lv.2
发表于 2020-8-13 20:46 复制 查看全部楼层
麻烦哪位老师给我做一下这个选股啊,万分感谢

举报

点亮(1) 扔鸡蛋(0) 回复

书的
Lv.2
发表于 2020-8-13 18:47 复制 查看全部楼层
老师麻烦你还能在做一个吗,谢谢

举报

扔鸡蛋(0) 回复

书的
Lv.2
发表于 2020-8-13 17:51 复制 查看全部楼层
老师不是这个线穿越是这个的下面还有两根线,老师在找几个股看看是不是下面还有两根线,谢谢老师

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-13 17:05 复制 查看全部楼层
书的 发表于 2020-8-13 16:50
谢谢老师,看着不是我要的效果,谢谢老师,源码没问题的,图片1是第2个公式,图片2是第1个公式

楼上下面的公式没问题就是写 的1,所以说原码发对了吗。我写的2,按你上部分写。下图就是上部分的公式。

附件

捕获.PNG

举报

点亮(2) 扔鸡蛋(0) 回复

书的
Lv.2
发表于 2020-8-13 17:05 复制 查看全部楼层
第1张图片做的选股可以,第2张图片做的那个看着有的线离的很远,非常感谢老师

举报

点亮(1) 扔鸡蛋(0) 回复

书的
Lv.2
发表于 2020-8-13 16:50 复制 查看全部楼层
本帖最后由 书的 于 2020-8-13 17:55 编辑

谢谢老师,看着不是我要的效果,谢谢老师,源码没问题的,图片1是第2个公式,图片2是第1个公式

附件

QQ图片20200813175531.jpg

举报

点亮(3) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-13 15:24 复制 查看全部楼层
如果原码没发错。试试
1
趋势线:=((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50),COLOR586FDE;
XA_2:=(2*CLOSE+HIGH+LOW+OPEN)/5;
XA_3:=LLV(LOW,34);
XA_4:=HHV(HIGH,34);
SK:=EMA((XA_2-XA_3)/(XA_4-XA_3)*100,13);
SD:=EMA(SK,2);
CROSS(SK,SD)&&趋势线>SK&&趋势线>REF(趋势线,1);

2
VAR6:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
K:=MA(3*SMA(VAR6,6,1)-2*SMA(SMA(VAR6,5,1),5,1),3);
D:=MA(K,3);
CROSS(K,D);
查看全部打赏
  • 书的+8理想币 +1共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表