手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这两个指标合成一个选股指标

[通达信]
设置
1579 3 红花绿叶配 Lv.3 发表于 · 2020-8-23 21:35 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
B:SMA(VAR1,N,1);
VAR2:SMA(B,M,1);
绝路航标:IF(CROSS(B,VAR2) AND B<40,50,0);

N:=5;
A1:=REF(C,1)<REF(O,1);
A2:=REF(C,2)>REF(O,2) AND REF(C,1)<REF(C,2);
A3:=REF(C,2)<REF(O,2) AND REF(C,1)<REF(O,2);
AA:=A1 OR A2 OR A3;
B1:=C>O AND C>REF(H,1);
B2:=ABS((REF(V,1)-LLV(V,N))/LLV(V,N))<=0.1;
B3:=V/REF(V,1)>=1.8;
BB:=B1 AND B2 AND B3;
倍量:=AA AND BB;
{去掉ST}
SS2:=IF(NAMELIKE('S'),0,1);
SS3:=IF(NAMELIKE('*'),0,1);
{去掉停牌}
SS4:=DYNAINFO(17)>0;
{去掉亏损与连续亏损}
SS5:=FINDSTR(FGBLOCK,'连续亏损');
SS6:=FINDSTR(FGBLOCK,'亏损股');
股本:=CAPITAL<20000000 ;
S1:=IF(CODELIKE('300'),0,1);
S2:=FINANCE(1)/10000000<=200;
股价:=S2 AND C<30  AND S1;
涨幅:=C/REF(C,1)>1.01 AND C/REF(C,1)<1.07;
ZIF:=EMA(C,12)-EMA(C,26);
ZEA:=EMA(ZIF,9);
ZBC:=2*(ZIF-ZEA);
ZJS:=1.25*ZIF-0.25*ZEA;
ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28;
ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28;
ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28;
ZNX:=(ZXH+ZQS)/2,COLORMAGENTA;
ZJD:=ATAN((ZPH-REF(ZPH,1))/REF(ZPH,1)*100)*180/3.14159;
趋向:=ZXH;
中分:=ZPH;
牛熊:=ZNX;
切割线:=ZQS;
分水岭:=EMA(牛熊,1);
去科创板:=IF(CODELIKE('688'),0,1);
XG:CROSS(分水岭,切割线);

举报

扔鸡蛋(0) 回复

红花绿叶配
Lv.3
发表于 2020-8-24 07:20 复制 查看全部楼层
许昌舍得 发表于 2020-8-23 21:58
N:=5;
M:=6;
VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;

好的,感谢老师!

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-8-23 21:58 复制 查看全部楼层
雨石100 发表于 2020-8-23 21:45
ATAN函数漂移比较严重,建议不用。

N:=5;
M:=6;
VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
B:=SMA(VAR1,N,1);
VAR2:=SMA(B,M,1);
绝路航标:=IF(CROSS(B,VAR2) AND B<40,50,0);


A1:=REF(C,1)<REF(O,1);
A2:=REF(C,2)>REF(O,2) AND REF(C,1)<REF(C,2);
A3:=REF(C,2)<REF(O,2) AND REF(C,1)<REF(O,2);
AA:=A1 OR A2 OR A3;
B1:=C>O AND C>REF(H,1);
B2:=ABS((REF(V,1)-LLV(V,N))/LLV(V,N))<=0.1;
B3:=V/REF(V,1)>=1.8;
BB:=B1 AND B2 AND B3;
倍量:=AA AND BB;
{去掉ST}
SS2:=IF(NAMELIKE('S'),0,1);
SS3:=IF(NAMELIKE('*'),0,1);
{去掉停牌}
SS4:=DYNAINFO(17)>0;
{去掉亏损与连续亏损}
SS5:=FINDSTR(FGBLOCK,'连续亏损');
SS6:=FINDSTR(FGBLOCK,'亏损股');
股本:=CAPITAL<20000000 ;
S1:=IF(CODELIKE('300'),0,1);
S2:=FINANCE(1)/10000000<=200;
股价:=S2 AND C<30  AND S1;
涨幅:=C/REF(C,1)>1.01 AND C/REF(C,1)<1.07;
ZIF:=EMA(C,12)-EMA(C,26);
ZEA:=EMA(ZIF,9);
ZBC:=2*(ZIF-ZEA);
ZJS:=1.25*ZIF-0.25*ZEA;
ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28;
ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28;
ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28;
ZNX:=(ZXH+ZQS)/2,COLORMAGENTA;
ZJD:=ATAN((ZPH-REF(ZPH,1))/REF(ZPH,1)*100)*180/3.14159;
趋向:=ZXH;
中分:=ZPH;
牛熊:=ZNX;
切割线:=ZQS;
分水岭:=EMA(牛熊,1);
去科创板:=IF(CODELIKE('688'),0,1);
XG:CROSS(分水岭,切割线) AND 绝路航标;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

雨石100
Lv.3
发表于 2020-8-23 21:45 复制 查看全部楼层
ATAN函数漂移比较严重,建议不用。

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表