手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助根据幅图指标做个兄弟连的选股器(条件附后)

[通达信]
设置
2116 3 同程者 Lv.3 发表于 · 2020-9-1 07:39 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
虚:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚,0,(-1),(-1)),COLOR00C0C0;
实:VOL,VOLSTICK;
V4:MA(实,4),COLORWHITE;
V10:MA(实,10),COLORMAGENTA,LINETHICK;
V90:MA(实,90),,COLORRED,LINETHICK2;
几倍:=1.9;
倍量:=实>=REF(实,1)*2;
天量:=实=HHV(实,0);
量比:=V/REF(MA(V,5),1) COLORBLUE;
量王:天量&&倍量&&量比>3&&(BARSCOUNT(C)+1)>120,COLORGREEN;
YH3:=量王;
X_1:=REF(CLOSE,1);
X_2:=VOL<MA(VOL,60)/3 OR VOL<CAPITAL*0.005;
STICKLINE(VOL/REF(VOL,1)>=0.97 AND VOL/REF(VOL,1)<=1.03,VOL,0,0.85,0),COLORWHITE;
STICKLINE(CLOSE>OPEN AND REF(CLOSE,1)<REF(OPEN,1) AND HIGH<REF(OPEN,1) AND CLOSE<(REF(OPEN,1)-REF(CLOSE,1))/3+REF(CLOSE,1),VOL,0,0.57,0),COLORGREEN;
STICKLINE(OPEN>CLOSE AND CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>=REF(OPEN,1),VOL,0,0.57,0),COLORRED;
今夕比:实/REF(实,1),COLORYELLOW;
季量比:实/MA(VOL,60),COLORMAGENTA;
量本比:10000*VOL/FINANCE(7),COLORRED;
买卖比:DYNAINFO(23)/DYNAINFO(22);
百低比:VOL/REF(LLV(VOL,100),1),NODRAW;
量能饱和度:IF(AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))>1,1,AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20)))*100,NODRAW,COLORYELLOW;
X_3:=1*AMOUNT;
X_4:=HHV(X_3,10)=X_3;
X_5:=HHV(X_3,30)=X_3;
X_6:=HHV(X_3,60)=X_3;
X_7:=HHV(X_3,100)=X_3;
X_8:=HHV(X_3,250)=X_3;
X_9:=X_4 OR X_5 OR X_6 OR X_7 OR X_8 AND CAPITAL/1000000<=35 AND CLOSE>REF(CLOSE,1);
STICKLINE(X_9,VOL,VOL*5/7,1.97,0),COLORYELLOW;
X_10:=VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)>=REF(VOL,3) AND REF(VOL,3)>=REF(VOL,4) AND VOL>0;
X_11:=CLOSE>REF(OPEN,1) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,1)>=(REF(CLOSE,2)+REF(OPEN,2))/2 OR (REF(CLOSE,1)>=(REF(CLOSE,3)+REF(OPEN,3))/2 AND REF(CLOSE,3)>REF(OPEN,3)) AND HIGH>LOW);
STICKLINE(VOL<MA(VOL,60)*1/3,VOL,0,1.17,0),COLORMAGENTA;
X_12:=(OPEN-CLOSE)/OPEN>=0.04 AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5));
DRAWICON(VOL/REF(VOL,1)>1.95 AND VOL/REF(VOL,1)<=6 AND (CLOSE>OPEN OR (CLOSE<OPEN AND CLOSE>=REF(CLOSE,1))),VOL*1.0027,1);
DRAWICON(VOL/REF(VOL,1)>1.95 AND VOL/REF(VOL,1)<=2.02 AND (CLOSE>OPEN OR (CLOSE<OPEN AND CLOSE>=REF(CLOSE,1))),0,41);
DRAWICON(VOL/REF(VOL,1)<=0.51 AND HIGH>LOW,VOL*0.87,2);
STICKLINE(FILTER(VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND CLOSE>OPEN,2),VOL,VOL*8/9,1.97,0),COLORMAGENTA;
STICKLINE(FILTER(VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND HIGH>LOW,2),VOL,VOL*7/9,1.97,0),COLORBROWN;
X_13:=REF(VOL,6)>REF(VOL,5) AND REF(VOL,6)>REF(VOL,4) AND REF(VOL,6)>REF(VOL,3) AND REF(VOL,6)>REF(VOL,2) AND REF(VOL,6)>REF(VOL,1);
X_14:=REF(VOL,5)>REF(VOL,4) AND REF(VOL,5)>REF(VOL,3) AND REF(VOL,5)>REF(VOL,2) AND REF(VOL,5)>REF(VOL,1);
X_15:=REF(VOL,4)>REF(VOL,3) AND REF(VOL,4)>REF(VOL,2) AND REF(VOL,4)>REF(VOL,1);
X_16:=REF(VOL,6)/VOL>=0.97 AND REF(VOL,6)/VOL<=1.03;
X_17:=REF(VOL,5)/VOL>=0.97 AND REF(VOL,5)/VOL<=1.03;
X_18:=REF(VOL,4)/VOL>=0.97 AND REF(VOL,4)/VOL<=1.03;
DRAWICON(X_13 AND X_16 OR (X_14 AND X_17) OR (X_15 AND X_18),VOL*0.93,41);
DRAWICON((OPEN-CLOSE)/OPEN>=0.04 AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5)),VOL*1.0158,39);
DRAWICON((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 AND (VOL<=MA(VOL,60) OR VOL/REF(VOL,1)<=1.2 OR VOL<HHV(VOL,5)) AND HIGH>LOW,VOL*1.0159,38);
DRAWICON(X_10 AND X_11,0,38);
DRAWICON(VOL<REF(LLV(VOL,100),1) AND HIGH>LOW,VOL*1.0359,23);
DRAWICON(COUNT(X_12,3) AND VOL<REF(LLV(VOL,20),1) AND HIGH>LOW,VOL*1.095,17);
X_19:=HHV(VOL,3)<REF(VOL,3);
X_20:=LLV(LOW,3)>REF(OPEN,3) AND REF(CLOSE,3)>REF(OPEN,3) AND CLOSE>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,3) AND REF(CLOSE,1)>REF(OPEN,3) AND HIGH>LOW AND CLOSE>OPEN;
X_21:=X_19 AND X_20;
DRAWICON(X_21,0,10);

选股器条件如下:
1.选出今日柱顶有红三角图标的量柱
2.选出昨日柱芯是竖的红芯图标的量柱
同时满足以上2个条件选股
例如8月17日 和8月18日太平鸟 的组合图例
本主题由 任务系统 于 2020-9-1 07:46 审核通过

相关股票

举报

扔鸡蛋(0) 回复

同程者
Lv.3
发表于 2020-9-1 18:05 复制 查看全部楼层
追牛服 发表于 2020-9-1 11:15
X_10:=VOL=REF(VOL,4) AND VOL>0;
X_11:=CLOSE>REF(OPEN,1) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(CLOS ...

不是同一天出现红芯和红三角信号,是分别2天出现信号

举报

点亮(0) 扔鸡蛋(0) 回复

同程者
Lv.3
发表于 2020-9-1 18:03 复制 查看全部楼层
追牛服 发表于 2020-9-1 11:15
X_10:=VOL=REF(VOL,4) AND VOL>0;
X_11:=CLOSE>REF(OPEN,1) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(CLOS ...

兄弟,选股不对的
是昨日红芯柱,今日红三角
红芯柱和红三角分别是2日的
如8月17和8月18 的太平鸟这样组合出现,才符合条件

举报

点亮(0) 扔鸡蛋(0) 回复

追牛服
Lv.3
发表于 2020-9-1 11:15 复制 查看全部楼层

X_10:=VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)>=REF(VOL,3) AND REF(VOL,3)>=REF(VOL,4) AND VOL>0;
X_11:=CLOSE>REF(OPEN,1) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,1)>=(REF(CLOSE,2)+REF(OPEN,2))/2 OR (REF(CLOSE,1)>=(REF(CLOSE,3)+REF(OPEN,3))/2 AND REF(CLOSE,3)>REF(OPEN,3)) AND HIGH>LOW);
X_12:=(OPEN-CLOSE)/OPEN>=0.04 AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5));
X_13:=REF(VOL,6)>REF(VOL,5) AND REF(VOL,6)>REF(VOL,4) AND REF(VOL,6)>REF(VOL,3) AND REF(VOL,6)>REF(VOL,2) AND REF(VOL,6)>REF(VOL,1);
X_14:=REF(VOL,5)>REF(VOL,4) AND REF(VOL,5)>REF(VOL,3) AND REF(VOL,5)>REF(VOL,2) AND REF(VOL,5)>REF(VOL,1);
X_15:=REF(VOL,4)>REF(VOL,3) AND REF(VOL,4)>REF(VOL,2) AND REF(VOL,4)>REF(VOL,1);
X_16:=REF(VOL,6)/VOL>=0.97 AND REF(VOL,6)/VOL<=1.03;
X_17:=REF(VOL,5)/VOL>=0.97 AND REF(VOL,5)/VOL<=1.03;
X_18:=REF(VOL,4)/VOL>=0.97 AND REF(VOL,4)/VOL<=1.03;
红柱:=OPEN>CLOSE AND CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>=REF(OPEN,1),,COLORRED;
三角:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 AND (VOL<=MA(VOL,60) OR VOL/REF(VOL,1)<=1.2 OR VOL<HHV(VOL,5)) AND HIGH>LOW,,;
红三角:红柱 AND 三角;




费了九牛二虎之力
查看全部打赏
  • 雄仔大哥+2共享币 : 感谢交流,感恩分享,收获正能量。
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表