手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这个KDJ反推公式加一条线

[通达信]
设置
2031 5 牧狼人1981 Lv.2 发表于 · 2020-9-25 00:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{J1 最小-50 最大120 缺省-50}
N:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;

K1:=1/3*RSV+REF(K,1)/3*2;
D1:=1/3*K+REF(D,1)/3*2;
JJ:=3*K1-2*D1;

J11:=J;J昨:=REF(JJ,1);JX:=IF(J1=-50,J11,IF(J1=-49,J昨,J1));
XXX:((9/7*JX-2*REF(K1,1)+12/7*REF(D1,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9),COLORRED;

老师这个是咱们论坛里赵鑫鑫老师的一个公式,是J值的反推也就是公式里的XXX,我想要加一条KDJ里面的K=50值反推 。

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-9-25 10:23 复制 查看全部楼层
牧狼人1981 发表于 2020-9-25 10:11
老师能否帮忙修改下。
求 KDJ的K值=50时候对应价格的输出。

现在的公式就是根据你说的条件修改的。

举报

扔鸡蛋(0) 回复

牧狼人1981
Lv.2
发表于 2020-9-25 10:11 复制 查看全部楼层
益阳龙 发表于 2020-9-25 08:04
楼上的反推不对

KDJ.J=49.95;

老师能否帮忙修改下。
求 KDJ的K值=50时候对应价格的输出。

举报

点亮(0) 扔鸡蛋(0) 回复

牧狼人1981
Lv.2
发表于 2020-9-25 10:10 复制 查看全部楼层
许昌舍得 发表于 2020-9-25 06:07
J1:=50;
N:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

老师好像有偏差。
求 KDJ的K值=50时候对应价格的输出。
能帮我再修改下吗

举报

点亮(0) 扔鸡蛋(0) 回复

益阳龙
Lv.4
发表于 2020-9-25 08:04 复制 查看全部楼层
本帖最后由 益阳龙 于 2020-9-25 08:08 编辑

楼上的反推不对

KDJ.J<=50.5 AND KDJ.J>=49.95;
这个选出接近50的一看就知道。与收盘价相差太远


001.JPG 1.JPG

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-9-25 06:07 复制 查看全部楼层
J1:=50;
N:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;

K1:=1/3*RSV+REF(50,1)/3*2;
D1:=1/3*50+REF(D,1)/3*2;
JJ:=3*K1-2*D1;

J11:=J;
J昨:=REF(JJ,1);
JX:=IF(J1=-50,J11,IF(J1=-49,J昨,J1));
XXX:((9/7*JX-2*REF(K1,1)+12/7*REF(D1,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9),COLORRED;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表