手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙将其改成选股公式

[通达信]
设置
2086 3 感谢好人 Lv.2 发表于 · 2020-9-26 17:49 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;
MA5:=EMA(EMA(C,5),3);
VAR1:=CLOSE-LLV(L,9);
VAR2:=HHV(H,9)-LLV(L,9);
VAR3:=(VAR1+0.00001)/VAR2*100;
VAR4:=EMA(EMA(VAR3,5),5);
VAR5:=EMA((0.668*REF(MA5,1)+0.333*MA5),1);
VAR6:=EMA((0.668*REF(VAR4,1)+0.333*VAR4),1);
VAR7:=IF(VAR4>VAR6,1,-1);
VAR8:=IF(C>MA5 AND MA5>VAR5 AND VAR4>50 AND VAR4>VAR6,1,-1);
STICKLINE(C>O,C,O,-1,0),COLORLIGRAY;
STICKLINE(C>O,L,H,0,0),COLORLIGRAY;
STICKLINE(C<O,C,O,-1,0),COLORWHITE;
STICKLINE(C<O,L,H,0,0),COLORWHITE;
STICKLINE(C=O AND C>REF(C,1),C,O,-1,0),COLORLIGRAY;
STICKLINE(C=O AND C>REF(C,1),L,H,0,0),COLORLIGRAY;
STICKLINE(C=O AND C<REF(C,1),C,O,-1,0),COLORWHITE;
STICKLINE(C=O AND C<REF(C,1),L,H,0,0),COLORWHITE;
STICKLINE(VAR7=1 AND C>O,C,O,-1,0),COLORRED;
STICKLINE(VAR7=1 AND C>O,L,H,0,0),COLORRED;
STICKLINE(VAR7=1 AND C<O,C,O,-1,0),COLORLIBLUE;
STICKLINE(VAR7=1 AND C<O,L,H,0,0),COLORLIBLUE;
STICKLINE(VAR7=1 AND C=O AND C>REF(C,1),C,O,-1,0),COLORRED;
STICKLINE(VAR7=1 AND C=O AND C>REF(C,1),L,H,0,0),COLORRED;
STICKLINE(VAR7=1 AND C=O AND C<REF(C,1),C,O,-1,0),COLORLIBLUE;
STICKLINE(VAR7=1 AND C=O AND C<REF(C,1),L,H,0,0),COLORLIBLUE;

STICKLINE(C>MA5 AND MA5>VAR5,C,O,-1,0),COLORRED;
STICKLINE(C>MA5 AND MA5>VAR5,L,H,0,0),COLORRED;
STICKLINE(C>MA5 AND MA5>VAR5,C,O,-1,0),COLORC08080;
STICKLINE(C>MA5 AND MA5>VAR5,L,H,0,0),COLORC08080;
STICKLINE(C>MA5 AND MA5>VAR5 AND C>REF(C,1),C,O,-1,0),COLORRED;
STICKLINE(C>MA5 AND MA5>VAR5 AND C>REF(C,1),L,H,0,0),COLORRED;
STICKLINE(C>MA5 AND MA5>VAR5 AND C<REF(C,1),C,O,-1,0),COLORC08080;
STICKLINE(C>MA5 AND MA5>VAR5 AND C<REF(C,1),L,H,0,0),COLORC08080;

STICKLINE(VAR8=1 AND C>O,C,O,-1,0),COLORMAGENTA;
STICKLINE(VAR8=1 AND C>O,L,H,0,0),COLORMAGENTA;
STICKLINE(VAR8=1 AND C<O,C,O,-1,0),COLORLIGREEN;
STICKLINE(VAR8=1 AND C<O,L,H,0,0),COLORLIGREEN;
STICKLINE(VAR8=1 AND C=O AND C>REF(C,1),C,O,-1,0),COLORMAGENTA;
STICKLINE(VAR8=1 AND C=O AND C>REF(C,1),L,H,0,0),COLORMAGENTA;
STICKLINE(VAR8=1 AND C=O AND C<REF(C,1),C,O,-1,0),COLORLIGREEN;
STICKLINE(VAR8=1 AND C=O AND C<REF(C,1),L,H,0,0),COLORLIGREEN;
DRAWBAND(VAR5,RGB(0,205,0),MA5,RGB(205,0,0));


请老师帮忙做2个选股公式:
1.绿色飘带首次变成红色飘带的选股
2.只要在红色飘带上方的股票都选出来

附件

绿变红当天的选股

绿变红当天的选股

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-9-26 18:24 复制 查看全部楼层
感谢好人 发表于 2020-9-26 18:18
太感谢舍得老师了,麻烦您把  只要是红色飘带上方的票都选出来 再做个选股


红带上的条件



MA5:=EMA(EMA(C,5),3);
VAR1:=CLOSE-LLV(L,9);
VAR2:=HHV(H,9)-LLV(L,9);
VAR3:=(VAR1+0.00001)/VAR2*100;
VAR4:=EMA(EMA(VAR3,5),5);
VAR5:=EMA((0.668*REF(MA5,1)+0.333*MA5),1);

TJ:(C>VAR5) AND VAR5<MA5 ;
查看全部打赏
  • 感谢好人+2理想币 +2共享币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

感谢好人
Lv.2
发表于 2020-9-26 18:18 复制 查看全部楼层
许昌舍得 发表于 2020-9-26 18:03
MA5:=EMA(EMA(C,5),3);
VAR1:=CLOSE-LLV(L,9);
VAR2:=HHV(H,9)-LLV(L,9);

太感谢舍得老师了,麻烦您把  只要是红色飘带上方的票都选出来 再做个选股  

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-9-26 18:03 复制 查看全部楼层
MA5:=EMA(EMA(C,5),3);
VAR1:=CLOSE-LLV(L,9);
VAR2:=HHV(H,9)-LLV(L,9);
VAR3:=(VAR1+0.00001)/VAR2*100;
VAR4:=EMA(EMA(VAR3,5),5);
VAR5:=EMA((0.668*REF(MA5,1)+0.333*MA5),1);

TJ:CROSS(C,VAR5) AND VAR5<MA5 AND CROSS(MA5,VAR5);
查看全部打赏
  • 感谢好人+2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表