手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股公式

[通达信]
设置
1934 2 一路丶向北 Lv.3 发表于 · 2020-10-2 00:30 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
出现准,绿柱时候的选股公式~! 不胜感激! 谢谢老师们!

N:25  P1:4  P2:5   M:20  SHORT:21   LONG:44  量1  额2  换手3
{快慢线}
底线:0,LINETHICK1,COLORMAGENTA;
高位:80,LINETHICK1,COLORMAGENTA;
低位:20,LINETHICK1,COLORMAGENTA;
VARR1:=LLV(LOW,P1);
VARR2:=HHV(HIGH,P1);
K: EMA((CLOSE-VARR1)/(VARR2-VARR1)*100,P2),COLORGREEN,LINETHICK1;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORRED,LINETHICK1;
{洗盘再买}
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
准备:=IF(黄金 AND RSVV<VARB2-2,10,0),COLORGREEN,NODRAW;
STICKLINE(准备,0,10,1,0),COLORGREEN;
DRAWTEXT(准备>0,13.6,'准'),COLORGREEN;
准备1:=REF(准备,1) OR REF(准备,2) OR REF(准备,3) OR 准备;
买:=CROSS(K,D) AND 准备1,COLORRED,NODRAW;
STICKLINE(买,0,10,1,0),COLORRED;
DRAWTEXT(买>0,13.6,'买'),COLORRED;

{建仓买点}
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0),STICK,COLORRED;
VARM1:=SMA(最佳买入选股,3,1);
VARM2:=SMA(VARM1,3,1),COLOR0000FF;
VARM3:=SMA(VARM2,3,1),COLOR00FFFF;
共振:=IF(CROSS(VARM2,VARM3) AND (VARM2<40),5,0*10000),COLORCYAN,NODRAW;
STICKLINE(共振,20,30,2,0),COLORCYAN;

举报

扔鸡蛋(0) 回复

龍在天
Lv.3
发表于 2020-10-2 11:09 复制 查看全部楼层

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-10-2 03:00 复制 查看全部楼层
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
准备:=IF(黄金 AND RSVV<VARB2-2,10,0);
DRAWTEXT(准备>0,13.6,'准'),COLORGREEN;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表