手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把指标改成选股公式

[通达信]
设置
1437 2 华2120 Lv.3 发表于 · 2020-10-11 12:18 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老师们帮忙指标改成选股公式中线和上线同时上穿上上线,指标原码ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
      AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
      通1:=AA*102/100;
      通2:=AA*(200-102)/100;
      CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
      DD:=DMA(CLOSE,CC);
      上:(1+7/100)*DD,DOTLINE,COLORGREEN;
      下:(1-7/100)*DD,DOTLINE,COLORGREEN;
      中:(上+下)/2,DOTLINE,COLORGREEN;
      上上:EMA(上,181),DOTLINE,COLORRED;
      下下:EMA(下,181),DOTLINE,COLORRED;
      中中:EMA(中,181),DOTLINE,COLORRED;
      STICKLINE(上>=上上,上,上上,0,0),COLORRED;
      DRAWKLINE(H,O,L,C);
      {IF((上 <= REF(上,1)),上,DRAWNULL),COLORGREEN,DOTLINE;
      IF((上 > REF(上,1)),上,DRAWNULL),COLORRED,DOTLINE;
      IF((中 <= REF(中,1)),中,DRAWNULL),COLORGREEN,DOTLINE;
      IF((中 > REF(中,1)),中,DRAWNULL),COLORRED,DOTLINE;
      IF((下 <= REF(下,1)),下,DRAWNULL),COLORGREEN,DOTLINE;
      IF((下 > REF(下,1)),下,DRAWNULL),COLORRED,LINETHICK2;}
      顶:=(1+14/100)*DD,LINETHICK2,COLORBLACK;
      底:=(1-14/100)*DD,LINETHICK2,COLORBLACK;
      触底:=REF(L,1)<底 AND ZT ;
      DRAWTEXT(触底,L,'反转'),COLORCYAN;
      STICKLINE(触底,C,O,3,1),COLORYELLOW;
      STICKLINE(触底,C,O,1,0),COLORRED;
      DF:=(C-REF(C,1))/REF(C,1)*100<-5;
      DF4:=(C-O)/O*100<-4;
      AAAA:=BARSLAST(DF);
      乖离涨停1:=H>上 AND ZT AND CROSS(C,上);
      DRAWTEXT(乖离涨停1,L,'爆'),COLORYELLOW;
      STICKLINE(乖离涨停1,C,O,3,1),COLORYELLOW;
      乖离涨停2:=O>上 AND ZT;
      STICKLINE(乖离涨停2,C,O,3,1),COLORCYAN;
      DRAWTEXT(乖离涨停2,L,'妖股'),COLORCYAN;

附件

中线上穿上上线选股

中线上穿上上线选股

举报

扔鸡蛋(0) 回复

华2120
Lv.3
发表于 2020-10-11 15:33 复制 查看全部楼层
老师那下线,中线,上线同时上穿上上线怎么改呀、谢谢。

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-11 12:44 复制 查看全部楼层
     CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
       DD:=DMA(CLOSE,CC);
       上:=(1+7/100)*DD,;
       下:=(1-7/100)*DD;
       中:=(上+下)/2;
       上上:=EMA(上,181);
       下下:=EMA(下,181);
       中中:=EMA(中,181);

TJ:CROSS(   上,上上) AND CROSS( 中,上上);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表