手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股公式

[通达信]
设置
1113 2 顺顺999 Lv.2 发表于 · 2020-10-11 15:16 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
NOTEXT1:=HHV(EMA(C,17),2);
NOTEXT2:EMA(C,17),LINETHICK3,COLORRED;
NOTEXT3:IF(((NOTEXT1 = NOTEXT2) AND UPNDAY(NOTEXT1,3)),NOTEXT1,DRAWNULL),LINETHICK3,COLORRED;
NOTEXT4:IF((REF(NOTEXT1,2) > NOTEXT2),NOTEXT2,DRAWNULL),LINETHICK3,COLORGREEN;
LC:=REF(CLOSE,1);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSI:=((SMA(MAX((CLOSE - LC),0),9,1) / SMA(ABS((CLOSE - LC)),9,1)) * 100);
DBTJ1:=(RSI >= 75);
DBTJ2:=(J >= 95);
B1:=(EMA(CLOSE,12) - EMA(CLOSE,26));
B2:=EMA(B1,3);
ZF:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
RSI1:=((SMA(MAX((CLOSE - LC),0),9,1) / SMA(ABS((CLOSE - LC)),9,1)) * 100);
TDSZ:=(((((((B1 > B2) OR (B1 = B2)) AND (ZF > 9)) AND (ZF < 11)) AND (40 < RSI1)) AND (RSI1 < 60)) AND (C = H));
RSV13:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
B11:=SMA(RSV13,4,1);
B22:=SMA(B11,3,1);
CDTJ:=(((C >= O) AND CROSS(B11,B22)) AND (B22 <= 50));
TOPB:=IF(((DBTJ1 OR DBTJ2) AND (((C + NOTEXT2) / 2) < NOTEXT2)),(((3 * NOTEXT2) - C) / 2),((C + NOTEXT2) / 2));
BOTB:=IF(((CDTJ OR TDSZ) AND (((C + NOTEXT2) / 2) > NOTEXT2)),(((3 * NOTEXT2) - C) / 2),((C + NOTEXT2) / 2));
STICKLINE((((NOT(DBTJ1) AND NOT(DBTJ2)) AND NOT(CDTJ)) AND NOT(TDSZ)),NOTEXT2,(NOTEXT2 * 1.009),2.3,0),COLORA4A4A4;
STICKLINE((((NOT(DBTJ1) AND NOT(DBTJ2)) AND NOT(CDTJ)) AND NOT(TDSZ)),NOTEXT2,(NOTEXT2 * 1.009),2,0),COLORB6B6B6;
STICKLINE((((NOT(DBTJ1) AND NOT(DBTJ2)) AND NOT(CDTJ)) AND NOT(TDSZ)),NOTEXT2,(NOTEXT2 * 1.009),1.7,0),COLORB8B8B8;
STICKLINE((((NOT(DBTJ1) AND NOT(DBTJ2)) AND NOT(CDTJ)) AND NOT(TDSZ)),NOTEXT2,(NOTEXT2 * 1.009),1.4,0),COLORCACACA;
STICKLINE((((NOT(DBTJ1) AND NOT(DBTJ2)) AND NOT(CDTJ)) AND NOT(TDSZ)),NOTEXT2,(NOTEXT2 * 1.009),1.1,0),COLORF4F4F4;
STICKLINE((((NOT(DBTJ1) AND NOT(DBTJ2)) AND NOT(CDTJ)) AND NOT(TDSZ)),NOTEXT2,(NOTEXT2 * 1.009),0.8,0),COLORF6F6F6;
STICKLINE((RSI >= 75),NOTEXT2,TOPB,2.3,0),COLOR000057;
STICKLINE((RSI >= 75),NOTEXT2,TOPB,2,0),COLOR00007D;
STICKLINE((RSI >= 75),NOTEXT2,TOPB,1.7,0),COLOR00008C;
STICKLINE((RSI >= 75),NOTEXT2,TOPB,1.4,0),COLOR0000A1;
STICKLINE((RSI >= 75),NOTEXT2,TOPB,1.1,0),COLOR0000B5;
STICKLINE((RSI >= 75),NOTEXT2,TOPB,0.8,0),COLOR0000CC;
STICKLINE((J >= 95),NOTEXT2,TOPB,2.3,0),COLOR570057;
STICKLINE((J >= 95),NOTEXT2,TOPB,2,0),COLOR660066;
STICKLINE((J >= 95),NOTEXT2,TOPB,1.7,0),COLOR7D007D;
STICKLINE((J >= 95),NOTEXT2,TOPB,1.4,0),COLOR990099;
STICKLINE((J >= 95),NOTEXT2,TOPB,1.1,0),COLORBD00BD;
STICKLINE((J >= 95),NOTEXT2,TOPB,0.8,0),COLORMAGENTA;
STICKLINE(CDTJ,NOTEXT2,BOTB,2.3,0),COLOR004040;
STICKLINE(CDTJ,NOTEXT2,BOTB,2,0),COLOR006464;
STICKLINE(CDTJ,NOTEXT2,BOTB,1.7,0),COLOR00A8A8;
STICKLINE(CDTJ,NOTEXT2,BOTB,1.4,0),COLOR00DBDB;
STICKLINE(CDTJ,NOTEXT2,BOTB,1.1,0),COLOR15FFFF;
STICKLINE(CDTJ,NOTEXT2,BOTB,0.8,0),COLOR4DFFFF;
STICKLINE(TDSZ,NOTEXT2,(BOTB * 0.98),2,0),COLORCYAN;
STICKLINE(TDSZ,NOTEXT2,(BOTB * 0.98),1.5,0),COLOR990000;
STICKLINE(TDSZ,NOTEXT2,(BOTB * 0.98),1.8,0),COLORCC0000;
STICKLINE(TDSZ,NOTEXT2,(BOTB * 0.98),0.3,0),COLORFF4400;
STICKLINE(TDSZ,NOTEXT2,(BOTB * 0.98),2,0),COLORFF8800;
STICKLINE(TDSZ,NOTEXT2,(BOTB * 0.98),1.5,0),COLORFFCC00;
STICKLINE(TDSZ,NOTEXT2,(BOTB * 0.98),0.8,0),COLORCYAN;


请老师帮忙  出现黄柱时做个选股公式 谢谢!

举报

扔鸡蛋(0) 回复

顺顺999
Lv.2
发表于 2020-10-11 16:05 复制 查看全部楼层
@许昌舍得 谢谢老师

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-11 15:34 复制 查看全部楼层

NOTEXT1:=HHV(EMA(C,17),2);
NOTEXT2:=EMA(C,17),LINETHICK3,COLORRED;
NOTEXT3:=IF(((NOTEXT1 = NOTEXT2) AND UPNDAY(NOTEXT1,3)),NOTEXT1,DRAWNULL),LINETHICK3,COLORRED;
NOTEXT4:=IF((REF(NOTEXT1,2) > NOTEXT2),NOTEXT2,DRAWNULL),LINETHICK3,COLORGREEN;
LC:=REF(CLOSE,1);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSI:=((SMA(MAX((CLOSE - LC),0),9,1) / SMA(ABS((CLOSE - LC)),9,1)) * 100);
DBTJ1:=(RSI >= 75);
DBTJ2:=(J >= 95);
B1:=(EMA(CLOSE,12) - EMA(CLOSE,26));
B2:=EMA(B1,3);
ZF:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
RSI1:=((SMA(MAX((CLOSE - LC),0),9,1) / SMA(ABS((CLOSE - LC)),9,1)) * 100);
TDSZ:=(((((((B1 > B2) OR (B1 = B2)) AND (ZF > 9)) AND (ZF < 11)) AND (40 < RSI1)) AND (RSI1 < 60)) AND (C = H));
RSV13:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
B11:=SMA(RSV13,4,1);
B22:=SMA(B11,3,1);
CDTJ:=(((C >= O) AND CROSS(B11,B22)) AND (B22 <= 50));
TOPB:=IF(((DBTJ1 OR DBTJ2) AND (((C + NOTEXT2) / 2) < NOTEXT2)),(((3 * NOTEXT2) - C) / 2),((C + NOTEXT2) / 2));
BOTB:=IF(((CDTJ OR TDSZ) AND (((C + NOTEXT2) / 2) > NOTEXT2)),(((3 * NOTEXT2) - C) / 2),((C + NOTEXT2) / 2));


XG:CDTJ;

附件

tdxjietu5.JPG

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表