手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这两个指标合并做成选股公式

[通达信]
设置
1387 2 烧刀子 Lv.3 发表于 · 2020-10-11 15:27 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
公式1:自适应均线主图源码
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
AMA1:EMA(DMA(CLOSE,CQ1),2) ,COLORWHITE;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
AMA2:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK2;
AMA3:IF(AMA2/REF(AMA2,1)>0.997,AMA2,DRAWNULL),COLORBLUE,LINETHICK2;
AMA4:IF(AMA2/REF(AMA2,1)>1.001,AMA2,DRAWNULL),COLORRED,LINETHICK2;

公式2:价格以大于45°角上穿MA5,去ST,去停牌。

MA5:=MA(C,5);
JD:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
去TP:=DYNAINFO(8)>0;
去ST:=NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S'));
XG:CROSS(C,MA5) AND C>=O AND JD>45  AND 去ST AND 去TP;

要求:做成选股公式价格以大于45°上穿公式1的AMA1。

如哪位老师能解决,这里非常感谢!!!

举报

扔鸡蛋(0) 回复

想好再说
Lv.2
发表于 2020-10-11 18:37 复制 查看全部楼层
本帖最后由 想好再说 于 2020-10-11 18:38 编辑
注册111 发表于 2020-10-11 16:22
试试
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);


注册111老师好!指标改写的很棒!学习了。同时也感谢烧刀子的分享!

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-10-11 16:22 复制 查看全部楼层
试试
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
AMA1:=EMA(DMA(CLOSE,CQ1),2) ;
JD:=ATAN((AMA1/REF(AMA1,1)-1)*100)*180/3.1416;
去TP:=DYNAINFO(8)>0;
去ST:=NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S'));
XG:CROSS(C,AMA1) AND C>=O AND JD>45  AND 去ST AND 去TP;
查看全部打赏
  • 烧刀子+10理想币 +2共享币 : 为表示老师的答疑,特此感谢

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表