手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把指标改成条件选股

[通达信]
设置
1713 9 华2120 Lv.3 发表于 · 2020-10-11 17:30 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦、各位老师把指标改成条件选股,下线,中线,上线同时上穿上上线。指标原码;ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
      AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
      通1:=AA*102/100;
      通2:=AA*(200-102)/100;
      CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
      DD:=DMA(CLOSE,CC);
      上:(1+7/100)*DD,DOTLINE,COLORGREEN;
      下:(1-7/100)*DD,DOTLINE,COLORGREEN;
      中:(上+下)/2,DOTLINE,COLORGREEN;
      上上:EMA(上,181),DOTLINE,COLORRED;
      下下:EMA(下,181),DOTLINE,COLORRED;
      中中:EMA(中,181),DOTLINE,COLORRED;
      STICKLINE(上>=上上,上,上上,0,0),COLORRED;
      DRAWKLINE(H,O,L,C);
      {IF((上 <= REF(上,1)),上,DRAWNULL),COLORGREEN,DOTLINE;
      IF((上 > REF(上,1)),上,DRAWNULL),COLORRED,DOTLINE;
      IF((中 <= REF(中,1)),中,DRAWNULL),COLORGREEN,DOTLINE;
      IF((中 > REF(中,1)),中,DRAWNULL),COLORRED,DOTLINE;
      IF((下 <= REF(下,1)),下,DRAWNULL),COLORGREEN,DOTLINE;
      IF((下 > REF(下,1)),下,DRAWNULL),COLORRED,LINETHICK2;}
      顶:=(1+14/100)*DD,LINETHICK2,COLORBLACK;
      底:=(1-14/100)*DD,LINETHICK2,COLORBLACK;
      触底:=REF(L,1)<底 AND ZT ;
      DRAWTEXT(触底,L,'反转'),COLORCYAN;
      STICKLINE(触底,C,O,3,1),COLORYELLOW;
      STICKLINE(触底,C,O,1,0),COLORRED;
      DF:=(C-REF(C,1))/REF(C,1)*100<-5;
      DF4:=(C-O)/O*100<-4;
      AAAA:=BARSLAST(DF);
      乖离涨停1:=H>上 AND ZT AND CROSS(C,上);
      DRAWTEXT(乖离涨停1,L,'爆'),COLORYELLOW;
      STICKLINE(乖离涨停1,C,O,3,1),COLORYELLOW;
      乖离涨停2:=O>上 AND ZT;
      STICKLINE(乖离涨停2,C,O,3,1),COLORCYAN;
      DRAWTEXT(乖离涨停2,L,'妖股'),COLORCYAN;

附件

下线,中线,上线同时上穿上上线

下线,中线,上线同时上穿上上线

举报

扔鸡蛋(0) 回复

华2120
Lv.3
发表于 2020-10-17 20:19 复制 查看全部楼层
是的,很难出现。

举报

扔鸡蛋(0) 回复

加薪哥
Lv.2
发表于 2020-10-17 16:29 复制 查看全部楼层
楼主,你好。我用了这个选股,11月1号到11月16号,就选了一只,300850新强联来,你也是吗?谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

彭元伦
Lv.2
发表于 2020-10-17 00:03 复制 查看全部楼层
华2120 发表于 2020-10-16 07:51
谢谢、老师的帮忙。

非常感谢,老师辛苦了!

举报

扔鸡蛋(0) 回复

华2120
Lv.3
发表于 2020-10-16 07:51 复制 查看全部楼层
许昌舍得 发表于 2020-10-11 17:41
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
       通1:=AA*102/100;
       通2:=AA*(200-102)/100;

谢谢、老师的帮忙。

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-10-13 08:58 复制 查看全部楼层

也可以用作预警。

举报

扔鸡蛋(0) 回复

彭元伦
Lv.2
发表于 2020-10-13 02:04 复制 查看全部楼层
彭元伦 发表于 2020-10-13 02:04
可以改成预警吗?

谢谢老师!

举报

扔鸡蛋(0) 回复

彭元伦
Lv.2
发表于 2020-10-13 02:04 复制 查看全部楼层
勤学务实 发表于 2020-10-11 17:44
{选股,下线,中线,上线同时上穿上上线}

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

可以改成预警吗?

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-10-11 17:44 复制 查看全部楼层
{选股,下线,中线,上线同时上穿上上线}

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:= (1+7/100)*DD;
下:= (1-7/100)*DD;
中:= (上+下)/2;
上上:= EMA(上,181);
XG: CROSS(上,上上) && CROSS(中,上上) && CROSS(下,上上);

举报

点亮(2) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-11 17:41 复制 查看全部楼层
    AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
       通1:=AA*102/100;
       通2:=AA*(200-102)/100;
       CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
       DD:=DMA(CLOSE,CC);
       上:=(1+7/100)*DD;
       下:=(1-7/100)*DD;
       中:=(上+下)/2,;
       上上:=EMA(上,181);
     
TJ:CROSS(上,上上) AND CROSS(中,上上) AND CROSS(下,上上);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表