手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助合并两个公式并且增加一个条件(今天是倍量柱)

[通达信]
设置
1044 2 陕西周公 Lv.3 发表于 · 2020-10-11 20:58 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
A00:=SUM(IF((C> REF(C,1)),VOL,IF((C<REF(C,1)),(0-V),0)),0);
A01:=SUMBARS(V,CAPITAL);
A02:=IF((C>LLV(C,A01)),1,(0-1))*IF((A00 >LLV(A00,A01)),1,(0-1));
A03:=(COUNT((IF((A02=(0-1)),1,0)=1),8)>2);
A04:=((C-DMA((((3 * H + L)+O)+2 * C)/7.000,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100))/DMA((((3*H+L)+O)+2*C)/7,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100)*100<(0-18));
A05:=((C-MIN(REF(C,5)*0.865,REF(C,21)*0.772))/C<0.009);
A06:=((A03 AND A04) AND A05);
A07:=((((O < EMA(C,5)) AND (C/O>=1.05)) AND (V/CAPITAL>=0.019)) AND (V/CAPITAL<=0.2));
A08:=(A07 AND (COUNT(A07,5)=1));
A0901:=MA(C,3)>REF(MA(C,3),1);
A0902:=MA(C,5)>REF(MA(C,5),1);
A0903:=MA(C,10)>REF(MA(C,10),1);
A0904:=V/240>REF(V,30)*1.200/240.000*1.500;
A0905:=C>L*1.059;
A0906:=C>REF(MA(C,3),1);
A0907:=A0901 AND A0902 AND A0903 AND A0904 AND A0905 AND A0906;
A0908:=A0907 AND REF(C,1);
A0909:=MA(C,20)>REF(MA(C,20),1);
A0910:=MA(V,5)>REF(MA(V,5),1);
A0911:=MA(C,5)-MA(C,10);
A0912:=A0911<= 0.579;
A09:=A0908 AND A0902 AND A0903 AND A0909 AND A0910 AND A0912;A0A:=FILTER(A09,5.000);
VBB:(A06 OR A07) AND A0A;



ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(HIGH+OPEN+LOW+(2)*(CLOSE))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(MMB,MMC);
主进主轨;



增加条件  今天量柱比昨天大2倍


谢谢老师

举报

扔鸡蛋(0) 回复

陕西周公
Lv.3
发表于 2020-10-11 21:57 复制 查看全部楼层
勤学务实 发表于 2020-10-11 21:17
{主图}
A00:=SUM(IF((C> REF(C,1)),VOL,IF((CLLV(C,A01)),1,(0-1))*IF((A00 >LLV(A00,A01)),1,(0-1));
  ...

谢谢老师 不好意思 你的共享币只能打进去2个

举报

点亮(0) 扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-11 21:17 复制 查看全部楼层
{主图}
A00:=SUM(IF((C> REF(C,1)),VOL,IF((C<REF(C,1)),(0-V),0)),0);
A01:=SUMBARS(V,CAPITAL);
A02:=IF((C>LLV(C,A01)),1,(0-1))*IF((A00 >LLV(A00,A01)),1,(0-1));
A03:=(COUNT((IF((A02=(0-1)),1,0)=1),8)>2);
A04:=((C-DMA((((3 * H + L)+O)+2 * C)/7.000,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100))/DMA((((3*H+L)+O)+2*C)/7,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100)*100<(0-18));
A05:=((C-MIN(REF(C,5)*0.865,REF(C,21)*0.772))/C<0.009);
A06:=((A03 AND A04) AND A05);
A07:=((((O < EMA(C,5)) AND (C/O>=1.05)) AND (V/CAPITAL>=0.019)) AND (V/CAPITAL<=0.2));
A08:=(A07 AND (COUNT(A07,5)=1));
A0901:=MA(C,3)>REF(MA(C,3),1);
A0902:=MA(C,5)>REF(MA(C,5),1);
A0903:=MA(C,10)>REF(MA(C,10),1);
A0904:=V/240>REF(V,30)*1.200/240.000*1.500;
A0905:=C>L*1.059;
A0906:=C>REF(MA(C,3),1);
A0907:=A0901 AND A0902 AND A0903 AND A0904 AND A0905 AND A0906;
A0908:=A0907 AND REF(C,1);
A0909:=MA(C,20)>REF(MA(C,20),1);
A0910:=MA(V,5)>REF(MA(V,5),1);
A0911:=MA(C,5)-MA(C,10);
A0912:=A0911<= 0.579;
A09:=A0908 AND A0902 AND A0903 AND A0909 AND A0910 AND A0912;A0A:=FILTER(A09,5.000);
VBB:=(A06 OR A07) AND A0A;
ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
A:=((VOL)/(CAPITAL))*(100);
S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X:=1;
V1:=(HIGH+OPEN+LOW+(2)*(CLOSE))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(MMB,MMC);
XG:(A06 OR A07) && A0A && 主进主轨 && REF(V,0)>REF(V,1)*2;
DRAWICON(XG,H*1.1,1);

{选股}
A00:=SUM(IF((C> REF(C,1)),VOL,IF((C<REF(C,1)),(0-V),0)),0);
A01:=SUMBARS(V,CAPITAL);
A02:=IF((C>LLV(C,A01)),1,(0-1))*IF((A00 >LLV(A00,A01)),1,(0-1));
A03:=(COUNT((IF((A02=(0-1)),1,0)=1),8)>2);
A04:=((C-DMA((((3 * H + L)+O)+2 * C)/7.000,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100))/DMA((((3*H+L)+O)+2*C)/7,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100)*100<(0-18));
A05:=((C-MIN(REF(C,5)*0.865,REF(C,21)*0.772))/C<0.009);
A06:=((A03 AND A04) AND A05);
A07:=((((O < EMA(C,5)) AND (C/O>=1.05)) AND (V/CAPITAL>=0.019)) AND (V/CAPITAL<=0.2));
A08:=(A07 AND (COUNT(A07,5)=1));
A0901:=MA(C,3)>REF(MA(C,3),1);
A0902:=MA(C,5)>REF(MA(C,5),1);
A0903:=MA(C,10)>REF(MA(C,10),1);
A0904:=V/240>REF(V,30)*1.200/240.000*1.500;
A0905:=C>L*1.059;
A0906:=C>REF(MA(C,3),1);
A0907:=A0901 AND A0902 AND A0903 AND A0904 AND A0905 AND A0906;
A0908:=A0907 AND REF(C,1);
A0909:=MA(C,20)>REF(MA(C,20),1);
A0910:=MA(V,5)>REF(MA(V,5),1);
A0911:=MA(C,5)-MA(C,10);
A0912:=A0911<= 0.579;
A09:=A0908 AND A0902 AND A0903 AND A0909 AND A0910 AND A0912;A0A:=FILTER(A09,5.000);
VBB:=(A06 OR A07) AND A0A;

ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MMA:=C-REF(C,1);
MMB:=100*EMA(EMA(MMA,9),9)/EMA(EMA(ABS(MMA),9),9);
MMC:=MA(MMB,5);
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(MMB,MMC);
XG:(A06 OR A07) && A0A && 主进主轨 && REF(V,0)>REF(V,1)*2;
查看全部打赏
  • 陕西周公+10理想币 +2共享币 : 很给力,投资愉快,理想因你而精彩;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表