手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

原贴不能编辑,重发打包请猪猪离线和汽油瓶大师进贴指导,求解,易语言5.9,精易模...

设置
3272 10 牛顿的家乡 Lv.3 发表于 · 2020-10-12 07:20 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 str, 文本型
.局部变量 json, 类_json
.局部变量 成员数, 整数型
.局部变量 i, 整数型
.局部变量 表项索引, 整数型
.局部变量 cookie, 文本型
.局部变量 tt, 逻辑型


' str = 编码_utf8到gb2312 (网页_取网页源码 (“http://push2.55188.com/api/qt/cl ... amp;fs=m:0+t:6+f:!2,m:0+t:13+f:!2,m:0+t:80+f:!2,m:1+t:2+f:!2,m:1+t:23+f:!2,m:0+t:7+f:!2,m:1+t:3+f:!2&stat=1&fields=f12,f14,f2,f3,f62,f184,f66,f69,f72,f75,f78,f81,f84,f87,f204,f205,f124&rt=?&cb=jQuery?&_=?”))
' COOKIE=
str = 编码_utf8到gb2312 (网页_取网页源码 (“http://push2.55188.com/api/qt/cl ... amp;fs=m:0+t:6+f:!2,m:0+t:13+f:!2,m:0+t:80+f:!2,m:1+t:2+f:!2,m:1+t:23+f:!2,m:0+t:7+f:!2,m:1+t:3+f:!2&stat=1&fields=f12,f14,f2,f3,f62,f184,f66,f69,f72,f75,f78,f81,f84,f87,f204,f205,f124&rt=53413408&cb=jQuery18303921204492050998_1602402232362&_=1602402251155”))
' 调试输出 (str)
tt = json.解析 (str)
' 调试输出 (str)
网页_置Cookie ()
成员数 = json.取属性 (“data”).成员数 ()  ' 到这里出问题了
' 调试输出 (成员数)
.计次循环首 (成员数, i)
    表项索引 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (表项索引, 0, 到文本 (i))
    超级列表框1.置标题 (表项索引, 1, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f12”))
    超级列表框1.置标题 (表项索引, 2, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f14”))
    超级列表框1.置标题 (表项索引, 3, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f2”))
    超级列表框1.置标题 (表项索引, 4, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f3”))
    超级列表框1.置标题 (表项索引, 5, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f62”))
    超级列表框1.置标题 (表项索引, 6, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f184”))
    超级列表框1.置标题 (表项索引, 7, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f66”))
    超级列表框1.置标题 (表项索引, 8, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f69”))
    超级列表框1.置标题 (表项索引, 9, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f72”))
    超级列表框1.置标题 (表项索引, 10, json.取通用属性 (“data.diff[” + 到文本 (i - 1) + “].f75”))
.计次循环尾 ()




'源码文本   jQuery?({"rc":0,"rt":6,"svr":181735162,"lt":1,"full":1,"data":{"total":4159,"diff":[{"f2":61.44,"f3":7.54,"f12":"002475","f14":"立讯精密","f62":884575536.0,"f66":1033069088.0,"f69":13.61,"f72":-148493552.0,"f75":-1.96,"f78":-497976384.0,"f81":-6.56,"f84":-386599168.0,"f87":-5.09,"f124":1602228843,"f184":11.66,"f204":"-","f205":"-","f206":"-"}]}});   数组数据很多,就拷贝了一个


json解析  失败的原因是什么呢?请猪猪离线和汽油瓶大师指教,谢谢!

附件

大师帮忙.rar

1.07 MB, 下载次数: 9, 下载积分: 理想币 -1 个

打包的需解压再打开文件易语言5.9加精易模块

举报

扔鸡蛋(0) 回复

托尼2007
Lv.4
发表于 2020-10-19 16:37 复制 查看全部楼层
本帖最后由 托尼2007 于 2020-10-19 18:05 编辑


猪猪老师你好
之前在你的帖子里下了 行业地位采集和公司亮点采集。
但是没有找到采集大智慧的主营亮点和选股宝 题材亮点的采集的程序。
请问可以发一个么?谢谢
非常感谢

举报

点亮(0) 扔鸡蛋(0) 回复

雪客fvptk
Lv.4
发表于 2020-10-12 16:12 复制 查看全部楼层
猪猪大师一出手就知有没有!

举报

扔鸡蛋(0) 回复

股中游
Lv.6
发表于 2020-10-12 10:36 复制 查看全部楼层
牛顿的家乡 发表于 2020-10-12 09:54
股中游  易语言编程请教请教,求解

直接下载猪猪老师的附件,打开后就能用,还要什么帮忙?

举报

点亮(2) 扔鸡蛋(0) 回复

牛顿的家乡
Lv.3
发表于 2020-10-12 09:54 复制 查看全部楼层
股中游  易语言编程请教请教,求解

举报

扔鸡蛋(0) 回复

用心学股
Lv.4
发表于 2020-10-12 09:08 复制 查看全部楼层
感谢猪猪侠

举报

扔鸡蛋(0) 回复

股中游
Lv.6
发表于 2020-10-12 08:57 复制 查看全部楼层
牛顿的家乡 发表于 2020-10-12 08:52
猪猪侠,打包文件没问题吧!

我试过了没有问题,有问题的一定是人品出问题了.

举报

点亮(0) 扔鸡蛋(0) 回复

牛顿的家乡
Lv.3
发表于 2020-10-12 08:52 复制 查看全部楼层
猪猪侠,打包文件没问题吧!

举报

扔鸡蛋(0) 回复

王智wt
Lv.5
发表于 2020-10-12 08:48 复制 查看全部楼层

猪猪老师辛苦了!!!

举报

扔鸡蛋(0) 回复

猪猪离线
Lv.7
发表于 2020-10-12 08:10 复制 查看全部楼层
大师帮忙.rar (1.21 MB, 下载次数: 55)
查看全部打赏

举报

扔鸡蛋(0) 回复

股中游
Lv.6
发表于 2020-10-12 07:33 复制 查看全部楼层
本帖最后由 股中游 于 2020-10-12 08:13 编辑

哈哈,进来只是瞎看一下.
猪猪老师出马了.

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表