手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将同花顺指标改成通达信指标

[通达信]
设置
1116 4 草席王 Lv.2 发表于 · 2020-10-12 08:51 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦各位老师:把下面同花顺指标改成通达信指标,万分感谢!

//#@Fname=底部监测
//#@comment=
//#@control=
//#@FuncType=
//#@style=吸筹:Line0,,1,0,1,5,65535;庄家吸筹:Line0,,1,0,1,5,65535;散户:Line0,,2,0,1,5,16776960;庄家:Line0,,2,0,1,5,16711935;
//#@availperiod=2147430400
//#@param=
//#@isDrawCurve=1
//#@Fdesc=选出底部的股
//#@defaultperiod=16384
//#@coord=D
//#@ordinate=0,0.000000;0,0.000000;0,0.000000;0,0.000000;0,0.000000;0;0,0.000000
//#@@FUNCSPEC@=source
M:=55;
N:=34;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(85,RSI),75,'▼'),colorgreen;
VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(LOW,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
吸筹:IF(VAR8>100,100,VAR8)*VAR1,coloryellow;
庄家吸筹:STICKLINE(吸筹>-150,0,吸筹,8,0),coloryellow;
散户: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
庄家:EMA(J,6),COLORFF00FF,LINETHICK2;

相关股票

举报

扔鸡蛋(0) 回复

彭林炜
Lv.4
发表于 2020-10-12 11:54 复制 查看全部楼层
春秋哦 发表于 2020-10-12 11:38
老师 请帮忙写个 买字的选股 谢谢

{所属板块、概念}

MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买1:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
买:FILTER(买1=1,5);

举报

点亮(1) 扔鸡蛋(0) 回复

草席王
Lv.2
发表于 2020-10-12 11:41 复制 查看全部楼层
谢谢,万分感谢!

举报

扔鸡蛋(0) 回复

春秋哦
Lv.2
发表于 2020-10-12 11:38 复制 查看全部楼层
彭林炜 发表于 2020-10-12 11:04
M:=55;
N:=34;
LC:=REF(CLOSE,1);

老师 请帮忙写个 买字的选股 谢谢

{所属板块、概念}
DRAWTEXT_FIX(1,0.005,0,0,'所属风格:'),COLORRED;DRAWTEXT_FIX(1,0.06,0,0,FGBLOCK),COLORRED;
DRAWTEXT_FIX(1,0.005,0.06,0,'所属概念:'),COLORMAGENTA;DRAWTEXT_FIX(1,0.06,0.06,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.06,0.12,0,'WX:  DTSMXH178'),COLORMAGENTA;

BM:=EMA(C,2);
SM:=EMA(SLOPE(C,21)*22+C,42);
BU:=CROSS(BM,SM);
SEL:=CROSS(SM,BM);
DRAWICON(BU,L-0.05,1);
DRAWICON(SEL,H+0.03,2);
STICKLINE(BM>=SM,LOW,HIGH,0,1),COLORRED;
STICKLINE(BM>=SM,CLOSE,OPEN,3,1),COLORRED;
MA18:=MA(CLOSE,18);
MA13:MA(C,13),COLORGREEN,LINETHICK2;
VAR1:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR2:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);
{红}
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),COLOR0000FF;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{蓝}
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLORFF9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.5,0),COLORFFCC00;
{粉}
STICKLINE(VAR1,C,(O+C)/2,3,0),COLORFF11FF;  
STICKLINE(VAR1,C,(O+C)/2,0.5,0),COLORFFDDFF;
{灰}  
STICKLINE(VAR2,C,(O+C)/2,3,0),COLOR999999;   
STICKLINE(VAR2,C,(O+C)/2,0.5,0),COLORFFBBFF;
{绿}  
STICKLINE(VAR3,O,(O+C)/2,3,0),COLOR00BB00;
STICKLINE(VAR3,O,(O+C)/2,0.5,0),COLOR00FF00;
卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'卖'),COLORGREEN;
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'买'),COLORRED;
加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
DRAWTEXT(FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3),LOW-0.03,''),COLORWHITE;
跟:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(跟,LOW*0.96,'跟'),COLORCC66FF;

举报

点亮(1) 扔鸡蛋(0) 回复

彭林炜
Lv.4
发表于 2020-10-12 11:04 复制 查看全部楼层
M:=55;
N:=34;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(85,RSI),75,'▼'),colorgreen;
VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(LOW,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
吸筹:IF(VAR8>100,100,VAR8)*VAR1,coloryellow;
庄家吸筹:STICKLINE(吸筹>-150,0,吸筹,8,0),coloryellow;
散户: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
庄家:EMA(J,6),COLORFF00FF,LINETHICK2;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表