手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将通达信指标改写易博大师(以前有类似的贴)

[通达信]
设置
1463 2 福吉413 Lv.1 发表于 · 2020-10-12 09:59 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
这个指标,我从通达信放到易博里,提示我  KDJ.J  无效引用。如下公式(请前辈帮忙修改,先谢过!):【说明一下:易博大师里KDJ的参数是默认的9,3,3】

N:=14;
M:=84;
TYP:=(HIGH+LOW+CLOSE)/3;
C1:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
C2:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M));
注意了结:200,COLORRED;
底部区域:-150,COLORGREEN;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
买入时机: IF(CROSS(C1,-150),-150,-200),COLORred,LINETHICK1;
LL:=REF(CLOSE,1);
MM:=SMA(MAX(CLOSE-LL,0),6,1)/SMA(ABS(CLOSE-LL),6,1)*100;
分批出: IF(CROSS(80,MM),200,250),COLORCYAN,LINETHICK1;
牛启动: IF(CROSS(C2,-70),-100,-150),COLORGREEN,LINETHICK1;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(VAR3*10,3);
VAR5:=LLV(LOW,13);
VAR6:=HHV(VAR4,13);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618;
VAR9:=IF(VAR8>100,100,VAR8);
var10:=var9*10;

STICKLINE(VAR9>-120,0,VAR10,3,1);
STICKLINE(VAR9>1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2),0,VAR10,3,0),COLORRED;
STICKLINE(VAR9>0.1 AND VAR9<1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2),0,VAR10,3,0),COLOREE00EE;

举报

扔鸡蛋(0) 回复

福吉413
Lv.1
发表于 2020-10-12 18:29 复制 查看全部楼层
谢谢前辈!可用!!不知如何感谢,加你关注了

举报

点亮(0) 扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-10-12 14:55 复制 查看全部楼层
N:=14;
M:=84;
TYP:=(HIGH+LOW+CLOSE)/3;
C1:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
C2:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M));
注意了结:200,COLORRED;
底部区域:-150,COLORGREEN;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
买入时机: IF(CROSS(C1,-150),-150,-200),COLORred,LINETHICK1;
LL:=REF(CLOSE,1);
MM:=SMA(MAX(CLOSE-LL,0),6,1)/SMA(ABS(CLOSE-LL),6,1)*100;
分批出: IF(CROSS(80,MM),200,250),COLORCYAN,LINETHICK1;
牛启动: IF(CROSS(C2,-70),-100,-150),COLORGREEN,LINETHICK1;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(VAR3*10,3);
VAR5:=LLV(LOW,13);
VAR6:=HHV(VAR4,13);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618;
VAR9:=IF(VAR8>100,100,VAR8);
var10:=var9*10;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;


STICKLINE(VAR9>-120,0,VAR10,3,1);
STICKLINE(VAR9>1 AND j>REF(j,1) AND REF(j,1)<REF(j,2),0,VAR10,3,0),COLORRED;
STICKLINE(VAR9>0.1 AND VAR9<1 AND j>REF(j,1) AND REF(j,1)<REF(j,2),0,VAR10,3,0),COLOREE00EE;

试试看看行不行

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表