手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改成选股公式

[通达信]
设置
1294 9 感谢好人 Lv.2 发表于 · 2020-10-12 11:55 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,'逃顶'),COLORYELLOW;VAR1:=EMA(EMA(CLOSE,13),13);
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,COLORFFCCCC,POINTDOT;
STICKLINE(控盘<0,控盘,0,2,0),COLORWHITE;
无庄控盘:控盘<0,COLORWHITE;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,2,1),COLORRED;
有庄控盘: 控盘>REF(控盘,1) AND 控盘>0,COLORRED;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,2,0),COLOR00FF00;
主力出货: 控盘<REF(控盘,1) AND 控盘>0,COLOR00FF00;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,2,0),COLORFF00FF;
高度控盘: VAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLORFF00FF;
A10:=CROSS(控盘,0);
开始控盘:IF(A10,6,0),COLORYELLOW;
控盘天数:BARSLASTCOUNT(有庄控盘 OR 高度控盘 ),LINETHICK0,COLORWHITE;
出货天数:BARSLASTCOUNT(主力出货),LINETHICK0,COLORWHITE;

请老师帮忙写2个选股公式:
第1个.首次出现粉柱的票(如下图)
第2个.只要是粉柱的票都选出来(不配图)

附件

如图

如图

举报

扔鸡蛋(0) 回复

感谢好人
Lv.2
发表于 2020-10-12 14:43 复制 查看全部楼层
竹隐风雷 发表于 2020-10-12 14:36
再试试用哪个吧其他两个用等号等于掉

风雷老师辛苦了! 感谢您!

举报

扔鸡蛋(0) 回复

感谢好人
Lv.2
发表于 2020-10-12 14:43 复制 查看全部楼层
许昌舍得 发表于 2020-10-12 14:32
风雷老师已经给你写出来了

VAR1:=EMA(EMA(CLOSE,13),13);

明白了 感谢老师解答!

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-10-12 14:36 复制 查看全部楼层
感谢好人 发表于 2020-10-12 13:07
当前公式 : 条件1 (条件选股公式)  
错误句 :
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,COLORFFCC ...

再试试用哪个吧其他两个用等号等于掉

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-12 14:32 复制 查看全部楼层
感谢好人 发表于 2020-10-12 14:01
老师,有空的话能否再帮忙在写个  首次出现红柱的选股呀  麻烦您了 自己鼓捣了一下不行

风雷老师已经给你写出来了

VAR1:=EMA(EMA(CLOSE,13),13);
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
VAR2:=100*WINNER(CLOSE*0.95);
条件1:CROSS(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,0.5);

附件

tdxjietu2.JPG
查看全部打赏
  • 不点儿+10理想币 +10共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(2) 扔鸡蛋(0) 回复

感谢好人
Lv.2
发表于 2020-10-12 14:01 复制 查看全部楼层

老师,有空的话能否再帮忙在写个  首次出现红柱的选股呀  麻烦您了 自己鼓捣了一下不行

举报

点亮(1) 扔鸡蛋(0) 回复

感谢好人
Lv.2
发表于 2020-10-12 13:40 复制 查看全部楼层

好了 感谢老师!

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-10-12 13:28 复制 查看全部楼层
感谢好人 发表于 2020-10-12 13:07
当前公式 : 条件1 (条件选股公式)  
错误句 :
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,COLORFFCC ...

不好意思再试试

举报

扔鸡蛋(0) 回复

感谢好人
Lv.2
发表于 2020-10-12 13:07 复制 查看全部楼层
竹隐风雷 发表于 2020-10-12 12:58
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,COLORFFCCCC,POINTDOT;
VAR2 ...

当前公式 : 条件1 (条件选股公式)  
错误句 :
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,COLORFFCCCC,POINTDOT
详细信息 : 不是画线指标公式,不能指定画线类型!
错误起始位置 : 9 ; 长度: 3




老师通过不了 帮忙看看

举报

点亮(1) 扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-10-12 12:58 复制 查看全部楼层
本帖最后由 竹隐风雷 于 2020-10-12 14:32 编辑

VAR1:=EMA(EMA(CLOSE,13),13);
控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
VAR2:=100*WINNER(CLOSE*0.95);
条件1:CROSS(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,0.5);
条件2:VAR2>50 AND COST(85)<CLOSE AND 控盘>0;
条件3:cross(控盘>REF(控盘,1) AND 控盘>0,0.5);
查看全部打赏
  • 不点儿+10理想币 +10共享币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表