手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助给下面2个指标和谐一下

[通达信]
设置
1728 6 海角麦穗 Lv.4 发表于 · 2020-10-12 12:55 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DRAWKLINE(H,O,L,C);

V1:=MA(HIGH,30)*1.10;
V3:=MA(LOW,3)*0.98;
V4:=MA(LOW,30)*0.90;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND
REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND
REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2)
AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2)
AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2)
AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2)
AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'A'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'B'),COLORFFFF00;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.96,'C买'),COLORFFFF00;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.01,'(1)'),COLOR0000FF;
(DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.99,'(2)'))*100,COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.01,'(3)'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.99,'(4)'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.01,'(5)'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.95,'1短'),COLORFF6000;
DRAWTEXT(EX2 AND DTJD10=2,H*1.04,'2'),COLORFF6000;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.94,'3买'),COLORFF6000;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'一卖'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.98,'二补'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)
AND EX2,H*1.03,'三清'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'四持'),LINETHICK3,COLOR00FFFF;



A:=VOL*CLOSE;
B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,17);
主力突破:=(B-B1)*1500/B COLORRED,NODRAW;
XG:=主力突破>300;
DRAWICON(主力突破>300 AND NOT(L=H)AND 主力突破>REF(主力突破,1) ,主力突破,24);



举报

扔鸡蛋(0) 回复

加薪哥
Lv.2
发表于 2020-10-17 15:46 复制 查看全部楼层
许昌舍得 发表于 2020-10-12 14:25
风雷老师已经提醒你了

组合如下

许老师,你好!可以把这个组合做一个选股公式吗?当出现C买信号时选出股票来,谢谢老师。

举报

点亮(0) 扔鸡蛋(0) 回复

九州同庆
Lv.3
发表于 2020-10-12 16:45 复制 查看全部楼层
ZIG未来函数

举报

扔鸡蛋(0) 回复

海角麦穗
Lv.4
发表于 2020-10-12 15:16 复制 查看全部楼层
竹隐风雷 发表于 2020-10-12 13:32
第一个没啥用使用未来数据补上的也和谐不了如果觉得第二个好用直接用第二个就行

谢谢老师!明白

举报

扔鸡蛋(0) 回复

海角麦穗
Lv.4
发表于 2020-10-12 15:15 复制 查看全部楼层
许昌舍得 发表于 2020-10-12 14:25
风雷老师已经提醒你了

组合如下

好的收到 明白,谢谢老师!

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-12 14:25 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-10-12 14:27 编辑

风雷老师已经提醒你了

组合如下


DRAWKLINE(H,O,L,C);

V1:=MA(HIGH,30)*1.10;
V3:=MA(LOW,3)*0.98;
V4:=MA(LOW,30)*0.90;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND
REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND
REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2)
AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2)
AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2)
AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2)
AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'A'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'B'),COLORFFFF00;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.96,'C买'),COLORFFFF00;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.01,'(1)'),COLOR0000FF;
(DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.99,'(2)'))*100,COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.01,'(3)'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.99,'(4)'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.01,'(5)'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.95,'1短'),COLORFF6000;
DRAWTEXT(EX2 AND DTJD10=2,H*1.04,'2'),COLORFF6000;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.94,'3买'),COLORFF6000;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'一卖'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.98,'二补'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)
AND EX2,H*1.03,'三清'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'四持'),LINETHICK3,COLOR00FFFF;



A:=VOL*CLOSE;
B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,17);
主力突破:=(B-B1)*1500/B COLORRED,NODRAW;
XG:=主力突破>300;
DRAWICON(主力突破>300 AND NOT(L=H)AND 主力突破>REF(主力突破,1) ,H*1.02,24);

附件

tdxjietu1.JPG
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 海角麦穗+10理想币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(2) 扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-10-12 13:32 复制 查看全部楼层
第一个没啥用使用未来数据补上的也和谐不了如果觉得第二个好用直接用第二个就行
查看全部打赏
  • 海角麦穗+10理想币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表