手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙把通达信主图公式做个选股公式

[通达信]
设置
1609 12 常来常往- Lv.2 发表于 · 2020-10-13 08:41 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
参数有四:   最小    最大    缺省
       P     5       60      15
       GT     1       500     1
       DT     1       500     1
     半径     1       5       1





DRAWTEXT_FIX(ISLASTBAR ,0.5,0.9,0,' 波 段 圆 主 图 '),COLORYELLOW;
P1:=IF(PERIOD<5 OR PERIOD=8,60,P);
A1:=REF(H,2)=HHV(H,P1) AND REF(H,2)>MAX(REF(H,1),H);
B1:=FILTER(A1,2);
C1:=BACKSET(B1,3);
D1:=FILTER(C1,2);{高点}
A2:=REF(L,2)=LLV(L,P1) AND REF(L,2)<MIN(REF(L,1),L);
B2:=FILTER(A2,2);
C2:=BACKSET(B2,3);
D2:=FILTER(C2,2);{低点}
E1:=(REF(LLV(LOW,2*2),1)+REF(HHV(HIGH,2*2),1))/2;
E02:=(HIGH+LOW)/2; {高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT((D2 AND E1>=E02))) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT((D1 AND E1<E02)));
H2:=D1 AND NOT((D2 AND E1>=E02));
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}
DRAWICON(LD,L*0.99,1);
DRAWICON(HD,H*1.01,2);
BDH:=REF(H,BARSLAST(HD));
BDL:=REF(L,BARSLAST(LD));
R11:=BACKSET(ISLASTBAR,BARSLAST(HD)+GT);
S11:=R11>REF(R11,1); {高}
T11:=BACKSET(ISLASTBAR,BARSLAST(LD)+DT);
U11:=T11>REF(T11,1); {低}
高点:REF(H,BARSLAST(S11)),COLOR00FF00;
低点:REF(L,BARSLAST(U11)),COLORFFCC00;
低天:=CONST(BARSLAST(U11));
高天:=CONST(BARSLAST(S11));
CURR:=CURRBARSCOUNT;
DRAWLINE(U11,L,S11,H,0),COLORYELLOW;
DRAWLINE(S11,H,U11,L,0),COLORWHITE;
SH:=CONST(高点);
SL:=CONST(低点);
高低差:=SH-SL;
天距:=ABS(低天-高天);
PR:=(高天+低天)/2;
RN:=(SH+SL)/2;
Y弧:=(SH*SL);
BX:=2*(SH*SL)/天距;
BY:=(SH*SL)/高低差;
XW:=IF(CURR<PR,PR-CURR,CURR-PR)*BX;
SY:=IF(XW<Y弧,SQRT(Y弧*Y弧-XW*XW),0)/BY/半径;
YX1:RN+SY,COLOR00FFFF;
YX2:RN-SY,COLOR00FFFF;


当股价突破绿色线,做一个选股公式,谢谢

附件

888888888888888.JPG

举报

扔鸡蛋(0) 回复

加薪哥
Lv.2
发表于 2020-10-19 01:46 复制 查看全部楼层
常来常往- 发表于 2020-10-18 18:57
主图和选股参数全部设置成参数
   最小    最大    缺省
       P     5       60      15

常来常往,你好,把第一行参数改成5   60   15  ,选出来的还是跟原来一样,不过就都在绿线了,谢谢!!

举报

点亮(0) 扔鸡蛋(0) 回复

常来常往-
Lv.2
发表于 2020-10-18 18:57 复制 查看全部楼层
常来常往- 发表于 2020-10-18 18:53
主图和选股的参数要设置成一样的,看一下是不是参数的原因

主图和选股参数全部设置成参数
   最小    最大    缺省
       P     5       60      15
       GT     1       500     1
       DT     1       500     1
     半径     1       5       1



也可以,只是大周期,小周期的区别

举报

点亮(0) 扔鸡蛋(0) 回复

常来常往-
Lv.2
发表于 2020-10-18 18:53 复制 查看全部楼层
加薪哥 发表于 2020-10-18 11:09
常来常往,你好。谢谢你的指点,已经安装好了,按照许昌舍得老师的选股方法,10月15号选股60支,有一半都 ...

主图和选股的参数要设置成一样的,看一下是不是参数的原因

附件

555555555555555555.png
66666666666666.png

举报

点亮(0) 扔鸡蛋(0) 回复

加薪哥
Lv.2
发表于 2020-10-18 11:09 复制 查看全部楼层
常来常往- 发表于 2020-10-17 20:48
把参数填一下就可以了,试一下

常来常往,你好。谢谢你的指点,已经安装好了,按照许昌舍得老师的选股方法,10月15号选股60支,有一半都没到突破绿线,10月16号选股50支,到绿线的也不多,是不是我哪里搞错了呢?

举报

点亮(0) 扔鸡蛋(0) 回复

常来常往-
Lv.2
发表于 2020-10-17 20:48 复制 查看全部楼层
加薪哥 发表于 2020-10-17 15:00
常来常往,你好!你的主图源码,我安装怎么提示有错误呢,错误句 :
P1:=IF(PERIOD

把参数填一下就可以了,试一下 搜狗截图20201017204505.png

举报

点亮(0) 扔鸡蛋(0) 回复

加薪哥
Lv.2
发表于 2020-10-17 15:00 复制 查看全部楼层

常来常往,你好!你的主图源码,我安装怎么提示有错误呢,错误句 :
P1:=IF(PERIOD<5 OR PERIOD=8,60,P)
详细信息 : 未知字符串 P
错误起始位置 : 94 ; 长度: 1
我也想使用你的这个指标看股票和选股票的,请你指导指导。谢谢!!

举报

点亮(0) 扔鸡蛋(0) 回复

怒风烈焰
Lv.4
发表于 2020-10-14 08:26 复制 查看全部楼层

谢谢老师指导见笑了

举报

扔鸡蛋(0) 回复

怒风烈焰
Lv.4
发表于 2020-10-14 08:26 复制 查看全部楼层
谢谢楼主分享公式和思路,我斗胆学着许昌舍得老师写了一个穿越低点的,希望对你能有帮助

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-14 08:19 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-10-14 08:31 编辑
怒风烈焰 发表于 2020-10-14 08:16
老师我想改成穿越低点蓝线的选股改成如下写法正确吗?
P:=15;
       GT:=1;



或最后一句  改为
XG2:=CROSS(C>低点,0.5);

举报

点亮(0) 扔鸡蛋(0) 回复

怒风烈焰
Lv.4
发表于 2020-10-14 08:16 复制 查看全部楼层
许昌舍得 发表于 2020-10-13 09:42
P:=15;
       GT:=1;
       DT:=1;

老师我想改成穿越低点蓝线的选股改成如下写法正确吗?
P:=15;
       GT:=1;
       DT:=1;
     半径:=1;






P1:=IF(PERIOD<5 OR PERIOD=8,60,P);
A1:=REF(H,2)=HHV(H,P1) AND REF(H,2)>MAX(REF(H,1),H);
B1:=FILTER(A1,2);
C1:=BACKSET(B1,3);
D1:=FILTER(C1,2);{高点}
A2:=REF(L,2)=LLV(L,P1) AND REF(L,2)<MIN(REF(L,1),L);
B2:=FILTER(A2,2);
C2:=BACKSET(B2,3);
D2:=FILTER(C2,2);{低点}
E1:=(REF(LLV(LOW,2*2),1)+REF(HHV(HIGH,2*2),1))/2;
E02:=(HIGH+LOW)/2; {高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT((D2 AND E1>=E02))) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT((D1 AND E1<E02)));
H2:=D1 AND NOT((D2 AND E1>=E02));
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}

BDH:=REF(H,BARSLAST(HD));
BDL:=REF(L,BARSLAST(LD));
T11:=BACKSET(ISLASTBAR,BARSLAST(LD)+DT);
U11:=T11>REF(T11,1); {低}

低点:=REF(L,BARSLAST(U11)),COLORFFCC00;


XG:CROSS(C,低点);

举报

点亮(0) 扔鸡蛋(0) 回复

常来常往-
Lv.2
发表于 2020-10-13 10:00 复制 查看全部楼层
谢谢,非常感谢

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-13 09:42 复制 查看全部楼层

       P:=15;
       GT:=1;
       DT:=1;
     半径:=1;






P1:=IF(PERIOD<5 OR PERIOD=8,60,P);
A1:=REF(H,2)=HHV(H,P1) AND REF(H,2)>MAX(REF(H,1),H);
B1:=FILTER(A1,2);
C1:=BACKSET(B1,3);
D1:=FILTER(C1,2);{高点}
A2:=REF(L,2)=LLV(L,P1) AND REF(L,2)<MIN(REF(L,1),L);
B2:=FILTER(A2,2);
C2:=BACKSET(B2,3);
D2:=FILTER(C2,2);{低点}
E1:=(REF(LLV(LOW,2*2),1)+REF(HHV(HIGH,2*2),1))/2;
E02:=(HIGH+LOW)/2; {高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT((D2 AND E1>=E02))) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT((D1 AND E1<E02)));
H2:=D1 AND NOT((D2 AND E1>=E02));
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}

BDH:=REF(H,BARSLAST(HD));
BDL:=REF(L,BARSLAST(LD));
R11:=BACKSET(ISLASTBAR,BARSLAST(HD)+GT);
S11:=R11>REF(R11,1); {高}

高点:=REF(H,BARSLAST(S11)),COLOR00FF00;


XG:CROSS(C,高点);

附件

tdxjietu11.JPG
查看全部打赏
  • 常来常往-+1理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表