手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

涨跌幅变为20%后的涨停、跌停K线标识公式

[同花顺]
设置
7010 16 暖冰Yeah Lv.3 发表于 · 2020-10-14 10:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
自己有一个非常好用和准确的涨跌停K线标识公式,公式可以自动区分老涨停(10%)和新涨停(20%),还可以标识炸板和撬板。
但是通达信的。

有没有高手可以改为同花顺的?




{K线图着重显示涨跌停}
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
XA_1:=IF(DATE<=1200823,1,0);
旧涨停:=(C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1;
旧跌停:=(C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1;
涨停:=C>=ZTPRICE(REF(C,1),BK) AND C=H;
跌停:=C<=DTPRICE(REF(C,1),BK) AND C=L;
曾涨停:=(H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1);
曾跌停:=(L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1);
STICKLINE(旧涨停 AND PERIOD=5,O,C,4,0),COLORYELLOW;
STICKLINE(旧跌停 AND PERIOD=5,O,C,4,0),COLORGREEN;
STICKLINE(涨停 AND PERIOD=5,C,O,4,0),COLORYELLOW;
STICKLINE(跌停 AND PERIOD=5,C,O,4,0),COLORGREEN;
STICKLINE(曾涨停 AND PERIOD=5,H,L,0.1,0),COLORYELLOW;{涨停后回落}
STICKLINE(曾跌停 AND PERIOD=5,L,H,0.1,0),COLORGREEN;{跌停后回升}
DRAWTEXT(旧涨停 AND PERIOD=5,L-0.1,'涨停'),COLORYELLOW;
DRAWTEXT(旧跌停 AND PERIOD=5,H+0.2,'跌停'),COLORGREEN;
DRAWTEXT(涨停 AND PERIOD=5,L-0.1,'涨停'),COLORYELLOW;
DRAWTEXT(跌停 AND PERIOD=5,H+0.2,'跌停'),COLORGREEN;
DRAWTEXT(曾涨停 AND PERIOD=5,H+0.2,'炸板'),COLORGREEN;
DRAWTEXT(曾跌停 AND PERIOD=5,L-0.1,'撬板'),COLORYELLOW;

举报

扔鸡蛋(0) 回复

马789
Lv.4
发表于 2020-10-21 08:46 复制 查看全部楼层

非常感谢,还标注出了假阳线和假阴线

举报

点亮(1) 扔鸡蛋(0) 回复

暖冰Yeah
Lv.3
发表于 2020-10-21 08:23 复制 查看全部楼层
黑色的幽灵 发表于 2020-10-20 16:11
IF(PERIODNAME>"日线")
RETURN;

非常感谢,还标注出了假阳线和假阴线,赞~~

举报

点亮(1) 扔鸡蛋(0) 回复

黑色的幽灵
Lv.2
发表于 2020-10-20 16:11 复制 查看全部楼层
暖冰Yeah 发表于 2020-10-20 13:47
能不能加上只在日线适用的条件限制?

IF(PERIODNAME>"日线")
RETURN;

CON1:=C>=O AND C>=REF(C,1);
CON2:=C<O AND C>=REF(C,1);
CON3:=C<=O AND C<REF(C,1);
CON4:=C>O AND C<REF(C,1);

STICKLINE(CON1,H,C,1,0),RGB(221,11,11);
STICKLINE(CON1,C,O,9,0),RGB(221,11,11);
STICKLINE(CON1,L,O,1,0),RGB(221,11,11);
STICKLINE(CON4,H,C,1,1),RGB(221,11,11);
STICKLINE(CON4,C,O,9,1),RGB(221,11,11);
STICKLINE(CON4,L,O,1,1),RGB(221,11,11);

STICKLINE(CON2,H,O,1,1),colorcyan;
STICKLINE(CON2,C,O,9,1),colorcyan;
STICKLINE(CON2,L,C,1,1),colorcyan;
STICKLINE(CON3,H,O,1,0),colorcyan;
STICKLINE(CON3,C,O,9,0),colorcyan;
STICKLINE(CON3,L,C,1,0),colorcyan;


涨幅20:=IF((CODE>=300000 AND CODE<400000 AND DATE>20200823) OR CODE>688000 ,1,0);
BARPOS:=BARSCOUNT(CLOSE);
涨停价:IF(BARPOS>5 OR 涨幅20,IF(涨幅20,INTPART((1.2*REF(C,1)+0.005)*100)/100,INTPART((1.1*REF(C,1)+0.005) *100)/100),10000),NODRAW;
跌停价:IF(BARPOS>5 OR 涨幅20,IF(涨幅20,INTPART((0.8*REF(C,1)+0.005)*100)/100,INTPART((0.9*REF(C,1)+0.005) *100)/100),10000),NODRAW;
ZT:=(涨停价-C)<=0;
DT:=(C-跌停价)=0;
CZT:=(涨停价-H)<=0;
CDT:=(L-跌停价)=0;


STICKLINE(ZT AND C=H,C,O,9,0),coloryellow;
STICKLINE(DT AND C=L,C,O,9,0),colorgreen;
DRAWTEXT(CZT AND C<H,H*1.01,'炸'),colorgreen;
DRAWTEXT(CDT AND C>L,L*0.99,'翘'),colorgreen;

举报

点亮(1) 扔鸡蛋(0) 回复

暖冰Yeah
Lv.3
发表于 2020-10-20 13:47 复制 查看全部楼层
黑色的幽灵 发表于 2020-10-19 21:05
日线和分钟线显示正常,大于日线上,就比较尴尬了。。。

能不能加上只在日线适用的条件限制?

举报

扔鸡蛋(0) 回复

黑色的幽灵
Lv.2
发表于 2020-10-19 21:05 复制 查看全部楼层
黑色的幽灵 发表于 2020-10-19 21:03
开盘:O,Colored; CON1:=C>=O AND C>=REF(C,1); CON2:=C=REF(C,1); CON3:=C688000 ,1,0); BARPOS:=BARSCOUNT ...

日线和分钟线显示正常,大于日线上,就比较尴尬了。。。

举报

点亮(1) 扔鸡蛋(0) 回复

黑色的幽灵
Lv.2
发表于 2020-10-19 21:03 复制 查看全部楼层
开盘:O,Colored; CON1:=C>=O AND C>=REF(C,1); CON2:=C<O AND C>=REF(C,1); CON3:=C<=O AND C<REF(C,1); CON4:=C>O AND C<REF(C,1);  STICKLINE(CON1,H,C,1,0),RGB(221,11,11); STICKLINE(CON1,C,O,9,0),RGB(221,11,11); STICKLINE(CON1,L,O,1,0),RGB(221,11,11); STICKLINE(CON4,H,C,1,1),RGB(221,11,11); STICKLINE(CON4,C,O,9,1),RGB(221,11,11); STICKLINE(CON4,L,O,1,1),RGB(221,11,11);  STICKLINE(CON2,H,O,1,1),colorcyan; STICKLINE(CON2,C,O,9,1),colorcyan; STICKLINE(CON2,L,C,1,1),colorcyan; STICKLINE(CON3,H,O,1,0),colorcyan; STICKLINE(CON3,C,O,9,0),colorcyan; STICKLINE(CON3,L,C,1,0),colorcyan;   涨幅20:=IF((CODE>=300000 AND CODE<400000 AND DATE>20200823) OR CODE>688000 ,1,0); BARPOS:=BARSCOUNT(CLOSE); 涨停价:IF(BARPOS>5 OR 涨幅20,IF(涨幅20,INTPART((1.2*REF(C,1)+0.005)*100)/100,INTPART((1.1*REF(C,1)+0.005) *100)/100),10000),NODRAW; 跌停价:IF(BARPOS>5 OR 涨幅20,IF(涨幅20,INTPART((0.8*REF(C,1)+0.005)*100)/100,INTPART((0.9*REF(C,1)+0.005) *100)/100),10000),NODRAW; ZT:=(涨停价-C)<=0; DT:=(C-跌停价)=0; CZT:=(涨停价-H)<=0; CDT:=(L-跌停价)=0;   STICKLINE(ZT AND C=H,C,O,9,0),coloryellow; STICKLINE(DT AND C=L,C,O,9,0),colorgreen; DRAWTEXT(CZT AND C<H,H*1.01,'炸'),colorgreen; DRAWTEXT(CDT AND C>L,L*0.99,'翘'),colorgreen;

举报

扔鸡蛋(0) 回复

表狐
Lv.2
发表于 2020-10-16 20:12 复制 查看全部楼层
不好用,这么多柱子文字!

举报

扔鸡蛋(0) 回复

邢襄
Lv.4
发表于 2020-10-16 15:57 复制 查看全部楼层
好东西  已经用了  谢谢分享

举报

扔鸡蛋(0) 回复

诺言999
Lv.1
发表于 2020-10-15 22:23 复制 查看全部楼层
谢谢分享指标了

举报

扔鸡蛋(0) 回复

暖冰Yeah
Lv.3
发表于 2020-10-15 09:22 复制 查看全部楼层
我是为了求大神改成同花顺的,你们…………

举报

点亮(1) 扔鸡蛋(0) 回复

涨百伦
Lv.3
发表于 2020-10-14 19:51 复制 查看全部楼层
好东西  已经用了  谢谢分享

举报

扔鸡蛋(0) 回复

腹黑美女
Lv.2
发表于 2020-10-14 17:09 复制 查看全部楼层
这指标不错,已经用上了,感谢分享

举报

扔鸡蛋(0) 回复

缝骨刀
Lv.5
发表于 2020-10-14 16:13 复制 查看全部楼层
目测,不好用

举报

扔鸡蛋(0) 回复

大公无私1
Lv.3
发表于 2020-10-14 15:36 复制 查看全部楼层
没鸟用,白费劲

举报

扔鸡蛋(0) 回复

圆圆头
Lv.3
发表于 2020-10-14 15:35 复制 查看全部楼层
没鸟用,白费劲

举报

扔鸡蛋(0) 回复

股三多A
Lv.4
发表于 2020-10-14 12:15 复制 查看全部楼层
谢谢分享指标了~~~~~~~~~~~

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表