手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改写成选股公式

[通达信]
设置
1024 2 想好再说 Lv.2 发表于 · 2020-10-14 10:28 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老师好!请老师将此 主图指标 改写成选股指标,要求选出当天出现是黄柱的股票,谢谢!


{千金八卦}
突破:REF(EMA(C,10),1)COLORMAGENTA,LINETHICK1;
A1X:=(EMA(C,10)-突破)/突破*100,NODRAW;
出击:IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK1;
休假:IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK1;
STICKLINE(A1X>=0,出击,突破,0,-1)COLORRED;
STICKLINE(A1X<0,休假,突破,0,-1),COLORGREEN;
STICKLINE(CROSS(A1X,0),C,O,3,0)COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,3,0)COLORBLUE;
※:IF(A1X<0,突破,DRAWNULL)COLORGREEN,LINETHICK1;
DP:=REF(EMA(INDEXC,14),1);
DPX:=(EMA(INDEXC,14)-DP)/DP*100;
Z:=ISLASTBAR;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)>REF(O,1)&&C>O&&Z,0.98,0.2,1,'筑顶阶段. 阳阳阳①乾/天:阳极,防变'),COLORFF00FF;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)>REF(O,1)&&C<=O&&Z,0.98,0.2,1,'破位下跌. 阳阳阴②兑/泽:阳减,调整'),COLORFFFF00;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)<=REF(O,1)&&C>O&&Z,0.98,0.2,1,'上升启动. 阳阴阳③离/火:阳光,关注'),COLOR00FFFF;
DRAWTEXT_FIX(REF(C,2)>REF(O,2)&&REF(C,1)<=REF(O,1)&&C<=O&&Z,0.98,0.2,1,'主升段. 阳阴阴④震/雷:继阴,空仓'),COLORFF0000;
DRAWTEXT_FIX(REF(C,2)<=REF(O,2)&&REF(C,1)>REF(O,1)&&C>O&&Z,0.98,0.2,1,'快速波动. 阴阳阳⑤巽/风:继阳,持股'),COLORFF00FF;
DRAWTEXT_FIX(REF(C,2)<=REF(O,2)&&REF(C,1)>REF(O,1)&&C<=O&&Z,0.98,0.2,1,'主跌段. 阴阳阴⑥坎/水:阴风,看跌'),COLORFF0000;
DRAWTEXT_FIX(REF(C,2)<=REF(O,2)&&REF(C,1)<=REF(O,1)&&C>O&&Z,0.98,0.2,1,'中途整理. 阴阴阳⑦艮/山:阴减,反弹'),COLOR00FFFF;

举报

扔鸡蛋(0) 回复

想好再说
Lv.2
发表于 2020-10-14 10:44 复制 查看全部楼层
谢谢许昌老师!神速!十分钟就写出,高手!真棒!

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-14 10:38 复制 查看全部楼层
突破:=REF(EMA(C,10),1)COLORMAGENTA,LINETHICK1;
A1X:=(EMA(C,10)-突破)/突破*100;

XG:CROSS(A1X,0);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表