手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助依据主图附图指标改编成选股指标公式

[通达信]
设置
1757 1 言而喻 Lv.2 发表于 · 2020-10-14 11:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师改编成主图附图同时金叉(附图中三角形符号处)的选股公式,写两个也可以。

变色KDJ主图指标源码:
MA20:MA(C,20),COLORRED,LINETHICK2;
MA55:MA(C,55),COLOR00FF00,LINETHICK2;
IF(MA20<REF(MA20,1),MA20,DRAWNULL),COLORFF0000,LINETHICK2;
IF(MA55<REF(MA55,1),MA55,DRAWNULL),COLORFFFF00,LINETHICK2;
BB:MA(MA(CLOSE,3),1),LINETHICK3,COLOR00FFFF;
IF(BB>=REF(BB,1),BB,DRAWNULL),COLORFF00FF,LINETHICK3;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
最高2:=CONST(HHV(H,NN));
最低2:=CONST(LLV(L,NN));
PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;
RCC1:=最高2*0.9-(最高2-最低2)*PP;
最低3:=MIN(RCC1,最低2);
AA:=最低3;
周J:=MA("KDJ.J#WEEK"(9,3,3) ,5),COLORFFFF00,LINETHICK2;
AA1:=周J<0 AND 周J<REF(周J,1) ;
FF1:=周J<0 AND 周J>REF(周J,1);
BB1:=周J>=0 AND 周J<85 AND 周J>REF(周J,1);
DD1:=周J>=REF(周J,1) AND 周J>=85 ;
EE1:=周J<REF(周J,1) AND 周J>0;
ZJ1:=MA("KDJ.J#WEEK"(9,3,3) ,5);
YK:=MA("KDJ.K#MONTH"(9,3,3),20),LINETHICK0;
YD:=MA("KDJ.D#MONTH"(9,3,3),20),LINETHICK0;
YJ:=MA("KDJ.J#MONTH"(9,3,3),20);
ZK:=MA("KDJ.K#WEEK"(9,3,3) ,5),LINETHICK0;
ZD:=MA("KDJ.D#WEEK"(9,3,3) ,5),LINETHICK0;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),LINETHICK0;
D:=SMA(K,3,1),LINETHICK0;
J:=3*K-2*D,LINETHICK0;
GG1:=C>0;


变色MACD幅图源码:
DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEAEA1:=EMA(DIFIF1,9);
MACD1:=2*(DIFIF1-DEAEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORGREEN;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCBCBC0;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIFIF1,COLOR33FF33,LINETHICK2;
DEAEA1,COLORYELLOW,LINETHICK2;
MACD:MACD1,NODRAW,COLORMAGENTA;
强:IF(DIFIF1>=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;
弱:IF(DEAEA1>=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;
DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1+0.1,1);
DRAWICON(CROSS(DEAEA1,DIFIF1),-0.5,2);
DRAWTEXT(CROSS(DIFIF1,DEAEA1),DIFIF1,'○'),LINETHICK2, COLORYELLOW;

附件

002459.png
300589.png

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-14 11:41 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-10-14 11:44 编辑

MA20:=MA(C,20),COLORRED,LINETHICK2;
BB:=MA(MA(CLOSE,3),1),LINETHICK3,COLOR00FFFF;
TJ1:=CROSS(BB,MA20);


DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEAEA1:=EMA(DIFIF1,9);
TJ2:=CROSS(DIFIF1,DEAEA1);

XG:TJ1 AND TJ2;

附件

tdxjietu3.JPG
查看全部打赏
  • 言而喻+10理想币 : 谢谢你,能否再次修改只选出零上金叉的。

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表