手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个条件选股

[通达信]
设置
1127 5 微利数码1 Lv.2 发表于 · 2020-10-14 16:11 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师做个黄K线连续出现最后一个下黄上红的K线,做个条件选股,谢谢了。




DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
金牛:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORYELLOW;
金钻趋势:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK2,COLORRED;
金牛2:EMA(金钻趋势,25)COLORCYAN,LINETHICK2;
DRAWBAND(金钻趋势,RGB(55,0,0),金牛2,RGB(0,91,0));
DRAWKLINE(H,O,L,C);
STICKLINE(金钻趋势>LOW AND 金钻趋势<HIGH,金钻趋势,MIN(MIN(OPEN,CLOSE),金钻趋势),2,0),COLORYELLOW;
STICKLINE(金钻趋势>MIN(C,O) AND 金钻趋势<MAX(C,O),金钻趋势,MIN(OPEN,CLOSE),2,0),COLORYELLOW;
STICKLINE(金钻趋势>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(金钻趋势>HIGH,HIGH,LOW,0,0),COLORYELLOW;
VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
回调买:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:=金钻趋势>HIGH AND 回调买 AND L<=金钻趋势;
DRAWTEXT(XG,L,'▲买入'),COLORRED;


tdxjietu1.JPG

举报

扔鸡蛋(0) 回复

屙金溺银
Lv.2
发表于 2020-10-14 18:59 复制 查看全部楼层
凡是含有未来函数的都是忽悠,别信

举报

扔鸡蛋(0) 回复

微利数码1
Lv.2
发表于 2020-10-14 17:04 复制 查看全部楼层

哪位高手能帮忙优化一下公式吗?去掉未来函数?

举报

点亮(0) 扔鸡蛋(0) 回复

微利数码1
Lv.2
发表于 2020-10-14 16:53 复制 查看全部楼层

谢谢提醒。

举报

扔鸡蛋(0) 回复

九州同庆
Lv.3
发表于 2020-10-14 16:36 复制 查看全部楼层
XMA未来函数

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-14 16:33 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-10-14 16:37 编辑

N:=3;
金牛:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25);
金钻趋势:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25));
金牛2:=EMA(金钻趋势,25)COLORCYAN,LINETHICK2;

H1:=金钻趋势>LOW AND 金钻趋势<HIGH;
H2:=金钻趋势>MIN(C,O) AND 金钻趋势<MAX(C,O);
H3:=金钻趋势>HIGH;
HH:= H2 OR H3;

XG:REF(EVERY(HH,N),1) AND C>金钻趋势 AND O<金钻趋势 AND C>O;
查看全部打赏
  • 微利数码1+2理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表