手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股公式

[通达信]
设置
1300 7 阿里山131419 Lv.2 发表于 · 2020-10-14 17:46 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师将下列公式连续出现5天红柱写个选股公式,万分感谢!

AMOW:AMOUNT,VOLSTICK;
HJ_1:=AMOW>REF(AMOW,1)*2;
HJ_2:=LLV(AMOW,5);
HJ_3:=HHV(AMOW,5);
HJ_4:=LLV(AMOW,250);
HJ_5:=HHV(AMOW,250);
HJ_6:=LLV(AMOW,120);
HJ_7:=HHV(AMOW,120);
HJ_8:=(HJ_2+HJ_3+HJ_4+HJ_5+MA(AMOW,5)+MA(AMOW,250)+HJ_6+HJ_7+MA(AMOW,120))/9;
HJ_9:=AMOW>HJ_8;
量王:HJ_9;
STICKLINE(量王,0,AMOUNT,3,0),COLORRED;
HJ_10:=HJ_1;
STICKLINE(HJ_10,0,AMOUNT,3,0),COLORMAGENTA;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-16 14:06 复制 查看全部楼层
阿里山131419 发表于 2020-10-16 13:30
许昌舍得老师你好,下面这个多于4个红柱又怎么写选股啊

VOLT:=VOL;
HJ_1:=VOL>REF(VOL,1)*2;
HJ_2:=LLV(VOL,5);
HJ_3:=HHV(VOL,5);
HJ_4:=LLV(VOL,250);
HJ_5:=HHV(VOL,250);

HJ_6:=MA(CLOSE,20);
HJ_7:=(HJ_2+HJ_3+HJ_4+HJ_5+MA(VOL,5)+MA(VOL,250))/6;
HJ_8:=CLOSE>MA(CLOSE,HJ_6) AND VOL>HJ_7*0.65;
HJ_9:=HJ_8;
HJ_10:=REF(HJ_9,1) AND CLOSE=OPEN;
HJ_11:=CLOSE=OPEN;
量王:=HJ_9 OR HJ_10 OR HJ_11;

连续四量王:BARSLASTCOUNT(量王)>3;

举报

点亮(0) 扔鸡蛋(0) 回复

阿里山131419
Lv.2
发表于 2020-10-16 13:30 复制 查看全部楼层
许昌舍得 发表于 2020-10-14 18:33
AMOW:=AMOUNT;
HJ_1:=AMOW>REF(AMOW,1)*2;
HJ_2:=LLV(AMOW,5);

许昌舍得老师你好,下面这个多于4个红柱又怎么写选股啊


VOLT:VOL,VOLSTICK;
HJ_1:=VOL>REF(VOL,1)*2;
HJ_2:=LLV(VOL,5);
HJ_3:=HHV(VOL,5);
HJ_4:=LLV(VOL,250);
HJ_5:=HHV(VOL,250);
MA1:MA(VOL,M1);
MA2:MA(VOL,M2);
MA3:MA(VOL,M3);
HJ_6:=MA(CLOSE,20);
HJ_7:=(HJ_2+HJ_3+HJ_4+HJ_5+MA(VOL,5)+MA(VOL,250))/6;
HJ_8:=CLOSE>MA(CLOSE,HJ_6) AND VOL>HJ_7*0.65;
HJ_9:=HJ_8;
HJ_10:=REF(HJ_9,1) AND CLOSE=OPEN;
HJ_11:=CLOSE=OPEN;
量王:HJ_9 OR HJ_10 OR HJ_11;
STICKLINE(量王,0,VOL,3,0),COLORRED;
STICKLINE(HJ_1,0,VOL,3,0),COLORMAGENTA;

举报

点亮(0) 扔鸡蛋(0) 回复

阿里山131419
Lv.2
发表于 2020-10-15 10:10 复制 查看全部楼层
感谢各位老师

举报

扔鸡蛋(0) 回复

神池王
Lv.2
发表于 2020-10-15 00:01 复制 查看全部楼层
AMOW:=AMOUNT;
HJ_1:=AMOW>REF(AMOW,1)*2;
HJ_2:=LLV(AMOW,5);
HJ_3:=HHV(AMOW,5);
HJ_4:=LLV(AMOW,250);
HJ_5:=HHV(AMOW,250);
HJ_6:=LLV(AMOW,120);
HJ_7:=HHV(AMOW,120);
HJ_8:=(HJ_2+HJ_3+HJ_4+HJ_5+MA(AMOW,5)+MA(AMOW,250)+HJ_6+HJ_7+MA(AMOW,120))/9;
HJ_9:=AMOW>HJ_8;
量王:=HJ_9;

XG:BARSLASTCOUNT(量王)>4;
查看全部打赏
  • 阿里山131419+5理想币 +2共享币 : 每天进步一点点,希望的火苗不熄灭。

举报

扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-14 18:40 复制 查看全部楼层
{连续出现5天红柱 选股公式}

AMOW:=AMOUNT;
HJ_1:=AMOW>REF(AMOW,1)*2;
HJ_2:=LLV(AMOW,5);
HJ_3:=HHV(AMOW,5);
HJ_4:=LLV(AMOW,250);
HJ_5:=HHV(AMOW,250);
HJ_6:=LLV(AMOW,120);
HJ_7:=HHV(AMOW,120);
HJ_8:=(HJ_2+HJ_3+HJ_4+HJ_5+MA(AMOW,5)+MA(AMOW,250)+HJ_6+HJ_7+MA(AMOW,120))/9;
HJ_9:=AMOW>HJ_8;
XG: EVERY(HJ_9 && HJ_9<>HJ_1,5);
查看全部打赏
  • 阿里山131419+5理想币 +2共享币 : 感谢交流,感恩分享,收获正能量。

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-10-14 18:35 复制 查看全部楼层
AMOW:=AMOUNT;
HJ_1:=AMOW>REF(AMOW,1)*2;
HJ_2:=LLV(AMOW,5);
HJ_3:=HHV(AMOW,5);
HJ_4:=LLV(AMOW,250);
HJ_5:=HHV(AMOW,250);
HJ_6:=LLV(AMOW,120);
HJ_7:=HHV(AMOW,120);
HJ_8:=(HJ_2+HJ_3+HJ_4+HJ_5+MA(AMOW,5)+MA(AMOW,250)+HJ_6+HJ_7+MA(AMOW,120))/9;
HJ_9:=AMOW>HJ_8;
量王:=HJ_9;
CROSS(COUNT(量王,5)=5,0.5);
查看全部打赏
  • 阿里山131419+5理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-14 18:33 复制 查看全部楼层
AMOW:=AMOUNT;
HJ_1:=AMOW>REF(AMOW,1)*2;
HJ_2:=LLV(AMOW,5);
HJ_3:=HHV(AMOW,5);
HJ_4:=LLV(AMOW,250);
HJ_5:=HHV(AMOW,250);
HJ_6:=LLV(AMOW,120);
HJ_7:=HHV(AMOW,120);
HJ_8:=(HJ_2+HJ_3+HJ_4+HJ_5+MA(AMOW,5)+MA(AMOW,250)+HJ_6+HJ_7+MA(AMOW,120))/9;
HJ_9:=AMOW>HJ_8;
量王:=HJ_9;

XG:BARSLASTCOUNT(量王)>4;
查看全部打赏
  • 阿里山131419+5理想币 +2共享币 : 点赞,知识的价值在于分享,谢谢!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表