手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助提供:定量结构指标

[通达信]
设置
1225 3 决策者1号 Lv.2 发表于 · 2020-10-14 17:53 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
拜求徐小明老师用的定量结构指标,要通达信版本的,哪位老师有这个指标?谢谢

举报

扔鸡蛋(0) 回复

神池王
Lv.2
发表于 2020-10-14 23:59 复制 查看全部楼层
下载附件
111.jpg

附件

定量结构_0.tn6

9.13 KB, 下载次数: 3, 下载积分: 共享币 -5 个

举报

扔鸡蛋(0) 回复

决策者1号
Lv.2
发表于 2020-10-14 18:37 复制 查看全部楼层
牛牛1888 发表于 2020-10-14 18:19
找了一个,和你共勉。



请问这么多的源码一起导入吗?是一个公式?

举报

点亮(0) 扔鸡蛋(0) 回复

牛牛1888
Lv.3
发表于 2020-10-14 18:19 复制 查看全部楼层
找了一个,和你共勉。


DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED,LINETHICK2;
DEA:EMA(DIF,9),COLORBLUE,LINETHICK2;
MACD:(DIF-DEA)*2,COLORSTICK,COLORMAGENTA;

{底部结构预警}
死叉:=CROSS(DEA,DIF);
N10:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}
N20:=REF(BARSLAST(死叉),N10+1),NODRAW;{倒数第二次死叉与倒数第一次死叉的区间}
N30:=REF(BARSLAST(死叉),N20+N10+2),NODRAW;{倒数第三次死叉与倒数第二次死叉的区间}
CL1:=LLV(C,N10+1),NODRAW;{最近一次死叉后,最低收盘价}
DIFL1:=LLV(DIF,N10+1),NODRAW;

CL2:=REF(CL1,N10+1),NODRAW;{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}
DIFL2:=REF(DIFL1,N10+1),NODRAW;
CL3:=REF(CL2,N10+1),NODRAW;{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}
DIFL3:=REF(DIFL2,N10+1),NODRAW;
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
BZ:=直接底背离 OR 隔峰底背离,NODRAW;
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),NODRAW;
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
DRAWTEXT(TFILTER(BZ,MACD>0,1),(DIF+MACD),'钝化'),COLORRED;
STICKLINE(BZ OR BG,DIF,DEA,1,0),COLORRED;
DRAWTEXT(TFILTER(底背离消失,BZ,1),(DIF+MACD/2),'消失'),COLORBLUE;
DRAWTEXT(TFILTER(BG,MACD>0,1),DIF*1.1,'结构形成'),COLORLIMAGENTA;

{顶部结构预警}

金叉:=CROSS(DIF,DEA);
MM1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}
MM2:=REF(BARSLAST(金叉),MM1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉的区间}
MM3:=REF(BARSLAST(金叉),MM2+MM1+2),NODRAW;{倒数第三次金叉与倒数第二次金叉的区间}
CH1:=HHV(C,MM1+1),NODRAW;{最近一次金叉后,最高收盘价}
DIFH1:=HHV(DIF,MM1+1),NODRAW;

CH22:=REF(CH1,MM1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉之间的最高收盘价}
DIFH2:=REF(DIFH1,MM1+1),NODRAW;
CH3:=REF(CH22,MM1+1),NODRAW;{倒数第三次金叉与倒数第二次金叉之间的最高收盘价}
DIFH3:=REF(DIFH2,MM1+1),NODRAW;
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH22 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH22 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=直接顶背离 OR 隔峰顶背离,NODRAW;
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1)),NODRAW;
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
DRAWTEXT(TFILTER(T,MACD<0,1),(DIF+MACD),'钝化'),COLORLIGREEN;
DRAWTEXT(TFILTER(顶背离消失,T,1),(DIF+MACD),'消失'),COLORLIBLUE;
STICKLINE(T OR TG,DIF,DEA,1,0),COLORLIGREEN;
DRAWTEXT(TFILTER(TG,MACD<0,1),DIF*1.02,'结构形成'),COLORMAGENTA;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表