手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改选股公式

[通达信]
设置
1017 5 张本海 Lv.3 发表于 · 2020-10-14 18:48 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
&#196;&#190;×ó0:=IF(DATE<= 99999999,1,0);
&#196;&#190;×ó1:=SMA(MAX(MAX(HIGH - LOW,ABS(HIGH - REF(CLOSE,1))),ABS(LOW - REF(CLOSE,1))),14,1);
&#196;&#190;×ó2:=HIGH - REF(HIGH,1);
&#196;&#190;×ó3:=REF(LOW,1) - LOW;
&#196;&#190;×ó4:=SMA(IF(&#196;&#190;×ó2 > 0 AND &#196;&#190;×ó2 > &#196;&#190;×ó3,&#196;&#190;×ó2,0),12,1);
&#196;&#190;×ó5:=SMA(IF(&#196;&#190;×ó3 > 0 AND &#196;&#190;×ó3 > &#196;&#190;×ó2,&#196;&#190;×ó3,0),12,1);
&#196;&#190;×ó6:=&#196;&#190;×ó4 * 100 / &#196;&#190;×ó1;
&#196;&#190;×ó7:=&#196;&#190;×ó5 * 100 / &#196;&#190;×ó1;
&#196;&#190;×ó8:=SMA(ABS(&#196;&#190;×ó7 - &#196;&#190;×ó6) / (&#196;&#190;×ó7 + &#196;&#190;×ó6) * 100,12,1);
&#196;&#190;×ó9:=(&#196;&#190;×ó8 + REF(&#196;&#190;×ó8,5)) / 2;
&#196;&#190;×ó10:=SUM(HIGH - OPEN,12) / SUM(OPEN - LOW,12) * 100;
&#196;&#190;×ó11:=SUM(MAX(0,HIGH - REF(CLOSE,1)),12) / SUM(MAX(0,REF(CLOSE,1) - LOW),12) * 100;
&#196;&#190;×ó12:=AMOUNT / VOL / 100;
&#196;&#190;×ó13:=(3 * HIGH + LOW + OPEN + 2 * CLOSE) / 7;
&#196;&#190;×ó14:=SUM(AMOUNT,5) / &#196;&#190;×ó12 / 100;
&#196;&#190;×ó15:=SUM(AMOUNT,13) / &#196;&#190;×ó12 / 100;
&#196;&#190;×ó16:=SUM(AMOUNT,34) / &#196;&#190;×ó12 / 100;
&#196;&#190;×ó17:=SUM(AMOUNT,209) / &#196;&#190;×ó12 / 100;
&#196;&#190;×ó18:=REF(VOL,1) + REF(VOL,2) + REF(VOL,3) + REF(VOL,4);
&#196;&#190;×ó19:=&#196;&#190;×ó18 / CAPITAL;
&#196;&#190;×ó20:=VOL / CAPITAL * &#196;&#190;×ó13 + &#196;&#190;×ó19 * REF(&#196;&#190;×ó12,1);
&#196;&#190;×ó21:=DMA(&#196;&#190;×ó13,VOL / &#196;&#190;×ó14);
&#196;&#190;×ó22:=DMA(&#196;&#190;×ó13,VOL / &#196;&#190;×ó15);
&#196;&#190;×ó23:=DMA(&#196;&#190;×ó13,VOL / &#196;&#190;×ó16);
&#196;&#190;×ó24:=DMA(&#196;&#190;×ó13,VOL / CAPITAL);
&#196;&#190;×ó25:=MA(HHV(HIGH,488),18);
&#196;&#190;×ó26:=MA(HHV(HIGH,220),18);
&#196;&#190;×ó27:=MA(HHV(HIGH,98),18);
&#196;&#190;×ó28:=MA(LLV(LOW,488),18);
&#196;&#190;×ó29:=MA(LLV(LOW,220),18);
&#196;&#190;×ó30:=MA(LLV(LOW,98),18);
&#196;&#190;×ó31:=MA((&#196;&#190;×ó28 * 0.96 + &#196;&#190;×ó29 * 0.96 + &#196;&#190;×ó30 * 0.96 + &#196;&#190;×ó25 * 0.558 + &#196;&#190;×ó26 * 0.558 + &#196;&#190;×ó27 * 0.558) / 6,18);
&#196;&#190;×ó32:=MA((&#196;&#190;×ó28 * 1.25 + &#196;&#190;×ó29 * 1.23 + &#196;&#190;×ó30 * 1.2 + &#196;&#190;×ó25 * 0.55 + &#196;&#190;×ó26 * 0.55 + &#196;&#190;×ó27 * 0.65) / 6,18);
&#196;&#190;×ó33:=MA((&#196;&#190;×ó28 * 1.3 + &#196;&#190;×ó29 * 1.3 + &#196;&#190;×ó30 * 1.3 + &#196;&#190;×ó25 * 0.68 + &#196;&#190;×ó26 * 0.68 + &#196;&#190;×ó27 * 0.68) / 6,18);
&#196;&#190;×ó34:=MA((&#196;&#190;×ó31 * 3 + &#196;&#190;×ó32 * 2 + &#196;&#190;×ó33) / 6 * 1.738,18);
&#196;&#190;×ó35:=IF(DATE <= 33031231,&#196;&#190;×ó34,&#196;&#190;×ó34 * DAY);
&#196;&#190;×ó36:=LOW;
&#196;&#190;×ó37:=REF(LOW,1);
&#196;&#190;×ó38:=SMA(ABS(&#196;&#190;×ó36 - &#196;&#190;×ó37),3,1) / SMA(MAX(&#196;&#190;×ó36 - &#196;&#190;×ó37,0),3,1) * 100;
&#196;&#190;×ó39:=MA(IF(CLOSE * 1.35 <= &#196;&#190;×ó35,&#196;&#190;×ó38 * 10,&#196;&#190;×ó38 / 10),3);
&#196;&#190;×ó40:=LLV(LOW,30);
&#196;&#190;×ó41:=HHV(&#196;&#190;×ó39,30);
&#196;&#190;×ó42:=IF(LOW <= &#196;&#190;×ó40,(&#196;&#190;×ó39 + &#196;&#190;×ó41 * 2) / 2,0);
&#196;&#190;×ó43:=MA(HHV(HIGH,488),18);
&#196;&#190;×ó44:=MA(HHV(HIGH,220),18);
&#196;&#190;×ó45:=MA(HHV(HIGH,98),18);
&#196;&#190;×ó46:=MA(LLV(LOW,488),18);
&#196;&#190;×ó47:=MA(LLV(LOW,220),18);
&#196;&#190;×ó48:=MA(LLV(LOW,98),18);
&#196;&#190;×ó49:=MA((&#196;&#190;×ó46 * 0.96 + &#196;&#190;×ó47 * 0.96 + &#196;&#190;×ó48 * 0.96 + &#196;&#190;×ó43 * 0.558 + &#196;&#190;×ó44 * 0.558 + &#196;&#190;×ó45 * 0.558) / 6,18);
&#196;&#190;×ó50:=MA((&#196;&#190;×ó46 * 1.25 + &#196;&#190;×ó47 * 1.23 + &#196;&#190;×ó48 * 1.2 + &#196;&#190;×ó43 * 0.55 + &#196;&#190;×ó44 * 0.55 + &#196;&#190;×ó45 * 0.65) / 6,18);
&#196;&#190;×ó51:=MA((&#196;&#190;×ó46 * 1.3 + &#196;&#190;×ó47 * 1.3 + &#196;&#190;×ó48 * 1.3 + &#196;&#190;×ó43 * 0.68 + &#196;&#190;×ó44 * 0.68 + &#196;&#190;×ó45 * 0.68) / 6,18);
&#196;&#190;×ó52:=MA((&#196;&#190;×ó49 * 3 + &#196;&#190;×ó50 * 2 + &#196;&#190;×ó51) / 6 * 1.738,18);
&#196;&#190;×ó53:=&#196;&#190;×ó52;
&#196;&#190;×ó54:=LOW;
&#196;&#190;×ó55:=REF(LOW,1);
&#196;&#190;×ó56:=SMA(ABS(&#196;&#190;×ó54 - &#196;&#190;×ó55),3,1) / SMA(MAX(&#196;&#190;×ó54 - &#196;&#190;×ó55,0),3,1) * 100;
&#196;&#190;×ó57:=MA(IF(CLOSE * 1.35 <= &#196;&#190;×ó53,&#196;&#190;×ó56 * 10,&#196;&#190;×ó56 / 10),3);
&#196;&#190;×ó58:=LLV(LOW,30);
&#196;&#190;×ó59:=HHV(&#196;&#190;×ó57,30);
&#196;&#190;×ó60:=IF(LOW <= &#196;&#190;×ó58,(&#196;&#190;×ó57 + &#196;&#190;×ó59 * 2) / 2,0);
&#196;&#190;×ó61:=MA(&#196;&#190;×ó60 AND CLOSE < COST(1),3);
&#196;&#190;×ó62:=MA(&#196;&#190;×ó42 AND CLOSE < COST(1),3) AND (CLOSE - &#196;&#190;×ó22) / &#196;&#190;×ó22 * 100 < 2 - 13;
&#196;&#190;×ó63:=EMA(3 * SMA((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27)) * 100,5,1) - 2 * SMA(SMA((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27)) * 100,5,1),3,1),5) / 100;
&#196;&#190;×ó64:=IF((REF(CLOSE,13) - CLOSE) / REF(CLOSE,13) * 100 > 15 AND SUM(VOL / CAPITAL,13) * 100 < 18 AND VOL / CAPITAL * 100 < 2.5 AND (REF(CLOSE,1) - CLOSE) / REF(CLOSE,1) * 100 < 8,0.7,0);
&#196;&#190;×ó65:=(CLOSE - REF(CLOSE,1)) / REF(CLOSE,1) * 100;
&#196;&#190;×ó66:=MA(VOL,2) / MA(VOL,10);
&#196;&#190;×ó67:=VOL / CAPITAL;
&#196;&#190;×ó68:=0.0068 * &#196;&#190;×ó65 - 0.0072 * &#196;&#190;×ó66 - 0.5676 * &#196;&#190;×ó67 - 0.0105;
&#196;&#190;×ó69:=0.0015 * &#196;&#190;×ó65 - 0.0124 * &#196;&#190;×ó66 + 1.7461 * &#196;&#190;×ó67 - 0.0074;
&#196;&#190;×ó70:=0 - 0.0003 * &#196;&#190;×ó65 + 0.047 * &#196;&#190;×ó66 - 0.5734 * &#196;&#190;×ó67 - 0.0549;
&#196;&#190;×ó71:=0 - 12.2401 * &#196;&#190;×ó68 - 1 * &#196;&#190;×ó69 + 0.321 < 0;
&#196;&#190;×ó72:=(CLOSE - MA(CLOSE,27)) / MA(CLOSE,27) < 0 - 0.16;
&#196;&#190;×ó73:=STICKLINE(&#196;&#190;×ó72,0,0.5,2,0);
XG:&#196;&#190;×ó62 * &#196;&#190;×ó0 AND &#196;&#190;×ó71 * &#196;&#190;×ó0;

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-10-14 19:42 复制 查看全部楼层

该选股条件很窄(很苛刻,很严格),所以符合条件的个股不多,可能半年或一年才会有几只个股符合条件的(大约从5月至今合符条件的只有600734,688088,300459三只个股),你可以适当延长选股天数就能选出个股,或得等待有新的符合条件的个股出现。

举报

点亮(0) 扔鸡蛋(0) 回复

张本海
Lv.3
发表于 2020-10-14 19:20 复制 查看全部楼层
张本海 发表于 2020-10-14 19:15
谢谢老师,谢谢老师

怎么选不了股呀

举报

扔鸡蛋(0) 回复

张本海
Lv.3
发表于 2020-10-14 19:18 复制 查看全部楼层
怎么选不股呀老师

举报

扔鸡蛋(0) 回复

张本海
Lv.3
发表于 2020-10-14 19:15 复制 查看全部楼层
谢谢老师,谢谢老师

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-10-14 19:01 复制 查看全部楼层
VAR0:=IF(DATE<= 99999999,1,0);
VAR1:=SMA(MAX(MAX(HIGH - LOW,ABS(HIGH - REF(CLOSE,1))),ABS(LOW - REF(CLOSE,1))),14,1);
VAR2:=HIGH - REF(HIGH,1);
VAR3:=REF(LOW,1) - LOW;
VAR4:=SMA(IF(VAR2 > 0 && VAR2 > VAR3,VAR2,0),12,1);
VAR5:=SMA(IF(VAR3 > 0 && VAR3 > VAR2,VAR3,0),12,1);
VAR6:=VAR4 * 100 / VAR1;
VAR7:=VAR5 * 100 / VAR1;
VAR8:=SMA(ABS(VAR7 - VAR6) / (VAR7 + VAR6) * 100,12,1);
VAR9:=(VAR8 + REF(VAR8,5)) / 2;
VAR10:=SUM(HIGH - OPEN,12) / SUM(OPEN - LOW,12) * 100;
VAR11:=SUM(MAX(0,HIGH - REF(CLOSE,1)),12) / SUM(MAX(0,REF(CLOSE,1) - LOW),12) * 100;
VAR12:=AMOUNT / VOL / 100;
VAR13:=(3 * HIGH + LOW + OPEN + 2 * CLOSE) / 7;
VAR14:=SUM(AMOUNT,5) / VAR12 / 100;
VAR15:=SUM(AMOUNT,13) / VAR12 / 100;
VAR16:=SUM(AMOUNT,34) / VAR12 / 100;
VAR17:=SUM(AMOUNT,209) / VAR12 / 100;
VAR18:=REF(VOL,1) + REF(VOL,2) + REF(VOL,3) + REF(VOL,4);
VAR19:=VAR18 / CAPITAL;
VAR20:=VOL / CAPITAL * VAR13 + VAR19 * REF(VAR12,1);
VAR21:=DMA(VAR13,VOL / VAR14);
VAR22:=DMA(VAR13,VOL / VAR15);
VAR23:=DMA(VAR13,VOL / VAR16);
VAR24:=DMA(VAR13,VOL / CAPITAL);
VAR25:=MA(HHV(HIGH,488),18);
VAR26:=MA(HHV(HIGH,220),18);
VAR27:=MA(HHV(HIGH,98),18);
VAR28:=MA(LLV(LOW,488),18);
VAR29:=MA(LLV(LOW,220),18);
VAR30:=MA(LLV(LOW,98),18);
VAR31:=MA((VAR28 * 0.96 + VAR29 * 0.96 + VAR30 * 0.96 + VAR25 * 0.558 + VAR26 * 0.558 + VAR27 * 0.558) / 6,18);
VAR32:=MA((VAR28 * 1.25 + VAR29 * 1.23 + VAR30 * 1.2 + VAR25 * 0.55 + VAR26 * 0.55 + VAR27 * 0.65) / 6,18);
VAR33:=MA((VAR28 * 1.3 + VAR29 * 1.3 + VAR30 * 1.3 + VAR25 * 0.68 + VAR26 * 0.68 + VAR27 * 0.68) / 6,18);
VAR34:=MA((VAR31 * 3 + VAR32 * 2 + VAR33) / 6 * 1.738,18);
VAR35:=IF(DATE <= 33031231,VAR34,VAR34 * DAY);
VAR36:=LOW;
VAR37:=REF(LOW,1);
VAR38:=SMA(ABS(VAR36 - VAR37),3,1) / SMA(MAX(VAR36 - VAR37,0),3,1) * 100;
VAR39:=MA(IF(CLOSE * 1.35 <= VAR35,VAR38 * 10,VAR38 / 10),3);
VAR40:=LLV(LOW,30);
VAR41:=HHV(VAR39,30);
VAR42:=IF(LOW <= VAR40,(VAR39 + VAR41 * 2) / 2,0);
VAR43:=MA(HHV(HIGH,488),18);
VAR44:=MA(HHV(HIGH,220),18);
VAR45:=MA(HHV(HIGH,98),18);
VAR46:=MA(LLV(LOW,488),18);
VAR47:=MA(LLV(LOW,220),18);
VAR48:=MA(LLV(LOW,98),18);
VAR49:=MA((VAR46 * 0.96 + VAR47 * 0.96 + VAR48 * 0.96 + VAR43 * 0.558 + VAR44 * 0.558 + VAR45 * 0.558) / 6,18);
VAR50:=MA((VAR46 * 1.25 + VAR47 * 1.23 + VAR48 * 1.2 + VAR43 * 0.55 + VAR44 * 0.55 + VAR45 * 0.65) / 6,18);
VAR51:=MA((VAR46 * 1.3 + VAR47 * 1.3 + VAR48 * 1.3 + VAR43 * 0.68 + VAR44 * 0.68 + VAR45 * 0.68) / 6,18);
VAR52:=MA((VAR49 * 3 + VAR50 * 2 + VAR51) / 6 * 1.738,18);
VAR53:=VAR52;
VAR54:=LOW;
VAR55:=REF(LOW,1);
VAR56:=SMA(ABS(VAR54 - VAR55),3,1) / SMA(MAX(VAR54 - VAR55,0),3,1) * 100;
VAR57:=MA(IF(CLOSE * 1.35 <= VAR53,VAR56 * 10,VAR56 / 10),3);
VAR58:=LLV(LOW,30);
VAR59:=HHV(VAR57,30);
VAR60:=IF(LOW <= VAR58,(VAR57 + VAR59 * 2) / 2,0);
VAR61:=MA(VAR60 && CLOSE < COST(1),3);
VAR62:=MA(VAR42 && CLOSE < COST(1),3) && (CLOSE - VAR22) / VAR22 * 100 < 2 - 13;
VAR63:=EMA(3 * SMA((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27)) * 100,5,1) - 2 * SMA(SMA((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27)) * 100,5,1),3,1),5) / 100;
VAR64:=IF((REF(CLOSE,13) - CLOSE) / REF(CLOSE,13) * 100 > 15 && SUM(VOL / CAPITAL,13) * 100 < 18 && VOL / CAPITAL * 100 < 2.5 && (REF(CLOSE,1) - CLOSE) / REF(CLOSE,1) * 100 < 8,0.7,0);
VAR65:=(CLOSE - REF(CLOSE,1)) / REF(CLOSE,1) * 100;
VAR66:=MA(VOL,2) / MA(VOL,10);
VAR67:=VOL / CAPITAL;
VAR68:=0.0068 * VAR65 - 0.0072 * VAR66 - 0.5676 * VAR67 - 0.0105;
VAR69:=0.0015 * VAR65 - 0.0124 * VAR66 + 1.7461 * VAR67 - 0.0074;
VAR70:=0 - 0.0003 * VAR65 + 0.047 * VAR66 - 0.5734 * VAR67 - 0.0549;
VAR71:=0 - 12.2401 * VAR68 - 1 * VAR69 + 0.321 < 0;
VAR72:=(CLOSE - MA(CLOSE,27)) / MA(CLOSE,27) < 0 - 0.16;
VAR73:=STICKLINE(VAR72,0,0.5,2,0);
XG: VAR62 * VAR0 && VAR71 * VAR0;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表