手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做三个预警选股公式

[通达信]
设置
1243 5 顺天自然 Lv.2 发表于 · 2020-10-14 20:10 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
1,“绝杀点”预警选股

2,“买入”预警选股

3,“卖出”预警选股





N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,N)*(1+P1/1000),COLORFFFFFF,LINETHICK3;
买入:=XMA(VAR1,M)*(1-P2/1000),COLOR0000FF,LINETHICK3;
DRAWBAND(卖出,RGB(200,50,55),卖出*1.03,RGB(0,100,50));
DRAWBAND(买入,RGB(0,55,0),买入*0.97,RGB(55,55,0));
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;

DRAWTEXT(CROSS(C,卖出),卖出*1.05,'卖出'),COLOR00FFFF;
机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0,LINETHICK2;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=REF(MA(RSV2,3),1)+(RSV2-REF(MA(RSV2,3),1))/3;
D2:=REF(MA(K2,3),1)+(K2-REF(MA(K2,3),1))/3;
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
金叉:=CROSS(BB1,BB2);
DRAWTEXT(CROSS(C,买入) AND BB1>BB2 AND C>REF(O,2),买入*0.95,'买入'),COLOR0000FF;
DRAWICON(CROSS(C,买入) AND金叉 AND 机会来临 ,LOW*0.96,26);
DRAWTEXT(CROSS(C,买入) AND金叉 AND 机会来临,LOW*0.92,'【绝杀点】'),COLOR00FF00;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-15 06:25 复制 查看全部楼层
分时指标,在分时图里使用(交易中)。及时数据过后许多就消失了。

举报

点亮(0) 扔鸡蛋(0) 回复

骏骏V5
Lv.2
发表于 2020-10-15 00:09 复制 查看全部楼层
许昌舍得 发表于 2020-10-14 20:52
N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,N)*(1+P1/1000),COLORFFFFFF,LINETHIC ...

老师你好,之前在一个帖子上看到你写的预警公式,运行后发现出不来票,问下是哪里出问题了
MA30:=EMA(CLOSE,30);
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLOR00DD00;
支撑:=L1+P1*0.5/8,COLOR00DD00;
现价:=CLOSE,COLORWHITE,LINETHICK1;

XG:LONGCROSS(支撑,现价,2);

举报

点亮(0) 扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-14 20:55 复制 查看全部楼层
{“绝杀点”预警选股}
N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,N)*(1+P1/1000);
买入:=XMA(VAR1,M)*(1-P2/1000);
幅度:=100*(卖出-买入)/买入;
MA1:=MA(VAR1,3);
机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1);
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=REF(MA(RSV2,3),1)+(RSV2-REF(MA(RSV2,3),1))/3;
D2:=REF(MA(K2,3),1)+(K2-REF(MA(K2,3),1))/3;
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
金叉:=CROSS(BB1,BB2);
XG: CROSS(C,买入) && 金叉 && 机会来临;


{“买入”预警选股}
N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
XG: XMA(VAR1,M)*(1-P2/1000);

{“卖出”预警选股}
N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
XG: XMA(VAR1,N)*(1+P1/1000);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-14 20:52 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-10-14 20:53 编辑

N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,N)*(1+P1/1000),COLORFFFFFF,LINETHICK3;
买入:=XMA(VAR1,M)*(1-P2/1000),COLOR0000FF,LINETHICK3;

幅度:=100*(卖出-买入)/买入;
MA1:=MA(VAR1,3);
卖出XG:=CROSS(C,卖出);
机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0,LINETHICK2;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=REF(MA(RSV2,3),1)+(RSV2-REF(MA(RSV2,3),1))/3;
D2:=REF(MA(K2,3),1)+(K2-REF(MA(K2,3),1))/3;
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
金叉:=CROSS(BB1,BB2);
买入XG:=CROSS(C,买入) AND BB1>BB2 AND C>REF(O,2);
绝杀点XG:CROSS(C,买入) AND金叉 AND 机会来临;














N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,N)*(1+P1/1000),COLORFFFFFF,LINETHICK3;
买入:=XMA(VAR1,M)*(1-P2/1000),COLOR0000FF,LINETHICK3;

幅度:=100*(卖出-买入)/买入;
MA1:=MA(VAR1,3);
卖出XG:=CROSS(C,卖出);
机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0,LINETHICK2;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=REF(MA(RSV2,3),1)+(RSV2-REF(MA(RSV2,3),1))/3;
D2:=REF(MA(K2,3),1)+(K2-REF(MA(K2,3),1))/3;
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
金叉:=CROSS(BB1,BB2);
买入XG:CROSS(C,买入) AND BB1>BB2 AND C>REF(O,2);










N:=20;M:=32;P1:=80;P2:=100;
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,N)*(1+P1/1000),COLORFFFFFF,LINETHICK3;
买入:=XMA(VAR1,M)*(1-P2/1000),COLOR0000FF,LINETHICK3;

幅度:=100*(卖出-买入)/买入;
MA1:=MA(VAR1,3);
卖出XG:CROSS(C,卖出);



举报

扔鸡蛋(0) 回复

中国饭店
Lv.4
发表于 2020-10-14 20:27 复制 查看全部楼层
买卖都含有XMA这种做出来选股应该也没多大意义吧。

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表