手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股指标

[通达信]
设置
870 2 一马平川66 Lv.2 发表于 · 2020-10-15 15:00 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师在下面副图指标,只要中线强势红色线在0轴上方,做条件选股。谢谢。

XA_1:=IF(CLOSE<OPEN,(CLOSE-OPEN)/OPEN,0);
XA_2:=IF(CLOSE>OPEN,(CLOSE-OPEN)/OPEN,0);
XA_3:=IF(CLOSE>OPEN,(OPEN-LOW)/OPEN,(CLOSE-LOW)/OPEN);
XA_4:=IF(CLOSE>OPEN,(HIGH-CLOSE)/OPEN,(HIGH-OPEN)/OPEN);
XA_5:=IF(BARSLAST(CLOSE>MA(CLOSE,20))>34,34,BARSLAST(CLOSE>MA(CLOSE,20)));
XA_6:=IF(BARSLAST(CLOSE>MA(CLOSE,60))>120,120,BARSLAST(CLOSE>MA(CLOSE,60)));
XA_7:=IF(COUNT(CLOSE>0,250)<240,CAPITAL,SUM(VOL,480)/8);
XA_8:=MA(LOW,20)*1.2;
XA_9:=MA(LOW,20)*1.1;
XA_10:=MA(HIGH,20)*0.9;
XA_11:=MA(HIGH,20)*0.8;
XA_12:=CLOSE/(1+(CLOSE/MA(CLOSE,240)-1)-MA(INDEXC/MA(INDEXC,240)-1,3));
短线上攻:IF(BARSLAST(CLOSE>XA_9)<4 AND CLOSE>MA(CLOSE,5) AND BARSLAST(CLOSE=HHV(CLOSE,21))<4,(MA(CLOSE,5)-REF(MA(CLOSE,5),1))/REF(MA(CLOSE,5),1)*300,0),COLORMAGENTA;
中线强势:(CLOSE/XA_12-1)*50,COLORRED,LINETHICK2;
中线控盘:MA(IF(CLOSE>MA(CLOSE,240) AND (CLOSE-MA(CLOSE,240))/MA(CLOSE,240)+SUM(XA_1,20)>0,((CLOSE-MA(CLOSE,240))/MA(CLOSE,240)+SUM(XA_1,20))/MA(VOL/XA_7,20)/2.5,0),10),COLORYELLOW,LINETHICK2;
短线超跌:IF(CLOSE<MA(CLOSE,20),((REF(CLOSE,XA_5)-CLOSE)/REF(CLOSE,XA_5)+SUM(XA_3,XA_5)-SUM(XA_4,XA_5))*20,0),COLORBLUE,LINETHICK2;
中线超跌:(REF(CLOSE,XA_6)-CLOSE)/CLOSE*2,COLORGREEN,LINETHICK2;
STICKLINE(中线强势>0,0,中线强势,0.7,0),COLORRED;
STICKLINE(中线控盘>0,0,中线控盘,0.7,0),COLORYELLOW;
STICKLINE(短线上攻>0,0,短线上攻,0.7,0),COLORMAGENTA;
STICKLINE(中线超跌>0,0,中线超跌,0.7,0),COLORGREEN;
STICKLINE(短线超跌>0,0,短线超跌,0.8,0),COLORBLUE;

举报

扔鸡蛋(0) 回复

一马平川66
Lv.2
发表于 2020-10-15 15:36 复制 查看全部楼层
谢谢许昌舍得老师的帮助,中线强势站在0轴上就有希望,谢谢老师。

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-15 15:07 复制 查看全部楼层
XA_1:=IF(CLOSE<OPEN,(CLOSE-OPEN)/OPEN,0);
XA_2:=IF(CLOSE>OPEN,(CLOSE-OPEN)/OPEN,0);
XA_3:=IF(CLOSE>OPEN,(OPEN-LOW)/OPEN,(CLOSE-LOW)/OPEN);
XA_4:=IF(CLOSE>OPEN,(HIGH-CLOSE)/OPEN,(HIGH-OPEN)/OPEN);
XA_5:=IF(BARSLAST(CLOSE>MA(CLOSE,20))>34,34,BARSLAST(CLOSE>MA(CLOSE,20)));
XA_6:=IF(BARSLAST(CLOSE>MA(CLOSE,60))>120,120,BARSLAST(CLOSE>MA(CLOSE,60)));
XA_7:=IF(COUNT(CLOSE>0,250)<240,CAPITAL,SUM(VOL,480)/8);
XA_8:=MA(LOW,20)*1.2;
XA_9:=MA(LOW,20)*1.1;
XA_10:=MA(HIGH,20)*0.9;
XA_11:=MA(HIGH,20)*0.8;
XA_12:=CLOSE/(1+(CLOSE/MA(CLOSE,240)-1)-MA(INDEXC/MA(INDEXC,240)-1,3));
短线上攻:=IF(BARSLAST(CLOSE>XA_9)<4 AND CLOSE>MA(CLOSE,5) AND BARSLAST(CLOSE=HHV(CLOSE,21))<4,(MA(CLOSE,5)-REF(MA(CLOSE,5),1))/REF(MA(CLOSE,5),1)*300,0),COLORMAGENTA;
中线强势:(CLOSE/XA_12-1)*50>0;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表