手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这指标改成通达信选股公式

[通达信]
设置
1158 2 黄个111 Lv.2 发表于 · 2020-10-15 19:57 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
XA_1:=30;
XA_2:=60;
XA_3:=(CLOSE-LLV(LOW,XA_1))/(HHV(HIGH,XA_1)-LLV(LOW,XA_1))*100;
XA_4:=SMA(XA_3,5,1);
XA_5:=SMA(XA_4,3,1);
XA_6:=3*XA_4-2*XA_5;
做空线:EMA(XA_6,6),COLORGREEN;
XA_7:=REF(LOW,1);
XA_8:=SMA(ABS(LOW-XA_7),3,1)/SMA(MAX(LOW-XA_7,0),3,1)*100;
XA_9:=EMA(IF(CLOSE*1.3,XA_8*10,XA_8/10),3);
XA_10:=LLV(LOW,30);
XA_11:=HHV(XA_9,30);
XA_12:=IF(MA(CLOSE,58),1,0);
XA_13:=EMA(IF(LOW<=XA_10,(XA_9+XA_11*2)/2,0),3)/618*XA_12;
XA_14:=IF(XA_13>100,100,XA_13);
XA_15:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
XA_16:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
XA_17:=SMA(XA_16,13,8);
做多线:CEILING(SMA(XA_17,13,8)),COLORYELLOW,LINETHICK3;
XA_18:=SMA(XA_15,21,8);
买关注:STICKLINE(做多线-XA_18<(-65),0,7,1,0),COLORLIRED;
资金进场:买关注;
DRAWICON(FILTER(XA_6<REF(XA_6,1) AND 做多线<=REF(做多线,1) AND XA_6>85,5),XA_6,2);
DRAWICON(做多线,XA_6,2);
XA_19:=(CLOSE*2+HIGH+LOW)/4*10;
XA_20:=EMA(XA_19,13)-EMA(XA_19,34);
XA_21:=EMA(XA_20,5);
XA_22:=2*(XA_20-XA_21)*5.5;
XA_23:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
XA_24:=EMA(3*XA_23-2*SMA(XA_23,18,1),5);
XA_25:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
XA_26:=(INDEXC*2+INDEXH+INDEXL)/4;
XA_27:=EMA(XA_26,13)-EMA(XA_26,34);
XA_28:=EMA(XA_27,3);
XA_29:=(XA_27-XA_28)/2;
XA_30:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
XA_31:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
XA_32:=MA(CLOSE,80)-MA(CLOSE,10)/3;
XA_33:=CLOSE<XA_32 AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;
XA_34:=IF(XA_33,1,0)*15;
DRAWTEXT(XA_34,15,1),COLORWHITE;
买入信号:IF(CROSS(3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),10),70,0),COLORRED,LINETHICK2;
STICKLINE(买入信号,82,0,0.005,0),COLORYELLOW;
DRAWICON(买入信号>0,80,26);
DRAWICON(买入信号>0,78,26);
DRAWICON(买入信号>0,76,26);
DRAWICON(买入信号>0,74,26);
DRAWICON(买入信号>0,72,26);
DRAWICON(买入信号>0,30,5);
DRAWICON(买入信号>0,29.5,5);
DRAWICON(买入信号>0,29,5);
DRAWICON(买入信号>0,28.5,5);
DRAWICON(买入信号>0,28,5);
DRAWICON(买入信号>0,27.5,5);
DRAWICON(买入信号>0,27,5);
DRAWICON(买入信号>0,26.5,5);
DRAWICON(买入信号>0,26,5);
DRAWICON(买入信号>0,25.5,5);
DRAWICON(买入信号>0,25,5);
DRAWICON(买入信号>0,24.5,5);
DRAWICON(买入信号>0,24,5);
DRAWICON(买入信号>0,23.5,5);
DRAWICON(买入信号>0,23,5);
DRAWICON(买入信号>0,22.5,5);
DRAWICON(买入信号>0,22,5);
DRAWICON(买入信号>0,21.5,5);
DRAWICON(买入信号>0,21,5);
DRAWICON(买入信号>0,20.5,5);
DRAWICON(买入信号>0,20,5);
DRAWICON(买入信号>0,19.5,5);
DRAWICON(买入信号>0,19,5);
DRAWICON(买入信号>0,18.5,5);
DRAWICON(买入信号>0,18,5);
DRAWICON(买入信号>0,17.5,5);
DRAWICON(买入信号>0,17,5);
DRAWICON(买入信号>0,16.5,5);
DRAWICON(买入信号>0,16,5);
DRAWICON(买入信号>0,15.5,5);
DRAWICON(买入信号>0,15,5);
DRAWICON(买入信号>0,14.5,5);
DRAWICON(买入信号>0,14,5);
DRAWICON(买入信号>0,13.5,5);
DRAWICON(买入信号>0,13,5);
DRAWICON(买入信号>0,12.5,5);
DRAWICON(买入信号>0,12,5);
DRAWICON(买入信号>0,11.5,5);
DRAWICON(买入信号>0,11,5);
DRAWICON(买入信号>0,10.5,5);
DRAWICON(买入信号>0,10,5);
DRAWICON(买入信号>0,9.5,5);
DRAWICON(买入信号>0,9,5);
DRAWICON(买入信号>0,8.5,5);
DRAWICON(买入信号>0,8,5);
DRAWICON(买入信号>0,7.5,5);
DRAWICON(买入信号>0,7,5);
DRAWICON(买入信号>0,6.5,5);
DRAWICON(买入信号>0,6,5);
DRAWICON(买入信号>0,5.5,5);
DRAWICON(买入信号>0,5,5);
DRAWICON(买入信号>0,4.5,5);
DRAWICON(买入信号>0,4,5);
DRAWICON(买入信号>0,3.5,5);
DRAWICON(买入信号>0,3,5);
DRAWICON(买入信号>0,2.5,5);
DRAWICON(买入信号>0,2,5);
DRAWICON(买入信号>0,1.5,5);
DRAWICON(买入信号>0,1,5);
DRAWICON(买入信号>0,0.5,5);
DRAWICON(买入信号>0,0,5);
STICKLINE(买入信号,4,(-2),6,0),COLORYELLOW;
STICKLINE(买入信号,4,(-2),0.5,0),COLORRED;
DRAWTEXT(买入信号,20,2),COLORGREEN;

举报

扔鸡蛋(0) 回复

黄个111
Lv.2
发表于 2020-10-15 22:31 复制 查看全部楼层
谢谢许老师

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-15 21:15 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-10-15 21:17 编辑

买入信号:CROSS(3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),10);

附件

tdxjietu2.JPG
查看全部打赏
  • 黄个111+2理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表