手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写两个选股公式

[通达信]
设置
1113 5 豆宝霸霸 Lv.2 发表于 · 2020-10-15 21:46 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 豆宝霸霸 于 2020-10-15 21:50 编辑

要求如下:
大飞龙:月KD在80上方+周KD在80上方+日KD金叉
小飞龙:月KD在80上方+周KD向上+日KD金叉
公式如下:
月K>80 K>80 AND REF(C,24)>1
周KD在80上方 K>80
日KD金叉CROSS(K,D) AND K<80 AND K>20 AND D>20
周KD向上K>D

麻烦老师给改成通达信可以用的公式吧

举报

扔鸡蛋(0) 回复

一不做
Lv.4
发表于 2020-10-17 14:07 复制 查看全部楼层
豆宝霸霸 发表于 2020-10-16 12:25
老师 这样对吗
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);

@许昌 老师说的“长度”,应该是时间长度吧。时间区间拉长。我的理解。

举报

点亮(0) 扔鸡蛋(0) 回复

豆宝霸霸
Lv.2
发表于 2020-10-16 12:25 复制 查看全部楼层
许昌舍得 发表于 2020-10-16 09:20
加大选股时段长度   发你的案例截图(股票名称信号位置)

老师 这样对吗
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
小飞龙:K#MONTH>80 AND K#WEEK>REF(K#WEEK,1) AND CROSS(K,D);


RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
大飞龙:K#MONTH>80 AND K#WEEK>80 AND CROSS(K,D);

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-16 09:20 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-10-16 09:53 编辑
豆宝霸霸 发表于 2020-10-16 07:12
老师你好,选不出股是因为没有符合条件的吗


加大选股时段长度   发你的案例截图(股票名称信号位置)

举报

点亮(0) 扔鸡蛋(0) 回复

豆宝霸霸
Lv.2
发表于 2020-10-16 07:12 复制 查看全部楼层
许昌舍得 发表于 2020-10-15 21:53
大飞龙:KD.K#MONTH>80 AND KD.K#WEEK>80 AND CROSS(KD.K,KD.D);

老师你好,选不出股是因为没有符合条件的吗

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-15 21:53 复制 查看全部楼层
大飞龙:KD.K#MONTH>80 AND KD.K#WEEK>80 AND CROSS(KD.K,KD.D);



小飞龙:KD.K#MONTH>80 AND KD.K#WEEK>REF(KD.K#WEEK,1) AND CROSS(KD.K,KD.D);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表