手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙根据这个指标做个选股公式

[通达信]
设置
1214 3 百度321 Lv.3 发表于 · 2020-10-16 09:04 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请大神帮忙把这个指标做个选股公式 出红箭头的位置  如图


N:=9;M1:=3;M2:=3;金波:=EMA((3)*(MA(CLOSE,3)) - (2)*(MA(CLOSE,6)),1),COLOR0000FF,LINETHICK1;TIAOJIAN1:=C=HHV(C,60);DAYS11:=BARSLAST(TIAOJIAN1);跌50﹪:=L<REF(C,DAYS11)/1.64;跌60:CURRBARSCOUNT<=10 AND L<REF(C,DAYS11)/1.68 AND 金波<H AND O>C AND REF(O,1)>=REF(C,1);P:=21;WH1:=IF(L=LLV(L,P),L,DRAWNULL);WH2:=CONST(BARSLAST(WH1!=DRAWNULL));WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100; 0,COLOR9000F5; K:SMA(RSV,M1,1),COLORWHITE; D:SMA(K,M2,1),COLORYELLOW; J:3*K-2*D,COLORGREEN; A1:=BARSLAST(REF(CROSS(J,0),1));底背离:=REF(CLOSE,A1+1)>CLOSE AND J>REF(J,A1+1) AND CROSS(J,0); J背离上穿0买: IF(底背离 AND LLV(J,7)>LLV(J,30),100,0),COLORRED,LINETHICK2; DRAWTEXT(底背离,J-25,底背离),COLOR9000F5;进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORRED;IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,P),L,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORRED;DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),进场,'进场线'),COLORRED;超跌进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH4=0,H,REF(H,WH4))),DRAWNULL),COLORCB21BE;DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),'超跌进场','超跌进场线'),COLORCB21BE;H1:=IF(H=HHV(H,P),H,DRAWNULL);H2:=CONST(BARSLAST(H1!=DRAWNULL));H3:=CONST(IF(H2=0,L,REF(L,H2)));H4:=CONST(REF(BARSLAST(L<H3),H2+1)+H2+1);H5:=CONST(IF(H4=0,L,REF(L,H4)));H6:=CONST(REF(BARSLAST(L<H5),H4+1)+H4+1);止损:IF(CURRBARSCOUNT<=H2+21,CONST(IF(H6=0,L,REF(L,H6))),DRAWNULL) AND J背离上穿0买 AND 跌60,COLORYELLOW;IF(CURRBARSCOUNT<=H2+1,IF(H=HHV(H,P),H,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORBLUE;DRAWTEXT(CURRBARSCOUNT=INTPART((H2+21)*0.618),'止损','止损线'),COLORYELLOW;

附件

360截图20201016090430086.jpg

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-16 10:44 复制 查看全部楼层
百度321 发表于 2020-10-16 10:06
老师帮忙看看这个选股指标是不是有未来函数  我用未来函数测试过似乎没有但在实际使用中和后期复盘的结 ...

低点的判断过程就有未来的性质

举报

扔鸡蛋(0) 回复

百度321
Lv.3
发表于 2020-10-16 10:06 复制 查看全部楼层


老师帮忙看看这个选股指标是不是有未来函数  我用未来函数测试过似乎没有但在实际使用中和后期复盘的结果却不太一样  请老师帮帮忙  看看是否有隐藏的未来函数
万分感谢

低点:=IF(CURRBARSCOUNT<=60,CONST(IF(ISLASTBAR=1,LLV(L,BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
准备赚钱:=(AV + NEWVOL);
AA:=REF(BARSLAST(NOT(L<REF(L,1)))>=3,1) AND CROSS(C,REF(C,1));
地量:=V=LLV(V,30) AND V>0 AND BARSCOUNT(V)>=30;
赚钱:REF(CCI<=100 AND L<=低点,1) AND FILTERX(CROSS(准备赚钱,0),5);

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-16 09:37 复制 查看全部楼层
N:=9;
M1:=3;
M2:=3;
金波:=EMA((3)*(MA(CLOSE,3)) - (2)*(MA(CLOSE,6)),1),COLOR0000FF,LINETHICK1;
TIAOJIAN1:=C=HHV(C,60);
DAYS11:=BARSLAST(TIAOJIAN1);
跌50﹪:=L<REF(C,DAYS11)/1.64;
跌60:=CURRBARSCOUNT<=10 AND L<REF(C,DAYS11)/1.68 AND 金波<H AND O>C AND REF(O,1)>=REF(C,1);
P:=21;
WH1:=IF(L=LLV(L,P),L,DRAWNULL);
WH2:=CONST(BARSLAST(WH1!=DRAWNULL));
WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));
WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);
WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));
WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1),COLORWHITE;
D:=SMA(K,M2,1),COLORYELLOW;
J:=3*K-2*D,COLORGREEN;
A1:=BARSLAST(REF(CROSS(J,0),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND J>REF(J,A1+1) AND CROSS(J,0);
J背离上穿0买: 底背离 AND LLV(J,7)>LLV(J,30);
查看全部打赏
  • 百度321+10理想币 : 万分感谢 实在是帮了大忙了

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表