手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将下面公式5%预警的条件给去除

[通达信]
设置
1049 4 隔壁老马 Lv.3 发表于 · 2020-10-16 14:11 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师将下面公式5%预警的条件给去除。谢谢!
MA10:=MA(CLOSE,50);
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);
HJ_10:=BARSLAST(HJ_9);
HJ_11:=REF(HIGH,HJ_10+2);
HJ_12:=REF(HIGH,HJ_10+1);
HJ_13:=REF(HIGH,HJ_10);
HJ_14:=MAX(HJ_11,HJ_12);
HJ_15:=MAX(HJ_14,HJ_13);
HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
HJ_17:=HJ_10<150;
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
HJ_21:=VOL/MA(VOL,5)<3.5;
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
BL:=FILTER(HJ_25,15);
MA54:=MA(CLOSE,54);
PL1:=(((CLOSE-MA54)/MA54)<0.1);
PL2:=(((CLOSE-MA10)/MA10)<0.3);
PLL:=(((PL1=1) AND (PL2=1))*0.2);
PTTP:=((((PLL=0) AND (REF(PLL,1)=0.2)) AND (REF((COUNT((PLL=0.2),10)=10),1)=1))*-0.1);
YGTP:=PTTP=-0.1;
XDF:=(BL OR YGTP);
VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
YG:=XDF AND FLIGA ;
M5:=MA(C,5);
M8:=MA(C,8);
M13:=MA(C,13);
M21:=MA(C,21);
M34:=MA(C,34);
M55:=MA(C,55);
VAR1:=O<=M5 AND C>M5;
VAR2:=O<=M8 AND C>M8;
VAR3:=O<=M13 AND C>M13;
VAR4:=O<=M21 AND C>M21;
VAR5:=O<=M34 AND C>M34;
VAR6:=O<=M55 AND C>M55;
CD:=(VAR1+VAR2+VAR3+VAR4+VAR5+VAR6)>3;
X1A_1:=IF(CLOSE>REF(CLOSE,1),88,0);
X1A_2:=IF(CLOSE/REF(CLOSE,1)>1.03 AND HIGH/CLOSE<1.01 AND X1A_1>0,91,0);
LT:=FILTER(X1A_2>90,45)=1;


触底:CD AND YG ;

举报

扔鸡蛋(0) 回复

区坤
Lv.4
发表于 2020-10-16 20:36 复制 查看全部楼层
1016.png

举报

扔鸡蛋(0) 回复

区坤
Lv.4
发表于 2020-10-16 20:35 复制 查看全部楼层
隔壁老马 发表于 2020-10-16 15:01
有问题,选拔出股票。

选股没问题的,按我给的公式今天选出5只个股。

举报

点亮(0) 扔鸡蛋(0) 回复

隔壁老马
Lv.3
发表于 2020-10-16 15:01 复制 查看全部楼层
区坤 发表于 2020-10-16 14:19
MA10:=MA(CLOSE,50);
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);

有问题,选拔出股票。

举报

扔鸡蛋(0) 回复

区坤
Lv.4
发表于 2020-10-16 14:19 复制 查看全部楼层
MA10:=MA(CLOSE,50);
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);
HJ_10:=BARSLAST(HJ_9);
HJ_11:=REF(HIGH,HJ_10+2);
HJ_12:=REF(HIGH,HJ_10+1);
HJ_13:=REF(HIGH,HJ_10);
HJ_14:=MAX(HJ_11,HJ_12);
HJ_15:=MAX(HJ_14,HJ_13);
{HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;}
HJ_17:=HJ_10<150;
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
HJ_21:=VOL/MA(VOL,5)<3.5;
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
HJ_25:={HJ_16 AND }HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
BL:=FILTER(HJ_25,15);
MA54:=MA(CLOSE,54);
PL1:=(((CLOSE-MA54)/MA54)<0.1);
PL2:=(((CLOSE-MA10)/MA10)<0.3);
PLL:=(((PL1=1) AND (PL2=1))*0.2);
PTTP:=((((PLL=0) AND (REF(PLL,1)=0.2)) AND (REF((COUNT((PLL=0.2),10)=10),1)=1))*-0.1);
YGTP:=PTTP=-0.1;
XDF:=(BL OR YGTP);
VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
YG:=XDF AND FLIGA ;
M5:=MA(C,5);
M8:=MA(C,8);
M13:=MA(C,13);
M21:=MA(C,21);
M34:=MA(C,34);
M55:=MA(C,55);
VAR1:=O<=M5 AND C>M5;
VAR2:=O<=M8 AND C>M8;
VAR3:=O<=M13 AND C>M13;
VAR4:=O<=M21 AND C>M21;
VAR5:=O<=M34 AND C>M34;
VAR6:=O<=M55 AND C>M55;
CD:=(VAR1+VAR2+VAR3+VAR4+VAR5+VAR6)>3;
X1A_1:=IF(CLOSE>REF(CLOSE,1),88,0);
X1A_2:=IF(CLOSE/REF(CLOSE,1)>1.03 AND HIGH/CLOSE<1.01 AND X1A_1>0,91,0);
LT:=FILTER(X1A_2>90,45)=1;


触底:CD AND YG ;

请参考。

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表