手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个'显示macd金叉死叉周期数'的公式

[通达信]
设置
1141 3 蓝315 Lv.4 发表于 · 2020-10-16 18:40 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙写个macd指标“在0轴或者DIF、DEA的交叉点显示金叉到死叉(死叉到金叉)周期数”的公式,谢谢!

举报

扔鸡蛋(0) 回复

蓝315
Lv.4
发表于 2020-10-16 20:36 复制 查看全部楼层
许昌舍得 发表于 2020-10-16 20:10
或距离标注

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);

十分感谢老师的帮助!谢谢!谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-16 20:10 复制 查看全部楼层
或距离标注

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;

JC:=CROSS(DIF>DEA,0.5);
SC:=CROSS(DEA>DIF,0.5);
T1:=BARSLAST(JC);
T2:=BARSLAST(SC);


DRAWNUMBER(JC,-0.1,T2),COLORRED;
DRAWNUMBER(SC,+0.1,T1),COLORGREEN;

附件

tdxjietu2.JPG

举报

点亮(2) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-16 20:01 复制 查看全部楼层
JC:=CROSS(DIF>DEA,0.5);
SC:=CROSS(DEA>DIF,0.5);
T1:=BARSLAST(JC);
T2:=BARSLAST(SC);
DRAWNUMBER(DIF>DEA,-0.1,T1+1),COLORRED;
DRAWNUMBER(DIF<DEA,+0.1,T2+1),COLORGREEN;

附件

tdxjietu1.JPG

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表