手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助根据指标编写个选股公式

[大智慧]
设置
1080 2 够小成 Lv.4 发表于 · 2020-10-16 23:36 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
1   麻烦把不破则入 ,破了观察 搞个选股 必须是当天可以选出。感谢高手帮助  ,还有买入信号。
买:=IF("KDJ.J"<0,10,0);
条件:=CROSS(9.9,买);
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=LLV(LOW,5);
VAR3:=HHV(HIGH,5);
VAR4:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,5);
MA1:=MA(VAR4,2);
AA:STICKLINE(VAR4>MA1,VAR4,MA1,6,1),COLORRED;
BBB:STICKLINE(VAR4>MA1 AND REF(VAR4,1)<30,VAR4,MA1,6,1),COLORRED;
STICKLINE(VAR4<=MA1,VAR4,MA1,6,1),COLORFFCC66;
DRAWICON(CROSS(9.9,买),VAR4-12,4);
STICKLINE(CROSS(9.9,买),VAR4+5,MA1-4,6,1),COLORYELLOW;
XXX:STICKLINE(VAR4>MA1 AND REF(VAR4,1)<30,VAR4+5,MA1-4,6,1),COLORYELLOW;
DRAWTEXT(CROSS(MA(C,20)*1.005,MA(C,5)) AND MA(C,5)>=MA(C,20),L,'不破则入,破了观察'),COLORMAGENTA;



2 这个选股指标不知道什么原因 ,比如今天选股 选出的票应该今天出信号的票 ,可是前几天的票也有 ,麻烦高手看看是否可以只是选出当日出信号的票,感谢
MAA10:=MA(C,10);
MAA30:=MA(C,30);
KS:=IF(MAA10>MAA30,MAA10,MAA30);
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
跟庄买进:FILTER(买=1,5);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-17 07:04 复制 查看全部楼层
破了观察:CROSS(MA(C,20)*1.005,MA(C,5)) AND MA(C,5)>=MA(C,20);

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-10-17 06:49 复制 查看全部楼层
本帖最后由 注册111 于 2020-10-17 06:56 编辑

1
买:=IF("KDJ.J"<0,10,0);
条件:=CROSS(9.9,买);
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=LLV(LOW,5);
VAR3:=HHV(HIGH,5);
VAR4:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,5);
MA1:=MA(VAR4,2);
CROSS(MA(C,20)*1.005,MA(C,5)) AND MA(C,5)>=MA(C,20);

2
没问题,当天能选出的。二次信号至少间隔5天,觉得间隔5天太短,把最后一项中数字5放大。

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表