手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将技术指标改写选股指标

[通达信]
设置
1341 1 星火燎渊 Lv.2 发表于 · 2020-10-17 09:41 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
各位老师,请把下面指标图中出现“黄色”柱子为条件,改个选股公式

最好是能做两个,一个是出现一个  黄色柱子,选出来。另一个是连续出现两个  黄色柱子选出来。

如果不好做,那就改一个就行,只要出现黄色柱子选出来就行。

源码
{波段极限}DRAWGBK(CURRBARSCOUNT=1, RGB(110,108,108),RGB(88,30,0),0,'',0);STICKLINE(C>0.1,0,100,4.8,0),COLOR668800;STICKLINE(C>0.1,-5,0,4.8,0),COLORFFB06C;VAR11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);VAR21:=SMA(ABS(LOW-VAR11),13,1)/SMA(MAX(LOW-VAR11,0),10,1);VAR31:=EMA(VAR21,10);VAR41:=LLV(LOW,33);VAR51:=EMA(IF(LOW<=VAR41,VAR31,0),3);主力进场:=IF(VAR51>REF(VAR51,1),VAR51,0),COLORRED,NODRAW;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0 ),COLOR000055;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.6,0 ),COLOR000077;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.1,0 ),COLOR000099;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.5,0 ),COLOR0000BB;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.9,0 ),COLOR0000DD;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.3,0 ),COLOR0000FF;洗盘:=IF(VAR51<REF(VAR51,1),VAR51,0),COLORGREEN,NODRAW;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,3,0),COLOR005500;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.6,0),COLOR007700;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.1,0),COLOR009900;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,1.5,0),COLOR00BB00;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.9,0),COLOR00DD00;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.3,0),COLOR00FF00;VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;火:=BARSLAST(EMA(CLOSE,5)<REF(EMA(CLOSE,5),1)),NODRAW;山:=COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),5),NODRAW;KL:=IF(山>0,2*火,0);趋势:=KL/2,COLOREE687B,NODRAW;VARL1:=(EMA(C,12)-EMA(C,26))*100+50;VARL2:=EMA(VARL1,9);VARL3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;VARL4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;VARL5:=SMA(VARL4,13,8);VARL6:=SMA(VARL3,21,8);低位线:=IF((趋势-VARL6<(-70)),0,-5);DRAWBAND(低位线,RGB(00,300,150),-5,RGB(00,300,150));QS:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);高位线:=IF((QS-VARL6>85),0,-5);DRAWBAND(高位线,RGB(255,20,147),-5,RGB(255,20,147));K1:EMA(VAR2,5),COLORLIBLUE,NODRAW;K2:SMA(VAR2,5,1),COLORYELLOW,NODRAW;K:EMA((K1-K2),2),COLORWHITE,NODRAW;DRAWBAND(85,RGB(100,100,100),85+K,RGB(128,00,00));KK1:=IF(K>12,90,85),COLORCYAN;KK2:=IF(K<-12,80,85),COLORCYAN;DRAWBAND(KK1,RGB(200,200,200),KK2,RGB(200,200,200));DRAWBAND(K1,RGB(400,200,00),K2,RGB(50,300,100));STICKLINE(C>0.1,15,15,1,0),COLORCYAN;STICKLINE(C>0.1,50,50,1,0),COLORCYAN;LC:=REF(CLOSE,1);VAR01:=C-REF(C,1);VAR02:=100*EMA(EMA(VAR01,6),6)/EMA(EMA(ABS(VAR01),6),6);MA5:=EMA(C,5);MA13:=EMA(C,13);UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;BT:=(LLV(VAR02,2)=LLV(VAR02,7) AND COUNT(VAR02<0,2) AND CROSS(VAR02,MA(VAR02,2))) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);STICKLINE(BT,85,100,2,0),COLOR000088;STICKLINE(BT,85,100,1,0),COLOR0000CC;STICKLINE(BT,85,100,0.22,0),COLOR0000FF;TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;STICKLINE(TJ1,85,95,3,0),COLOR880088;STICKLINE(TJ1,85,95,1.5,0),COLORAA00AA;STICKLINE(TJ1,85,95,0.8,0),COLORCC00CC;STICKLINE(TJ1,85,95,0.2,0),COLORFF00FF;HR:=HHV(HIGH,55);HRY:=LLV(LOW,55);HRY11:=HR*HRY;HRY33:=SQRT(HRY11);TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;STICKLINE(TJ2,85,90,4,0),COLOR008888;STICKLINE(TJ2,85,90,2,0),COLOR00AAAA;STICKLINE(TJ2,85,90,1,0),COLOR00CCCC;STICKLINE(TJ2,85,90,0.2,0),COLOR00FFFF;{HZ_买底1}A8:=100*EMA(EMA((C-REF(C,1)),6),6)/EMA(EMA(ABS((C-REF(C,1))),6),6);UP1:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(EMA(CLOSE,19),EMA(CLOSE,7)))+1),LLV(L,BARSLAST(CROSS(EMA(CLOSE,19),EMA(CLOSE,7)))+1),H=HHV(H,BARSLAST(CROSS(EMA(CLOSE,7),EMA(CLOSE,19)))+1),HHV(H,BARSLAST(CROSS(EMA(CLOSE,7),EMA(CLOSE,19)))+1),0);DOWN1:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(EMA(CLOSE,7),EMA(CLOSE,19)))+1),HHV(H,BARSLAST(CROSS(EMA(CLOSE,7),EMA(CLOSE,19)))+1),L=LLV(L,BARSLAST(CROSS(EMA(CLOSE,19),EMA(CLOSE,7)))+1),LLV(L,BARSLAST(CROSS(EMA(CLOSE,19),EMA(CLOSE,7)))+1),0);买1:=IF((LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2))) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1),DRAWNULL,100);STICKLINE(买1=100,0,5,4,0),COLOR00AAAA;STICKLINE(买1=100,0,5,2.5,0),COLOR00CCCC;STICKLINE(买1=100,0,5,0.5,0),COLOR00FFFF;MAC5:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);M5:=MA(MAC5,5);M60:=LLV(MA(MAC5,60),10);A:=(HHV(M5,3)-LLV(M5,3))/LLV(M5,3)<1.4 AND M5>REF(M5,1);B:=REF(MAC5,3)/REF(MAC5,2)<1.1 AND REF(M5,3)/REF(M5,2)<1.1 AND CROSS(MAC5,M5);XD1:=HHVBARS(M5,5)=1;{以N日最低点}XD2:=REF(COUNT(M5-REF(M5,1)<=0,5)=1,10) AND COUNT(M5-REF(M5,1)>0,5)=1;{以M日变化量的正负}XD3:=REF(COUNT(M5-REF(M5,1)<=0,5)=1,10) AND M5>0;{以当日变化角的正负};AA:=PLOYLINE(CROSS(MAC5,M5),M5),COLORRED;AAB:=PLOYLINE(CROSS(M5,MAC5),MAC5),COLORFF00FF ;大涨区:=COUNT(CROSS(MAC5,M5),AA<REF(AA,5) AND AAB>REF(AAB,5));STICKLINE(大涨区,0,20,3,0),COLORRED ;DRAWTEXT(大涨区,15,'角买'),COLOR00FF00;{MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);加仓:IF(FILTER(YXF=1,5),20,0),STICK,COLORLIBLUE,LINETHICK3;}A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;CQS:(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2)),LINETHICK2,COLORRED;RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;AK1:=SMA(RSV,3,1);AD1:=SMA(AK1,3,1);AJ1:=3*AK1-2*AD1;X1:=LLV(AJ1,2)=LLV(AJ1,8);Y1:=IF(CROSS(AJ1,REF(AJ1+0.01,1)) AND X1 AND AJ1<20,30,0);主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);VAR22:=LLV(LOW,10);VAR33:=HHV(HIGH,25);动能趋势线:=100*EMA((CLOSE-VAR22)/(VAR33-VAR22),4);DRAWTEXT(CROSS(动能趋势线,87.5),100,'●出局'),COLORGREEN;{信号}TT1:=IF((DATE<=1090314),1,0);VAR2H:=(CLOSE+HIGH+LOW)/(3);VAR3H:=(EMA(VAR2H,10))*(TT1);VAR4H:=(REF(VAR3H,1))*(TT1);STICKLINE(CROSS(VAR3H,VAR4H),L,L-0.3,3,1),COLORWHITE;VAR10H:=(MA(CLOSE,80)-(MA(CLOSE,10))/(3))*(TT1);DRAWTEXT(IF((CLOSE<VAR10H) AND ((VOL)/(240)>(MA(VOL,5))/(240)) AND (CLOSE>(REF(CLOSE,1))*(1.08)) AND (CLOSE<(MA(CLOSE,13))*(1.3)),1,0),30,'●抄底'),COLOR0000FF;AA1:=BARSCOUNT(C);DRAWTEXT((AA1+0)/34=FLOOR((AA1+0)/34),60,'☆'),COLORYELLOW;XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);XL3:=CROSS(XL2,(0 - 20));DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),30,'●买点');DRAWTEXT((XL3 > 0),25,'●绝对底部');X6:=REF(CLOSE,1);X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);X8:=CROSS(79,X7);X9:=FILTER(X8,4);DRAWTEXT(X9,90,'●出货'),COLOR9000F5;

附件

1.png
2.png

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-10-17 11:52 复制 查看全部楼层
{朋友,你所要求的两个公式都是一样的,只是副图图标不一样做多一个黄色柱子}

MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0);
A8:=100*EMA(EMA((C-REF(C,1)),6),6)/EMA(EMA(ABS((C-REF(C,1))),6),6);
XG: ((LLV(A8,2)=LLV(A8,7) && COUNT(A8<0,2) && CROSS(A8,MA(A8,2))) && REF(DOWN,1)<REF(DOWN,2) && UP>REF(DOWN,1))=0;
查看全部打赏
  • 星火燎渊+5理想币 +1共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表