手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股,此公式指标k线站在绿线上(如10月14日的300591)

[通达信]
设置
1245 2 人间正道1 Lv.3 发表于 · 2020-10-17 10:25 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
N:=5;M:=3;
{DRAWGBKLAST(C > 0,'$RGB(60,60,60)$RGB(0,0,0)$0');
DRAWGBKLAST((("RSI.RSI2") > ("RSI.RSI3")) AND (("RSI.RSI3") > (60.5)),'$RGB(0,0,0)$RGB(100,100,100)$1');}
VAR0:=((EMA(C,5)) * 7 + (EMA(C,10)) * 3) / 10;
VAR1:=IF((YEAR) >= (2025),0,1);
VAR2:=EMA(EMA(L,21) + (6.8) * (STD(L,2)),55);
VAR3:=EMA(((C / (VAR2)) * ((1.88) * C + L + O)) / (2.75),3);
VAR4:=(((VAR3) - (VAR2)) / (VAR2)) / 2;
VAR5:=(EMA((VAR3) - ((VAR4) * (VAR3)),5)) * (VAR1);
黄金轨道:(IF((VAR0) > (VAR5),VAR0,VAR5)) * (VAR1),LINETHICK2,COLORYELLOW;
上轨:IF(((VAR5) < (VAR0)) AND ((VAR5) < (C * (0.15))),(EMA(C,300)) - (3 * (STD(C,300))),VAR5),LINETHICK2,COLORYELLOW;
IF((VAR5) > (VAR0),上轨,DRAWNULL),COLOR00FF00,LINETHICK2;
开口XG:BARSLASTCOUNT(黄金轨道!=上轨)=1,NODRAW;
DRAWICON(开口XG,MIN(上轨,黄金轨道)*0.96,11);
VAR6:=(REF(C,1)) * (0.95);
VAR7:=(REF(C,3)) * (0.875);
VAR8:=MIN(VAR6,VAR7);
VAR9:=((SMA(MAX(C - (REF(C,1)),0),9,1)) / (SMA(ABS(C - (REF(C,1))),9,1))) * (100);
VAR10:=(((SMA(MAX(C - (REF(C,1)),0),24,1)) / (SMA(ABS(C - (REF(C,1))),24,1))) * (100)) * (VAR1);
IF((((VAR8) = (VAR6)) AND ((VAR0) > (VAR5))) AND ((VAR10) > (64.5)),上轨,DRAWNULL),COLORWHITE,LINETHICK2;
{STICKLINE((VAR6) = (VAR8),C,O,2.5,0),COLORBLUE;
STICKLINE((VAR6) = (VAR8),H,L,0,0),COLORBLUE;}
VAR11:=(EMA(DMA(((2.15) * C + L + H) / 4,(ABS((((3.48) * C + H + L) / 4) - (EMA(C,20)))) / (EMA(C,20))),200)) * (0.968 + 15 / (100));
{DRAWTEXT(((CROSS((HHV(H,13)) - (((HHV(H,13)) - (LLV(L,13))) * (0.382)),VAR5)) AND (C > (VAR5))) AND (H > (VAR11)),VAR5,'买入'),LINETHICK2,COLORWHITE;}
VAR12:=MA(C,26) + 2 * (STD(C,26));
VAR13:=((SMA(MAX(C - (REF(C,1)),0),14,1)) / (SMA(ABS(C - (REF(C,1))),14,1))) * (100);
VAR14:=(EMA(C,60) + EMA(C,120) + EMA(C,240) + EMA(C,480)) / 4;
VAR15:=VAR14 + (1.91) * (STD(VAR14,3));
VAR16:=(EMA(VAR15,12)) * (1.23);
STICKLINE((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND ((MA(C,1)) > (VAR16)),C,O,3,0),COLORRED;
STICKLINE((((VAR10) >= 65) AND (C = O)) AND ((MA(C,1)) > (VAR16)),C,O,3,0),COLORRED;
STICKLINE((((VAR10) > 65) AND ((VAR13) >= 65)) AND ((MA(C,1)) > (VAR16)),H,L,0,0),COLORRED;
STICKLINE(((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND ((VAR13) > (VAR10))) AND (C < 上轨),O,L,0,0),COLORRED;
STICKLINE(((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND ((VAR13) > (VAR10))) AND (C < 上轨),C,H,0,0),COLORRED;
VAR17:=(MA(C,3) + MA(C,6) + MA(C,12) + MA(C,24)) / 4;
{VAR17 + 3 * (STD(VAR17,10)),LINETHICK3;}
IF((VAR0) > (VAR5),VAR17 + 3 * (STD(VAR17,10)),DRAWNULL),COLORFF00FF,LINETHICK1;
VAR18:=(((((((((SMA(MAX(C - (REF(C,1)),0),24,1)) / (SMA(ABS(C - (REF(C,1))),24,1))) * (100)) > 65) AND ((VAR0) > (EMA(C,13)))) AND ((EMA(C,13)) > (EMA(C,55)))) AND ((VAR12) > (REF(VAR12,1)))) AND (C > (EMA((H + L + C) / 3,13)))) AND ((MA(C,5)) > (MA(C,10)))) AND ((CROSS(HHV(C,5),(MA(H,10)) * (1 + 5 / (100)))) AND ((((C - (REF(C,1))) / (REF(C,1))) * (100)) > (6.5)));
DRAWTEXT((VAR18) > 0,L,'涨停追击'),LINETHICK1,COLORYELLOW;
VAR19:=(EMA((C - (REF(C,1))) / (REF(C,3)),8)) * (100);
DRAWTEXT(((((((((C >= ((REF(C,1)) * (1.095))) AND (C = O)) AND (L < C)) AND (C > (VAR5))) AND ((VAR19) <= 6)) AND ((VAR19) > 1)) > 0) AND ((VAR9) > (VAR10))) AND ((VAR9) > (64.5)),C,'T字战法'),COLORYELLOW;
VAR20:=((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND (C > (VAR16))) AND (C > ((MA(H,30)) * (1 + 15 / (100))));
IF(((((VAR0) > (VAR5)) AND ((VAR20) > 0)) AND ((VAR17 + 3 * (STD(VAR17,10))) > (REF(VAR17 + 3 * (STD(VAR17,10)),1)))) AND ((VAR17 + 3 * (STD(VAR17,10))) > (HHV(MA(C,5),60))),VAR17 + 3 * (STD(VAR17,10)),DRAWNULL),COLORFF00FF,LINETHICK3;
{DRAWTEXT((((VAR6) = (VAR8)) AND (C > (MA(C,20)))) AND ((MA(C,5)) > (MA(C,20))),L,'反弹'),COLORWHITE;}

VAR22:=EMA(EMA(EMA(EMA(EMA((C - (REF(C,1))) / (REF(C,3)),8),2),2),2),3);
{DRAWTEXT(FILTER(((CROSS(EMA((C - (REF(C,1))) / (REF(C,3)),8),VAR22))) > 0,10),L,'抄底'),COLORYELLOW;}
DRAWTEXT_FIX(1,0,0.9,0,'所属板块:')COLOR00FFFF;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0.1,0.9,0,STRCAT(Z3,GNBLOCK)),COLOR00FFFF;
VAR23:=(REF((C - (REF(C,1))) / (REF(C,1)),1)) * (100);


STICKLINE(((((C >= ((REF(C,1)) * (1.095))) AND (C = O)) AND (L < C)) AND ((VAR19) > 1)) > 0,C,O,5,0),COLORWHITE;
STICKLINE(((((C >= ((REF(C,1)) * (1.095))) AND (C = O)) AND (L < C)) AND ((VAR19) > 1)) > 0,L,C,0,0),COLORWHITE;
STICKLINE(CROSS(VAR9,21),O,C,4,1),COLORWHITE;
VAR24:=COUNT((((C - (REF(C,1))) / (REF(C,1))) * (100)) > 8,120);

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.145,0,0,VAR24),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'【股票活跃度】 '),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.16,0,0,'级:   '),COLORYELLOW;
VAR25:=C * V;
VAR26:=EMA(((EMA(VAR25,3)) / (EMA(V,3)) + (EMA(VAR25,6)) / (EMA(V,6)) + (EMA(VAR25,12)) / (EMA(V,12)) + (EMA(VAR25,24)) / (EMA(V,24))) / 4,13);
VAR27:=(1.06) * (VAR26);
DRAWTEXT(((((C - (REF(C,1))) / (REF(C,1))) * (100)) > (5.5)) AND (CROSS((L / ((H + REF(C,1) + O) / 3)) * C,EMA((EMA(C,9)) * (1.14),5))),EMA(L - (0.15),1),'▲'),COLORF00FF0;
STICKLINE((((((C - (REF(C,1))) / (REF(C,1))) * (100)) > (8.5)) AND (CROSS(MA(C,1),(EMA(H,10)) * (1 + 5 / (100))))) AND (CROSS(MA(C,1),VAR27)),(L + H + O) / 3,O,3,0),COLORRED;
STICKLINE((((((C - (REF(C,1))) / (REF(C,1))) * (100)) > (8.5)) AND (CROSS(MA(C,1),(EMA(H,10)) * (1 + 5 / (100))))) AND (CROSS(MA(C,1),VAR27)),(L + H + O) / 3,C,3,0),COLORFF0099;
VAR28:=((C - (LLV(L,9))) / ((HHV(H,9)) - (LLV(L,9)))) * (100);
VAR29:=SMA(VAR28,3,1);
VAR30:=SMA(VAR29,3,1);
VAR31:=(3 * (VAR29)) - (2 * (VAR30));
VAR32:=((H - L) / (REF(C,1))) * (100);
VAR33:=((C - O) / (REF(C,1))) * (100);
VAR34:=((O - L) / (REF(C,1))) * (100);
VAR35:=((H - C) / (REF(C,1))) * (100);
VAR36:=(VAR32) / (1.5);
STICKLINE(((((((VAR32) > 7) AND ((VAR36) > (4.5))) AND ((VAR35) < (5.5))) AND ((VAR35) < (VAR34))) AND (BETWEEN(VAR33,-2.5,2.5))) AND ((VAR31) < (100)),O,H,0,0),COLORRED;
STICKLINE(((((((VAR32) > 7) AND ((VAR36) > (4.5))) AND ((VAR35) < (5.5))) AND ((VAR35) < (VAR34))) AND (BETWEEN(VAR33,-2.5,2.5))) AND ((VAR31) < (100)),O,C,3.5,0),COLORRED;
STICKLINE(((((((VAR32) > 7) AND ((VAR36) > (4.5))) AND ((VAR35) < (5.5))) AND ((VAR35) < (VAR34))) AND (BETWEEN(VAR33,-2.5,2.5))) AND ((VAR31) < (100)),C,L,0,0),COLORF00FF0;
DRAWTEXT(((((VAR32) > 2) AND ((VAR34) > (VAR33))) AND (H = C)) AND (((((((C >= ((REF(C,1)) * (1.095))) AND (L < C)) AND ((VAR19) <= 6)) AND ((VAR19) > 1)) AND ((VAR9) > (VAR10))) AND ((VAR9) > 64)) > 0),L,'锤法→'),COLORYELLOW;
STICKLINE((((((REF(((C - (REF(C,1))) / (REF(C,1))) * (100),1)) < -4) AND ((REF(VAR32,1)) > 5)) AND (O > (REF(C,1)))) AND ((((C - (REF(C,1))) / (REF(C,1))) * (100)) > 3)) AND (O < (REF(O,1))),C,C,5,0),COLORYELLOW;
STICKLINE((((((REF(((C - (REF(C,1))) / (REF(C,1))) * (100),1)) < -4) AND ((REF(VAR32,1)) > 5)) AND (O > (REF(C,1)))) AND ((((C - (REF(C,1))) / (REF(C,1))) * (100)) > 3)) AND (O < (REF(O,1))),O,O,5,0),COLORYELLOW;
STICKLINE((((((REF(((C - (REF(C,1))) / (REF(C,1))) * (100),1)) < -4) AND ((REF(VAR32,1)) > 5)) AND (O > (REF(C,1)))) AND ((((C - (REF(C,1))) / (REF(C,1))) * (100)) > 3)) AND (O < (REF(O,1))),L,O,0,0),COLORYELLOW;
STICKLINE((((((REF(((C - (REF(C,1))) / (REF(C,1))) * (100),1)) < -4) AND ((REF(VAR32,1)) > 5)) AND (O > (REF(C,1)))) AND ((((C - (REF(C,1))) / (REF(C,1))) * (100)) > 3)) AND (O < (REF(O,1))),C,O,3,0),COLORYELLOW;


DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.145,0.1,0,VAR19),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.1,0,'【强度关注2级以上】 '),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.2,0.1,0,'级:   '),COLORYELLOW;
天界:(EMA(H,11)) * (1 + (5.2) / (100)),NODRAW;

VAR37:=((L + H) / 2);
VAR38:=(EMA((O + C + L + H) / 4,1));
VAR39:=(EMA((C + L + H) / 3,1));
STICKLINE((((((((VAR10) > (64.5)) AND (C > (MA(C,5)))) AND ((VAR17 + 3 * (STD(VAR17,10))) > (REF(VAR17 + 3 * (STD(VAR17,10)),1)))) AND (C > (VAR17 + 3 * (STD(VAR17,10))))) AND (C > (VAR5))) AND ((VAR18) > 0)) AND ((V >= ((REF(V,1)) * 2)) OR (V >= ((REF(V,3)) * 4))),VAR39,C,3,0),COLORYELLOW;
STICKLINE((((((((VAR10) > (64.5)) AND (C > (MA(C,5)))) AND ((VAR17 + 3 * (STD(VAR17,10))) > (REF(VAR17 + 3 * (STD(VAR17,10)),1)))) AND (C > (VAR17 + 3 * (STD(VAR17,10))))) AND (C > (VAR5))) AND ((VAR18) > 0)) AND ((V >= ((REF(V,1)) * 2)) OR (V >= ((REF(V,3)) * 4))),VAR37,O,3,0),COLORRED;
STICKLINE((((((((VAR10) > (64.5)) AND (C > (MA(C,5)))) AND ((VAR17 + 3 * (STD(VAR17,10))) > (REF(VAR17 + 3 * (STD(VAR17,10)),1)))) AND (C > (VAR17 + 3 * (STD(VAR17,10))))) AND (C > (VAR5))) AND ((VAR18) > 0)) AND ((V >= ((REF(V,1)) * 2)) OR (V >= ((REF(V,3)) * 4))),VAR39,VAR37,3,0),COLORBLUE;
STICKLINE((((((((VAR10) > (64.5)) AND (C > (MA(C,5)))) AND ((VAR17 + 3 * (STD(VAR17,10))) > (REF(VAR17 + 3 * (STD(VAR17,10)),1)))) AND (C > (VAR17 + 3 * (STD(VAR17,10))))) AND (C > (VAR5))) AND ((VAR18) > 0)) AND (V < ((REF(V,1)) * 2)),VAR37,C,3,0),COLORYELLOW;
STICKLINE(((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND ((MA(C,1)) > (VAR16))) AND ((MA(C,1)) > ((MA(H,30)) * (1 + 15 / (100)))),O,(VAR37 + L) / 2,3,0),COLORYELLOW;
STICKLINE(((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND ((MA(C,1)) > (VAR16))) AND ((MA(C,1)) > ((MA(H,30)) * (1 + 15 / (100)))),L,(VAR37 + L) / 2,0,0),COLORYELLOW;
{DRAWTEXT((((C / L) > (1.05)) AND ((VAR23) < -5)) AND (C > (黄金轨道)),VAR39,'包'),LINETHICK2,COLORWHITE;}

STICKLINE(((C > ((MA(H,30)) * (1 + 18 / (100)))) AND (C > (VAR5))) AND ((VAR10) > (64.5)),VAR39,VAR37,3,0),COLORWHITE;

{波段买卖}
{N:10,FFD值到2时候大多为压力位,牛股除外}

FFD:=EMA((C - REF(C,1)) / REF(C,3),10) * 100;
KJHU:=EMA(EMA(EMA(EMA(FFD,2),2),2),3);
KJHU1:=EMA(KJHU,4);
A1:=SMA(MAX(C - REF(C,1),0),24,1) / SMA(ABS(C - REF(C,1)),24,1) * 100;
{龙头启动:(A1 > 65) * (A1 - 65) / 10 + 2,NODRAW;}
VARA1:=CLOSE-LOW;
VARA2:=HIGH-LOW;
VARA3:=CLOSE-HIGH;
VARA4:=IF(HIGH>LOW,(VARA1/VARA2+VARA3/VARA2)*VOL,0);
CYW1:=SUM(VARA4,4)/100000, COLORSTICK;
控盘度:=CYW1 / 10,COLORSTICK,LINETHICK2,COLORRED;
{STICKLINE(KJHU >= REF(KJHU,1),KJHU,KJHU * 1.2,2,0),COLORRED;
STICKLINE(KJHU < REF(KJHU,1) AND KJHU > EMA(KJHU,4),KJHU,KJHU * 1.2,1,0),COLOR00BBFF;
STICKLINE(KJHU < REF(KJHU,1) AND KJHU < EMA(KJHU,4),KJHU,KJHU * 1.2,2,0),COLORGREEN;}
DRAWICON(BARSLASTCOUNT(KJHU >= REF(KJHU,1))=1,L*0.93,7);
DRAWICON(KJHU < REF(KJHU,1) AND KJHU > EMA(KJHU,4),H*1.03,8);
{0,POINTDOT,LINETHICK2,COLORGRAY;}
{1.5,POINTDOT,COLORGRAY;}
{DRAWICON(CROSS(FFD,2),2,7);}
{CROSS(FFD,KJHU1);}
A2:=(C - REF(C,1)) / REF(C,1) * 100;
A3:=COUNT(A2 > 8,120);

{DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.145,0,0,A3),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'【关注级别大的股票】 '),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.16,0,0,'级:   '),COLORYELLOW;}
NA:=14;MAA:=6;
TR1 := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),NA,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),NA,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),NA,1);
PDI:=DMP*100/TR1;
MDI:=DMM*100/TR1;
ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,NA,1);
ADXR:=(ADX+REF(ADX,MAA))/2;
{IF(PDI > MDI,2,DRAWNULL),COLOR00C800,LINETHICK4;
IF(MDI>PDI,2,DRAWNULL),COLOR64FF00,LINETHICK4;}
{IF(PDI > MDI AND ADX > ADXR AND MDI < 20,2,DRAWNULL),COLOR7850FF,LINETHICK4;}
A4:=(MA(C,3) + MA(C,6) + MA(C,12) + MA(C,24)) / 4;
A5:=A4 + 3 * STD(A4,10);
A6:=EMA(HHV(C,21),21);




相关股票

举报

扔鸡蛋(0) 回复

牛牛1888
Lv.3
发表于 2020-10-17 12:02 复制 查看全部楼层
本帖最后由 牛牛1888 于 2020-10-17 12:06 编辑

N:=5;
M:=3;
VAR0:=((EMA(C,5)) * 7 + (EMA(C,10)) * 3) / 10;
VAR1:=IF((YEAR) >= (2025),0,1);
VAR2:=EMA(EMA(L,21) + (6.8) * (STD(L,2)),55);
VAR3:=EMA(((C / (VAR2)) * ((1.88) * C + L + O)) / (2.75),3);
VAR4:=(((VAR3) - (VAR2)) / (VAR2)) / 2;
VAR5:=(EMA((VAR3) - ((VAR4) * (VAR3)),5)) * (VAR1);
黄金轨道:=(IF((VAR0) > (VAR5),VAR0,VAR5)) * (VAR1),LINETHICK2,COLORYELLOW;
上轨:=IF(((VAR5) < (VAR0)) AND ((VAR5) < (C * (0.15))),(EMA(C,300)) - (3 * (STD(C,300))),VAR5);
{开口XG:BARSLASTCOUNT(黄金轨道!=上轨)=1;}
站绿线上选股:CROSS(O>黄金轨道,0.2) AND 黄金轨道=上轨 AND C>黄金轨道;

举报

点亮(0) 扔鸡蛋(0) 回复

花雪狼花
Lv.3
发表于 2020-10-17 11:59 复制 查看全部楼层
这个公式真长,看不懂

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表