手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改一下公式

[通达信]
设置
1043 3 远航999 Lv.2 发表于 · 2020-10-17 10:59 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
拉升线在强势区250线下显示白色的虚线,拉升线突破250线才显示黄色实线,谢谢老师!


JJ:=(H+L+C)/3;



拉升线:(JJ-MA(JJ,N))/(0.015*AVEDEV(JJ,N)),COLORYELLOW,LINETHICK2;
强势区:250,COLORRED,LINETHICK2;
平衡:100,LINETHICK2,COLORFF00FF;

AA:=MA((2*CLOSE+HIGH+LOW)/4,9);
通道1:=AA*102/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(C,26))/MA(C,26);
DD:=DMA(CLOSE,CC);
通道2:=(1+7/100)*DD;
中线:MA(ATAN((通道2-REF(通道2,1))),3),LINETHICK2,COLORLIGREEN;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-10-18 07:58 复制 查看全部楼层
连贯做不到,再到楼上看看。

举报

扔鸡蛋(0) 回复

远航999
Lv.2
发表于 2020-10-17 15:15 复制 查看全部楼层
本帖最后由 远航999 于 2020-10-17 15:21 编辑


老师为什么拉升线变成断断续续的了,能调整成连贯的吗?并且把黄色线加粗,突破250线时加个向上的箭头,标注文字:突破    谢谢老师
tdxjietu1.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-10-17 14:17 复制 查看全部楼层
本帖最后由 注册111 于 2020-10-18 07:55 编辑

N:=14;
JJ:=(H+L+C)/3;

拉升线:(JJ-MA(JJ,N))/(0.015*AVEDEV(JJ,N)),NODRAW;
IF(拉升线<250,拉升线,DRAWNULL),COLORWHITE,DOTLINE;
IF(拉升线>250,拉升线,DRAWNULL),COLORYELLOW,LINETHICK3;
强势区:250,COLORRED,LINETHICK2;
平衡:100,LINETHICK2,COLORFF00FF;

AA:=MA((2*CLOSE+HIGH+LOW)/4,9);
通道1:=AA*102/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(C,26))/MA(C,26);
DD:=DMA(CLOSE,CC);
通道2:=(1+7/100)*DD;
中线:MA(ATAN((通道2-REF(通道2,1))),3),LINETHICK2,COLORLIGREEN;REF(WINNER(C)*100<10,2)&&REF(BETWEEN(WINNER(C)*100,50,60),1)&&BETWEEN(WINNER(C)*100,80,90);
DRAWICON(CROSS(拉升线>250,0.5),250,1);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表