手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并一个选股公式

[通达信]
设置
863 1 狼要吃肉 Lv.3 发表于 · 2020-10-17 13:17 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请帮忙把两个选股合并为一个选股预警
选股一
XA_1:=5;
XA_2:=6;
XA_3:=6;
XA_4:=8;
XA_5:=IF(DATE<1900612,1,0);
XA_6:=(HIGH+MAX(CLOSE,OPEN))/2;
XA_7:=MA(XA_6,3);
XA_8:=(LOW+MIN(CLOSE,OPEN))/2;
XA_9:=MA(XA_8,3);
XA_10:=MA(XA_6,3);
XA_11:=(HIGH+LOW+CLOSE+OPEN)/4;
XA_12:=MA(XA_11,3);
XA_13:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2) AND REF(MIN(CLOSE,OPEN),1)>REF(MAX(CLOSE,OPEN),2);
XA_14:=(MAX(XA_11,XA_12)-MIN(XA_11,XA_12))/MIN(XA_11,XA_12)*100;
XA_15:=(XA_12-(REF(XA_12,1)-XA_12)-LOW)/LOW*100;
XA_16:=(XA_7+(XA_7-REF(XA_7,1))-LOW)/LOW*100;
XA_17:=XA_12-(REF(XA_12,1)-XA_12);
XA_18:=XA_7+(XA_7-REF(XA_7,1));
XA_19:=IF(XA_13,XA_16,XA_15);
XA_20:=REF(EVERY(CLOSE>=OPEN,4),1) AND REF(EVERY((CLOSE+OPEN)/2>XA_12,4),1) AND (CLOSE+OPEN)/2<XA_12;
XA_21:=NOT(XA_20) AND (XA_12-OPEN)/OPEN*1000>5 AND OPEN<REF(MIN(CLOSE,OPEN),1);
XA_22:=SMA(LOW,4,3);
XA_23:=SMA(HIGH,4,3);
XA_24:=SMA(MIN(CLOSE,OPEN),4,3);
XA_25:=REF(LOW,1)-HHV(MAX(REF(LOW,2),REF(LOW,1))-MIN(REF(LOW,2),REF(LOW,1)),2);
XA_26:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2);
XA_27:=LOW<=XA_25+XA_25*0.01 AND OPEN>REF(OPEN,2) AND OPEN>=REF(LOW,3) AND COUNT(CLOSE>OPEN,7)>3;
XA_28:=(XA_25-LOW)/LOW*100;
XA_29:=(REF(LOW,1)-XA_25)/XA_25*100;
XA_30:=(XA_22-LOW)/LOW>XA_1/1000;
XA_31:=XA_30;
XA_32:=(REF(HIGH,1)-OPEN)/OPEN*100-(REF(MAX(CLOSE,OPEN),2)-REF(MAX(CLOSE,OPEN),1))/REF(MAX(CLOSE,OPEN),1)*100;
XA_33:=IF(XA_26,XA_28,XA_32);
XA_34:=XA_28+XA_33>2;
XA_35:=IF(XA_26,XA_27,XA_34) AND XA_19>2;
XA_36:=XA_5 AND XA_31 AND XA_35;
XG:REF(XA_36,1) AND LOW<REF(LOW/0.995,1),COLORYELLOW;



选股二
XA_1:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
XA_2:=REF(CLOSE,1);
XA_3:=SMA(MAX(CLOSE-XA_2,0),2,1)/SMA(ABS(CLOSE-XA_2),2,1)*100;
XA_4:=45;
XA_5:=20;
XA_6:=XA_3<XA_4 AND REF(XA_3,1)>XA_4;
XA_7:=XA_3<XA_5 AND REF(XA_3,1)>XA_5;
XA_8:=REF(COUNT(XA_1,5),1)>=1;
XA_9:=SMA(LOW,4,3);
XG:XA_9 AND (REF(XA_6,1) OR REF(XA_7,1)) AND XA_8,COLORRED;




举报

扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-17 13:53 复制 查看全部楼层
XA_1:=5;
XA_2:=6;
XA_3:=6;
XA_4:=8;
XA_5:=IF(DATE<1900612,1,0);
XA_6:=(HIGH+MAX(CLOSE,OPEN))/2;
XA_7:=MA(XA_6,3);
XA_8:=(LOW+MIN(CLOSE,OPEN))/2;
XA_9:=MA(XA_8,3);
XA_10:=MA(XA_6,3);
XA_11:=(HIGH+LOW+CLOSE+OPEN)/4;
XA_12:=MA(XA_11,3);
XA_13:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2) AND REF(MIN(CLOSE,OPEN),1)>REF(MAX(CLOSE,OPEN),2);
XA_14:=(MAX(XA_11,XA_12)-MIN(XA_11,XA_12))/MIN(XA_11,XA_12)*100;
XA_15:=(XA_12-(REF(XA_12,1)-XA_12)-LOW)/LOW*100;
XA_16:=(XA_7+(XA_7-REF(XA_7,1))-LOW)/LOW*100;
XA_17:=XA_12-(REF(XA_12,1)-XA_12);
XA_18:=XA_7+(XA_7-REF(XA_7,1));
XA_19:=IF(XA_13,XA_16,XA_15);
XA_20:=REF(EVERY(CLOSE>=OPEN,4),1) AND REF(EVERY((CLOSE+OPEN)/2>XA_12,4),1) AND (CLOSE+OPEN)/2<XA_12;
XA_21:=NOT(XA_20) AND (XA_12-OPEN)/OPEN*1000>5 AND OPEN<REF(MIN(CLOSE,OPEN),1);
XA_22:=SMA(LOW,4,3);
XA_23:=SMA(HIGH,4,3);
XA_24:=SMA(MIN(CLOSE,OPEN),4,3);
XA_25:=REF(LOW,1)-HHV(MAX(REF(LOW,2),REF(LOW,1))-MIN(REF(LOW,2),REF(LOW,1)),2);
XA_26:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2);
XA_27:=LOW<=XA_25+XA_25*0.01 AND OPEN>REF(OPEN,2) AND OPEN>=REF(LOW,3) AND COUNT(CLOSE>OPEN,7)>3;
XA_28:=(XA_25-LOW)/LOW*100;
XA_29:=(REF(LOW,1)-XA_25)/XA_25*100;
XA_30:=(XA_22-LOW)/LOW>XA_1/1000;
XA_31:=XA_30;
XA_32:=(REF(HIGH,1)-OPEN)/OPEN*100-(REF(MAX(CLOSE,OPEN),2)-REF(MAX(CLOSE,OPEN),1))/REF(MAX(CLOSE,OPEN),1)*100;
XA_33:=IF(XA_26,XA_28,XA_32);
XA_34:=XA_28+XA_33>2;
XA_35:=IF(XA_26,XA_27,XA_34) AND XA_19>2;
XA_36:=XA_5 AND XA_31 AND XA_35;
XA_41:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
XA_42:=REF(CLOSE,1);
XA_43:=SMA(MAX(CLOSE-XA_42,0),2,1)/SMA(ABS(CLOSE-XA_42),2,1)*100;
XA_44:=45;
XA_45:=20;
XA_46:=XA_43<XA_44 AND REF(XA_43,1)>XA_44;
XA_47:=XA_43<XA_45 AND REF(XA_43,1)>XA_45;
XA_48:=REF(COUNT(XA_41,5),1)>=1;
XA_49:=SMA(LOW,4,3);
XG: XA_49 && (REF(XA_46,1) OR REF(XA_47,1)) && XA_48 && REF(XA_36,1) && LOW<REF(LOW/0.995,1);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表