手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个预警公式

[通达信]
设置
911 3 胡不拉 Lv.3 发表于 · 2020-10-17 13:25 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MA5:MA(CLOSE,5);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

MA50:MA(CLOSE,50),COLORRED,LINETHICK3;

MA120:MA(CLOSE,120);

MA250:MA(CLOSE,250),COLORYELLOW,LINETHICK2;

Z:=EXTDATA_USER(3,0);{50天的}

RPS50:=Z/10;

D:=IF(RPS50<=85,0,1);{RPS50大于85}

A:=C/MA(C,250)>1;{站上年线}

NH:=IF(H<HHV(H,50),0,1);

B:=COUNT(NH,30);{一月内曾创50日新高}

NN:=IF(C>MA(C,250),1,0);

AA:=COUNT(NN,30);

AB:=HIGH/HHV(HIGH,120)>0.9;{最高价距离120日内的最高价不到10%}

DRAWICON(BARSSINCEN((A AND B AND D AND  AA>2  AND AA<30 AND AB),30)=0,LOW,34);

ZZ:=EXTDATA_USER(10,0);

RPS20:=ZZ/10;

DD:=IF(RPS20<=97,0,1);

A1:=C/MA(C,250)>1;

NH1:=IF(H<HHV(H,20),0,1);

B1:=COUNT(NH1,30);

NN1:=IF(C>MA(C,250),1,0);

AA1:=COUNT(NN1,30);

AB1:=HIGH/HHV(HIGH,120)>0.9;

DRAWICON(BARSSINCEN(( A1 AND AB1 AND AA1>2  AND    DD AND   C<MA(C,10)),30)=0,LOW,9);

X:=CONST(HHV(HIGH,150));

X2:=HHVBARS(H,150)+1;

X3:=CONST(LLV(LOW,X2));

X4:=X3/X;X5:=X4*100-100;DRAWNUMBER(L=X3,X3,X5);

中期调整:X5,NODRAW;IF(X5<=-30,X5,DRAWNULL),NODRAW,COLORRED;

C2:=REF(C,1);

涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);

STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;

{黄色涨停}

STICKLINE(涨停,H,L,0,0),COLORRED;

跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);

STICKLINE(跌停,OPEN,CLOSE,2,0),COLORBLUE;{跌停}

STICKLINE(跌停,H,L,0,1),COLORBLUE;









K120:=EXTDATA_USER(1,0);{120天的RPS}

RPSK120:=K120/10;

K01:=IF(RPSK120<=90,0,1);{RPS120大于90};

K250:=EXTDATA_USER(2,0);{250天的RPS}

RPSK250:=K250/10;

K02:=IF(RPSK250<=90,0,1);{RPS250大于90};

K50:=EXTDATA_USER(3,0);{50天的RPS}

RPSK50:=K50/10;

K03:=IF(RPSK50<=90,0,1);{RPS50大于90};

DRAWICON(BARSSINCEN((K01 ANDK02ANDK03),20)=0,LOW*0.95,15);


1.当天出现小人的预警  。              2.小人和圆圈(内有小箭头)同时出现时候的预警   谢谢

举报

扔鸡蛋(0) 回复

胡不拉
Lv.3
发表于 2020-10-19 09:42 复制 查看全部楼层
@许昌舍得老师您能给看看吗

举报

扔鸡蛋(0) 回复

胡不拉
Lv.3
发表于 2020-10-17 14:42 复制 查看全部楼层






第一个不通过
当前公式 : 选股 (条件选股公式)  
错误句 :  
详细信息 : 对不起,公式选股最少有1个输出!
错误起始位置 : 305 ; 长度: 10





第2个预警不通过
错误句 :



XG:TJ1 AND TJ2
详细信息 : 未知字符串 TJ1
错误起始位置 : 361 ; 长度: 3

老师能给再看看吗

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-17 14:34 复制 查看全部楼层


Z:=EXTDATA_USER(3,0);{50天的}

RPS50:=Z/10;

D:=IF(RPS50<=85,0,1);{RPS50大于85}

A:=C/MA(C,250)>1;{站上年线}

NH:=IF(H<HHV(H,50),0,1);

B:=COUNT(NH,30);{一月内曾创50日新高}

NN:=IF(C>MA(C,250),1,0);

AA:=COUNT(NN,30);

AB:=HIGH/HHV(HIGH,120)>0.9;{最高价距离120日内的最高价不到10%}

TJ1:=BARSSINCEN((A AND B AND D AND  AA>2  AND AA<30 AND AB),30)=0;









K120:=EXTDATA_USER(1,0);{120天的RPS}

RPSK120:=K120/10;

K01:=IF(RPSK120<=90,0,1);{RPS120大于90};

K250:=EXTDATA_USER(2,0);{250天的RPS}

RPSK250:=K250/10;

K02:=IF(RPSK250<=90,0,1);{RPS250大于90};

K50:=EXTDATA_USER(3,0);{50天的RPS}

RPSK50:=K50/10;

K03:=IF(RPSK50<=90,0,1);{RPS50大于90};

TJ2:=BARSSINCEN((K01 ANDK02ANDK03),20)=0;



XG:TJ1 AND TJ2;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表