手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股公式

[通达信]
设置
920 2 小斌仔王智勃 Lv.2 发表于 · 2020-10-17 14:51 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
需求:选出有粉色柱体的K线。(如图)
公式源码:
顶:80,COLORYELLOW,LINETHICK2;
底:20,COLORWHITE,LINETHICK2;
DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD1:=(DIF-DEA)*2;
主力潜入:COUNT(MACD1<0,10)=10,COLORLIRED;
STICKLINE(主力潜入,0,MACD1*200,1,0),COLORLIRED;
庄家:=EMA(EMA(CLOSE,10),10);
现价:=(庄家-REF(庄家,1))/REF(庄家,1)*1000;
STICKLINE(现价<REF(现价,1) AND 现价<0,现价,0,2,0),COLORBLUE;
打压吸筹:IF(现价<REF(现价,1) AND 现价<0,现价,0)COLORBLUE,NODRAW;
上价:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
下价:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
中价:=MAX(EMA(上价,1)-EMA(下价,5),0)*200;
与庄共舞:EMA(中价,5)STICK,COLORRED;
STICKLINE(与庄共舞<REF(与庄共舞,1),0,与庄共舞,1,0),COLOR00FF00;
STICKLINE(现价<REF(现价,1) AND 现价>0,现价,0,1,0),COLOR00FF00;
庄家出货:IF(现价<REF(现价,1) AND 现价>0,现价,0),COLOR00FF00,NODRAW;
RSV:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*100;
K:EXPMA(EXPMA(EXPMA(RSV,3),3),3),COLORCYAN;
D:SMA(K,2,1),COLORWHITE;
J:3*K-2*D,COLORMAGENTA,LINETHICK2;






VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),10,15);

附件

123232323.png

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-17 15:18 复制 查看全部楼层
DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD1:=(DIF-DEA)*2;
主力潜入:COUNT(MACD1<0,10)=10;

附件

tdxjietu4.JPG
查看全部打赏
  • 快乐398+8理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-17 15:17 复制 查看全部楼层
{选出有粉色柱体的K线}

DIF:= EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:= EMA(DIF,9);
MACD1:= (DIF-DEA)*2;
XG: COUNT(MACD1<0,10)=10;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表