手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并一个选股

[通达信]
设置
1036 1 狼要吃肉 Lv.3 发表于 · 2020-10-17 15:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请帮忙把 三个选股合并成一个
XA_1:=100*WINNER(CLOSE)>=90 AND DYNAINFO(4)>0 AND BARSCOUNT(CLOSE)>200;
XA_2:=MA(CLOSE,30);
A5:FILTER(XA_1,21) AND CLOSE>XA_2 AND CLOSE/REF(CLOSE,1)>=1.09;


BOLL:=MA(CLOSE,20);
UPPER:=(BOLL+2*STD(CLOSE,20))*0.995;
站上上轨:=REF(C<UPPER,1) AND C>UPPER;
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
M120:=MA(C,120);
AA:=C>MAX(M5,MAX(M10,MAX(M20,MAX(M60,M120))));
BB:=OBV>=HHV(OBV,60);
埋伏上轨捉妖1:=AA AND BB AND 站上上轨;
埋伏上轨捉妖2:REF(埋伏上轨捉妖1,1)=0 AND 埋伏上轨捉妖1 ,COLORRED;



VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
选股:CROSS(主力资金,0) AND CROSS(拉升资金,0.01)AND VOL/MA(REF(VOL,1),5)>2;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-17 15:24 复制 查看全部楼层
三合一共振选股

XA_1:=100*WINNER(CLOSE)>=90 AND DYNAINFO(4)>0 AND BARSCOUNT(CLOSE)>200;
XA_2:=MA(CLOSE,30);
A5:=FILTER(XA_1,21) AND CLOSE>XA_2 AND CLOSE/REF(CLOSE,1)>=1.09;


BOLL:=MA(CLOSE,20);
UPPER:=(BOLL+2*STD(CLOSE,20))*0.995;
站上上轨:=REF(C<UPPER,1) AND C>UPPER;
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
M120:=MA(C,120);
AA:=C>MAX(M5,MAX(M10,MAX(M20,MAX(M60,M120))));
BB:=OBV>=HHV(OBV,60);
埋伏上轨捉妖1:=AA AND BB AND 站上上轨;
埋伏上轨捉妖2:=REF(埋伏上轨捉妖1,1)=0 AND 埋伏上轨捉妖1 ,COLORRED;



VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
选股:=CROSS(主力资金,0) AND CROSS(拉升资金,0.01)AND VOL/MA(REF(VOL,1),5)>2;



共振选股: A5 AND 埋伏上轨捉妖2 AND 选股;
查看全部打赏
  • 快乐398+18理想币 : 谢谢老师帮助!祝老师事事如愿!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表