手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把附图黄块买字改成预警和选股

[通达信]
设置
1098 2 枫林波哥 Lv.2 发表于 · 2020-10-17 18:08 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR4:=((HHV(HIGH,9) - CLOSE)/(HHV(HIGH,9) - LLV(LOW,9)))*(100) - 70;
VAR5:=((CLOSE - LLV(LOW,60))/(HHV(HIGH,60) - LLV(LOW,60)))*(100);
VAR7:=SMA(((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100),3,1);
VAR8:=LLV(LOW,34);
VARC:=EMA(((((2)*(CLOSE) + HIGH + LOW)/(4) - VAR8)/(HHV(HIGH,34) - VAR8))*(100),8);
VARD:=EMA(VARC,5);
VARE:=((HHV(HIGH,9) - CLOSE)/(HHV(HIGH,9) - LLV(LOW,9)))*(100) - 70;
VAR11:=SMA(((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100),3,1);
VAR12:=SMA(VAR11,3,1) + 100;
VAR13:=VAR12 - SMA(VARE,9,1) + 100;
VAR14:=ZIG(3,13);
建仓:=IF((VARC > 17) AND (VARC < 59) AND (VARC - VARD >= 0),10,(-10));
猎豹:=IF((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),10,45);
丰收:=IF((VARC > 70) AND (VARC - VARD >= 0),77,82);
牛:=IF((VAR13 > 100),VAR13 - 100,0);
顶:=IF((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),95,55);
风:=IF((VARC - VARD > 0),VARC,VARD);
STICKLINE((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),CLOSE,OPEN,5,0),COLOR66FF00;
STICKLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),CLOSE,OPEN,5,0),COLORYELLOW;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),LINETHICK5,COLOR070084;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),LINETHICK4,COLOR0000A3;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),LINETHICK3,COLOR0000B7;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),LINETHICK2,COLOR0000CD;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),LINETHICK1,COLOR077BF3;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),COLORFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,4.5,0),COLORFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,4,0),COLORFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),COLORFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2,0),COLORFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,0.5,0),COLORCCCCCC;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),COLOR070084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4.5,0),COLOR0000A3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),COLOR0000B7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3.5,0),COLOR0000CD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),COLOR0000E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),COLOR0754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),COLOR076EF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0.5,0),COLOR077BF3;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0.5,0),COLOR0726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.5,0),COLOR0726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,0.5,0),COLORDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,0.5,0),COLORDE9100;
买:DRAWTEXT((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.05),'买'),COLORRED;
卖:DRAWTEXT((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.03),'卖'),COLOR66FF00;
STICKLINE((REF(VAR14,2) < REF(VAR14,1)) AND (VAR14 < REF(VAR14,1)),CLOSE,OPEN,5,0),COLOR66FF00;
STICKLINE((REF(VAR14,2) > REF(VAR14,1)) AND (VAR14 > REF(VAR14,1)),CLOSE,OPEN,5,0),COLORYELLOW;
本主题由 任务系统 于 2020-10-17 18:19 审核通过

举报

扔鸡蛋(0) 回复

枫林波哥
Lv.2
发表于 2020-10-17 21:03 复制 查看全部楼层
好的谢谢老师

举报

扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-17 18:25 复制 查看全部楼层
{预警和选股} {原公式含未来函数,数据可能漂移,实盘慎用}

XG: (REF(ZIG(3,13),2)>REF(ZIG(3,13),1)) && (ZIG(3,13)>REF(ZIG(3,13),1));

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表