手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师指导一下:修改以下龙头公式的错误

[通达信]
设置
1077 1 朱坏123 Lv.4 发表于 · 2020-10-17 22:21 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师修改以下龙头公式的错误:


日K:='KDJ.K#DAY'(9,3,3);
日D:='KDJ.D#DAY'(9,3,3);

周K:='KDJ.K#WEEK'(9,3,3);
周D:='KDJ.D#WEEK'(9,3,3);

月K:='KDJ.K#MONTH'(9,3,3);
月D:='KDJ.D#MONTH'(9,3,3);
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;

停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0989,1.110) AND C=H AND C>O;
BETWEEN(CLOSE/REF(CLOSE,1),1.075,1.110) AND NOT(L=H) AND NOT(REF(停,1))AND NOT(REF(停,2)) AND
Z值>0 AND C<10  AND FINANCE(7)<2000000000  AND  FINANCE(7)>100000000  AND
日K>日D AND 周K>周D AND 月K>月D;


错误句 : 日K:='KDJ.K#DAY'(9,3,3)
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 0 ; 长度: 0

谢谢!

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-10-17 22:35 复制 查看全部楼层
日K:=KDJ.K#DAY(9,3,3);
日D:=KDJ.D#DAY(9,3,3);

周K:=KDJ.K#WEEK(9,3,3);
周D:=KDJ.D#WEEK(9,3,3);

月K:=KDJ.K#MONTH(9,3,3);
月D:=KDJ.D#MONTH(9,3,3);
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;

停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0989,1.110) AND C=H AND C>O;
BETWEEN(CLOSE/REF(CLOSE,1),1.075,1.110) AND NOT(L=H) AND NOT(REF(停,1))AND NOT(REF(停,2)) AND
Z值>0 AND C<10  AND FINANCE(7)<2000000000  AND  FINANCE(7)>100000000  AND
日K>日D AND 周K>周D AND 月K>月D;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表