钻石超牛(源码 副图 通达信 贴图)无加密

[通达信] 精华 1 205个推荐205
设置
75100 70 快乐飞牛 Lv.3 发表于 · 2020-10-18 15:18 显示全部楼层 正序浏览 |
跳转到指定楼层
本帖最后由 快乐飞牛 于 2020-10-18 19:04 编辑

公式感觉不错,我也是棵小韭菜,大家互相讨论学习,共进步,希望大家多留言,多点赞,多推荐,下载,多改进公式,使公式更完美

附件

微信截图_20201018150235.png
微信截图_20201018145950.png
微信截图_20201018150449.png
钻石副图指标源码公式.txt [预览] 在线检测未来函数

13.11 KB, 下载次数: 274, 下载积分: 共享币 -20 个

本主题由 任务系统 于 2020-11-19 00:30 解除限时高亮

举报

使用道具 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2021-1-17 20:59 复制 查看全部楼层

大红叁与


SJ:=1;

超买:100*SJ,COLORRED;

超卖:0*SJ,COLOR00FF00;

VAR51:=EMA(CLOSE,2)-EMA(CLOSE,150);

VAR61:=EMA(VAR51,100);

VAR71:=2*(VAR51-VAR61);

VAR81:=POW(VAR71,3)*0.100+POW(VAR71,1);

成大控股投资版:=IF(VAR71>0.100,VAR81,0)*10;

成基投资汇市版:=成大控股投资版;

挺身上九重:=(LLV(LOW,25)-CLOSE)/(LLV(LOW,25)-HHV(HIGH,25))*100;

VAR21B:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100;

VAR21C:=SMA(VAR21B,4,1);

散户:=SMA(VAR21C,4,1);

VAR21D:=(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6))*100;

VAR21E:=SMA(VAR21D,4,1);

血染夕阳正红:=SMA(VAR21E,4,1);

主力:=SMA(散户,4,1);

VAR2:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;

VAR3:=SMA(VAR2,3,1);

VAR4:=SMA(VAR3,3,1);

VAR5:=3*VAR3-2*VAR4;

VAR6:=LLV(LOW,5);

VAR7:=HHV(HIGH,5);

VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4)*2;

VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);

VARA:=3*VAR8-2*VAR9;

VARB:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);

VARC:=POW(MA(LOW,5),2)+MA(LOW,5);

VARD:=POW(MA(HIGH,5),2)+MA(HIGH,5);

VARE:=(VARB-LLV(VARC,64))/(HHV(VARD,64)-LLV(VARC,64))*150+65-10;

VARF:=SMA(VARE,3,1)*1.5-100;

VAR10:=SMA(VARF,3,1);

VAR11:=3*VARF-2*VAR10;

VAR12:=(HIGH+LOW+CLOSE*2)/4;

VAR13:=EMA(VAR12,13);

VAR14:=STD(VAR12,13);

VAR15:=(VAR12-VAR13)*100/VAR14;

VAR16:=EMA(VAR15,5);

VAR17:=EMA(VAR16,13);

VAR18:=EMA(VAR16,13)+200-100;

VAR19:=EMA(VAR18,10);

VAR1A:=3*VAR18-2*VAR19;

VAR1B:=VAR3+VAR8+VARF+VAR18;

VAR1C:=VAR4+VAR9+VAR10+VAR19;

VAR1D:=VAR5+VARA+VAR11+VAR1A;

VAR1E:=(HIGH+LOW+CLOSE)/3;

VAR21:=(VAR1E-MA(VAR1E,34))/(0.015*AVEDEV(VAR1E,34));

VAR22:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

VAR23:=(HIGH+LOW+CLOSE+VAR1E)/4;

VAR24:=EMA(VAR23,24);

VAR25:=STD(VAR23,24);

VAR26:=(VAR23-VAR24)/VAR25*100;

VAR27:=(VAR1E-MA(VAR1E,24))/(0.015*AVEDEV(VAR1E,24));

VAR28:=EMA(VAR26,5);

VAR2B:=((VAR28+VAR27+VAR21)/3+165)/4;

VAR2C:=(EMA(EMA(EMA(VAR2B,15),10),5)-25)*2;

VAR2D:=(VAR1B+VAR1C+VAR1D*30)/32/5-15;

VAR2E:=EMA(VAR2D,13);

攻击路线:=EMA((VAR2C+VAR2E)/2,2);

印钞痕迹:=REF(攻击路线,1);

攻击路线, COLORGREEN,LINETHICK3;

DY11:=(2*CLOSE+HIGH+LOW)/4;

DY22:=LLV(LOW,34);

DY33:=HHV(HIGH,34);

DYAA:=EMA((DY11-DY22)/(DY33-DY22)*100,30);

DYBB:=EMA(DYAA,5);

A11:=EMA((DY11-DY22)/(DY33-DY22)*100,9);

B11:=EMA(0.667*REF(A11,1)+0.333*A11,2);

DRAWBMP(挺身上九重<血染夕阳正红,28,'2');

DRAWBMP(血染夕阳正红<挺身上九重,28,'1');

HZDWR:=MA((CLOSE-LLV(LOW,98))/(HHV(HIGH,98)-LLV(LOW,98))*120,8);

HZZWR:=MA((CLOSE-LLV(LOW,88))/(HHV(HIGH,88)-LLV(LOW,88))*120,8);

RSV:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26));

DY1:=(OPEN+CLOSE+HIGH+LOW)/4;

DY2:=LLV(LOW,13);

DY3:=HHV(HIGH,13);

DYA:=MA((DY1-DY2)/(DY3-DY2)*100,1);

DYB:=MA(DYA,5);

A1:=EMA((DY1-DY2)/(DY3-DY2)*180,20);

B1:=EMA(REF(A1,1),1);

B2:=MA(0.667*REF(RSV,1)+0.333*RSV,1);

RB:=IF(A1>=B2,A1,B2);

QL:=IF(B1-A1,B1,A1);

RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

RSV2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

J1:=SMA(RSV1,3,1);

J2:=SMA(J1,3,1);

趋势线:=3*SMA(RSV2,5,1)-2*SMA(SMA(RSV2,5,1),3,1);

K:=SMA(RSV2,3,1);

D:=SMA(K,3,1);

买点准备:=IF(趋势线<=10,25,0);

卖点准备:=IF(CROSS(J2,J1) AND J2>85,70,100);

DRAWBMP(趋势线>=49,65,'A18');

DRAWBMP(趋势线<=49,55,'下');

IF(攻击路线<0,攻击路线,DRAWNULL)*SJ,COLORMAGENTA,LINETHICK3;

IF(印钞痕迹<攻击路线 AND 攻击路线<0,攻击路线,DRAWNULL)*SJ,LINETHICK3, COLORYELLOW ;

IF(攻击路线<100 AND 攻击路线>0,攻击路线,DRAWNULL)*SJ, LINETHICK3, COLORGREEN;

IF(印钞痕迹<攻击路线 AND 攻击路线>0,攻击路线,DRAWNULL)*SJ,LINETHICK3, COLORRED;

IF(攻击路线>100,攻击路线,DRAWNULL)*SJ,LINETHICK2, COLORBLUE;

STICKLINE(攻击路线>135,115,110,10,0)*SJ,COLORGREEN;

STICKLINE(攻击路线>105,110,105,10,1)*SJ,COLORBLUE;

STICKLINE(攻击路线<-15,5,10,10,1)*SJ,COLORMAGENTA;

STICKLINE(攻击路线<-26,10,15,10,0)*SJ,COLORRED;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2021-1-17 20:47 复制 查看全部楼层
本帖最后由 快乐飞牛 于 2021-1-17 20:48 编辑

抓妖选股超牛


BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,0.1));

ZTTJ:=C>=ZTPRICE(REF(C,1),BK) AND C=H AND NOT(O=H) ;

换手率:=V/CAPITAL*100;

S2:=IF(NAMELIKE('S'),0,1);

S3:=IF(NAMELIKE('*'),0,1);

S4:=DYNAINFO(17)>0;

VAR12:=(HIGH - LOW);

VAR13:=ABS((OPEN - CLOSE));VAR14:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));

VAR15:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);VAR16:=((VAR13 / VAR12) * VOL);

VAR17:=((VAR14 / VAR12) * VOL);VAR18:=((VAR15 / VAR12) * VOL);

VAR19:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));

VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);

VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));

ZXZ:=IF(REF(C,1)>REF(O,1) AND O>REF(C,1)*1.014 AND C<O*1.02,1,3);

V34:=MA(V,34);

VD5:=MA(V,5);

V12:=MA(V,12);

C6:=MA(C,6);

吸:=(CROSS(C,C6) AND V>VD5*1.2 AND V>V12*1.2 AND ZXZ>2 AND C>H*0.975)

OR(VOL>MA(VOL,5)*2 AND V>V34*3 AND C<REF(C,1)*1.05 AND CROSS(C,C6) AND V>VD5*1.2 AND V>V12*1.2 AND ZXZ>2 AND C>H*0.975)OR

(VOL>MA(VOL,5)*2 AND V>V34*3 AND C<REF(C,1)*1.05 AND CROSS(C6,C) AND V>VD5*1.2 AND V>V12*1.2);

黑马柱:=(((((VAR16 > (MA(VOL,5) * 2)) AND (VAR16 >= VAR17)) AND (VAR16 >= VAR18)) AND (CLOSE > OPEN))

OR ((VOL > (MA(VOL,5) * 3)) AND VARB)) OR 吸;

DIFFG:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEAG:=EMA(DIFFG,9);MACDG:=2*(DIFFG-DEAG);

日K:="KDJ.K#DAY"(9,3,3);

日D:="KDJ.D#DAY"(9,3,3);

日DIF:="MACD.DIF#DAY"(12,26,9);

日DEA:="MACD.DEA#DAY"(12,26,9);

日RSI:="RSI.RSI1#DAY"(9);

周K:="KDJ.K#WEEK"(9,3,3);

周D:="KDJ.D#WEEK"(9,3,3);

周DIF:="MACD.DIF#WEEK"(12,26,9);

周DEA:="MACD.DEA#WEEK"(12,26,9);

周RSI:="RSI.RSI1#WEEK"(9);

月K:="KDJ.K#MONTH"(9,3,3);

月D:="KDJ.D#MONTH"(9,3,3);

月DIF:="MACD.DIF#MONTH"(12,26,9);

月DEA:="MACD.DEA#MONTH"(12,26,9);

月RSI:="RSI.RSI1#MONTH"(9);

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;

LWR1:=SMA(RSV,3,1);

LWR2:=SMA(LWR1,3,1);

BBI:=(MA(CLOSE,3)+MA(CLOSE,5)+MA(CLOSE,8)+MA(CLOSE,13))/4;

LC:=REF(CLOSE,1);

RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;

RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

牛线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORGREEN{COLORRED};

马线:=MA(牛线,6),COLORMAGENTA;

A7:=MAX(MA(C,60),MA(C,120));

B7:=MIN(MA(C,60),MA(C,120));

E:=MAX(MA(C,45),MA(C,90));

F:=MIN(MA(C,45),MA(C,90));

J:=MAX(MA(C,30),MA(C,60));

K:=MIN(MA(C,30),MA(C,60));

WR1:=110*(HHV(HIGH,10)-EMA(C,1))/(HHV(HIGH,10)-LLV(LOW,10));

WR2:=110*(HHV(HIGH,2)-EMA(C,1))/(HHV(HIGH,2)-LLV(LOW,2));

G:=BARSLAST(CROSS(WR1,WR2))/2+12;

T1:=日K>日D AND 日DIF>日DEA AND 日RSI>50

AND 周K>周D AND 周DIF>周DEA AND 周RSI>50 AND 月K>月D AND 月DIF>月DEA AND 月K>=月D AND 月RSI>50

AND CCI>=0 AND LWR1>LWR2 AND CLOSE>BBI AND RSI1>RSI2 AND C>牛线 AND C>=A7 AND C>E AND C>J AND G>=WR2;

TY:=C;

AJ1:=REF(TY,10)=HHV(TY,2*10+1); BJ1:=FILTER(AJ1,10); CJ1:=BACKSET(BJ1,10+1); HDJ:=FILTER(CJ1,10);

AJ2:=REF(TY,10)=LLV(TY,2*10+1); BJ2:=FILTER(AJ2,10); CJ2:=BACKSET(BJ2,10+1); LDJ:=FILTER(CJ2,10);

TJJ1:=BARSLAST(HDJ)<BARSLAST(LDJ) AND NOT(HDJ) ;AJ:=REF(C,BARSLAST(HDJ));

波峰射线:=IF(TJJ1<1,AJ,DRAWNULL);

穿线:=C>波峰射线 OR CROSS(C,MA(CLOSE,5)) OR CROSS(C,MA(C,10)) OR CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)) OR CROSS(C,MA(C,120)) OR CROSS(C,MA(C,250));

去停牌:=DYNAINFO(8)>0;

红振:=去停牌 AND 换手率>2 AND 换手率<15 AND T1 AND ZTTJ AND REF(NOT(ZTTJ),1) AND EXIST(穿线,2) AND C<10  AND FINANCE(7)<3000000000  ;



HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;

HJ_9:=FILTER(HJ_8,10);

HJ_10:=BARSLAST(HJ_9);

HJ_11:=REF(HIGH,HJ_10+2);

HJ_12:=REF(HIGH,HJ_10+1);

HJ_13:=REF(HIGH,HJ_10);

HJ_14:=MAX(HJ_11,HJ_12);

HJ_15:=MAX(HJ_14,HJ_13);

HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;

HJ_17:=HJ_10<150;

HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;

HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;

HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;

HJ_21:=VOL/MA(VOL,5)<3.5;

HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;

HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;

暴利:=FILTER(HJ_25,15);

PL1:=(((CLOSE-MA(CLOSE,54))/MA(CLOSE,54))<0.1);

PL2:=(((CLOSE-MA(CLOSE,10))/MA(CLOSE,10))<0.3);

偏离率:=(((PL1=1) AND (PL2=1))*0.2);

平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);

妖股突破:=平台突破=-0.1;

XDF:=(暴利 OR 妖股突破);

VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);

FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);

妖股:=XDF AND C/REF(C,1)>1.05 AND FLIGA AND VARAA;

红吸:=去停牌 AND 换手率>2 AND 换手率<15 AND 吸 AND ZTTJ AND REF(NOT(ZTTJ),1) AND EXIST(穿线,2)   AND C<10  AND FINANCE(7)<3000000000 AND (C-MA(C,60))/MA(C,60)<0.25 AND S2 AND S3 AND S4  AND REF(V,1)<V AND 黑马柱;

红妖:=去停牌 AND 换手率>2 AND 换手率<15 AND 妖股 AND ZTTJ AND REF(NOT(ZTTJ),1) AND EXIST(穿线,2) AND C<10  AND FINANCE(7)<3000000000 AND (C-MA(C,60))/MA(C,60)<0.25 AND S2 AND S3 AND S4  AND REF(V,1)<V AND 黑马柱;

红吸 OR 红妖 OR 红振;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2021-1-14 15:02 复制 查看全部楼层
通达信--KDJ自动画线公式

{参数:N:2,90,9;M1:2,30,3;M2:2,30,3}

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:SMA(RSV,M1,1);

D:SMA(K,M2,1);

J:3*K-2*D;

{0,COLORRED,LINETHICK1;20,COLORLIMAGENTA,LINETHICK1;

80,COLORBLUE,LINETHICK1;100,COLORGREEN,LINETHICK1;}

DRAWTEXT(ISLASTBAR,0,'高安全区'),COLORRED;

DRAWTEXT(ISLASTBAR,100,'高风险区'),COLORGREEN;

OBV:=K;     

P:=12;

A1:=REF(OBV,P)=HHV(OBV,2*P+1);

B1:=FILTER(A1,P);

C1:=BACKSET(B1,P+1);

D1:=FILTER(C1,P);{高点1}

R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);

DRAWLINE(D1,OBV,S11,OBV,1),COLORLIRED,LINETHICK2;

A2:=REF(OBV,P)=LLV(OBV,2*P+1);

B2:=FILTER(A2,P);

C2:=BACKSET(B2,P+1);

D2:=FILTER(C2,P);{低点1}

T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);

DRAWLINE(D2,OBV,U11,OBV,1),COLORLIGREEN,LINETHICK2;

Q1:=INTPART(3*8/18);

A12:=REF(OBV,Q1)=HHV(OBV,2*Q1+1);

B12:=FILTER(A12,Q1);

C12:=BACKSET(B12,Q1+1);

D12:=FILTER(C12,Q1);{高点2}

R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);

DRAWLINE(S11,OBV,S112,OBV,1),COLORRED,LINETHICK2;

Q2:=INTPART(3*8/18);

A22:=REF(OBV,Q2)=LLV(OBV,2*Q2+1);

B22:=FILTER(A22,Q2);

C22:=BACKSET(B22,Q2+1);

D22:=FILTER(C22,Q2);{低点2}

T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);

DRAWLINE(U11,OBV,U112,OBV,1),COLORGREEN,LINETHICK2;

DRAWICON(D2,OBV,26);

DRAWICON(D1,OBV,27);

压力:REF(OBV,BARSLAST(D1)),COLORFF00FF,NODRAW;

支撑:REF(OBV,BARSLAST(D2)),COLOR00FF00,NODRAW;

向上:CROSS(OBV,压力*1.01),NODRAW;

相对能量:(OBV-支撑)/(压力-支撑)*100,COLORYELLOW,NODRAW;

STICKLINE(C>0,支撑,支撑,1,0),COLORGREEN;

STICKLINE(C>0,压力,压力,1,0),COLORRED;

DRAWTEXT(CROSS(OBV,压力*1.01),压力,'压力线'),COLORRED;

DRAWTEXT(CROSS(支撑*0.99,OBV),支撑,'支撑线'),COLORGREEN;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

南方孤雁
Lv.3
发表于 2020-12-20 14:18 复制 查看全部楼层
感谢分享钻石超牛指标,非常感谢!

举报

使用道具 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-12-17 02:51 复制 查看全部楼层
本帖最后由 快乐飞牛 于 2020-12-17 02:54 编辑

今天给大家讲讲几大经典的买入技术形态,遇到了满仓抄底:



什么叫“蚂蚁上树”?



是指个股有超大可能性走牛的K线技术形态,一般出现在股价的底部区域,是股价见底开始转强的标。核心要点是温和低量小阳线缓慢推进,然后带量大阳(最好是涨停板)突破中线组起来的形态。







“蚂蚁上树”的形成机理:



股价底部出蚂蚁,你说好奇不好奇。   股价长期下跌后,空方进攻金鼓息。

此时主力建仓毕,指数配合随时起。   为不引起你注意,计划限购买价低。

一试盘面抛压力,二做热身来演习。   确立形态的蚂蚁,十分关注不余力。

一旦放量来上攻,及时跟进不迟疑。   底部出现小蚂蚁,股价见底转强义。







“蚂蚁上树”形态特征:



千里之堤毁于蚁穴,蚂蚁虽小大象移。K线图上蚂蚁现,预示股价将发力。

股价长期缩量跌,均线变的平且密。十三均线跌走平,股价又上十三堤。

连续小阳缓步升,爬上五五就成立。几根上升小阳线,蚂蚁上树不容疑。







“蚂蚁上树”形态特点:



1、成交量很小;

2、小阳线缓慢推进;

3、股价处在底部反弹趋势中;

4、超过5点的大阳线起来,带3倍以上的成交量;

5、短线组上穿中线组,中线组走平上翘;







“蚂蚁上树”操作条件:



1、反弹阶段的“蚂蚁上树”一般出现在个股的回调末期或者是反弹的初期。主升浪阶段的“蚂蚁上树”出现在刚刚突破60日均线以上的个股,属于上升行情的中段;

2、成交量必须是温和放量;

3、KDJ指标形成金叉在50以下,刚刚形成最好,并且J线拐头向上呈现出大于45°角的形态向上。

4、MACD指标下方绿色柱子逐渐缩短并且由绿色柱向红色柱转换最好。



“蚂蚁上树”买入时机:

1、蚂蚁上树出现当天,成功突破十日均线后,我们可以密切关注

2、股价回调的第一或第二根阴线,轻仓试探

3、股价形成“阳克阴”之势,即一阳吃掉前几日的几根阴线或一根阴线,可半仓或重仓出击。



蚂蚁上树选股公式:





EMA13:=EMA(C,13);

EMA34:=EMA(C,34);

EMA55:=EMA(C,55);

BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;

BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;

BR3:=C>EMA55 AND (REF(C,1)

(C,4)

蚂蚁上树:BR1 AND BR2 AND BR3;



红三兵:



指的是三根连续上涨的阳线,幅度相当。它有标准形态、遇阻形态和思考形态三种情形,如下图所示





它的技术特征主要如下几点:1、每日的收盘价均较前一日高;

2、每日最高价均比前一日最高价高,每日最低价均比前一日最低价高;

3、每日开盘价可以在前一日实体之内;

4、每日收盘价位于最高价附近。



红三兵选股公式:





MID:=MA(CLOSE,26),colorwhite;

Uu:=MID + 2*STDDEV(CLOSE,26),coloryellow;

Ll:=MID - 2*STDDEV(CLOSE,26),colorff00ff;

v1:=STICKLINE(MID>=REF(MID,1),MID,REF(MID,1),5,1),

colorYELLOW,LINETHICK2;

v2:=STICKLINE(MID<REF(MID,1),MID,REF(MID,1),5,1),colorRED,

LINETHICK2;

K:=REF(CLOSE,2)>REF(OPEN,2) AND

REF(CLOSE,1)>REF(OPEN,1) AND

CLOSE>OPEN AND REF(CLOSE,1)>REF(CLOSE,2) AND

CLOSE>REF(CLOSE,1) and v>ref(v,1) and ref(v,1)>ref(v,2)

and (close-open)<0.05*ref(open,1) and (ref(close,1)-ref(open,1))<0.05*ref(open,2)

and (ref(close,2)-ref(open,2))<0.05*ref(open,3);

红三兵:=if(K,1,0),colorred;

vab:=uu>ref(uu,1) and mid>ref(mid,1) and c>ref(c,1) and c>uu;

xg1:if(vab and 红三兵,1,0);





出水芙蓉:



出水芙蓉是非常典型的大牛股启动形态之一,无论是在长期震荡盘整低位区域还是牛股上升途中,该形态出现意味着主力开始新一轮征程,牛股狂欢将再一次拉开序幕。形态上,个股在横盘整理或下跌过程中,某天一根长阳突破了短期均线系统,必须要有较大成交量来配合。这就是出水芙蓉的基本特征。









三线金叉:



三线金叉是非常强烈的见底买入信号。均价线、均量线、MACD三者都出现金叉。在技术分析中,“价、量、时、空”四大要素中有三个发出了买入信号,极大提高研判准确性。




超短线,一直是相当一波投资者喜欢的操作方式,但如果不配合相应的技巧和纪律,短线操作亏损的概率是很大的。这里补充股票短线买卖技巧,实用性很强。

超短线战法之一(涨停板突破前高,巨量阴线洗盘法):

具体操作,涨停板过前高,第二天收巨量阴线,第三天敢翻红就毫不犹豫跟进。





超短线战法之二(连续小阳推升,收缩量阴线法):

具体操作,连续小阳推升,接着收一根缩量阴线,尾盘买入。这类走势图,后市意味着股价将进入加速拉升!





超短线战法之三:

勇于在“空中加油”时介入强势股做第2波。

具体操作:如果一只股票走牛而你没有来及骑上,那么还有一个机会,就是在这只黑马奔跑途中加料喝水休整的时候套住它。从技术上,就是在第一波上涨后的二浪调整阶段,趁机介入,也就是在人们常说的“空中加油”时买入,吃它的第二段行情。

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-12-13 19:34 复制 查看全部楼层
一旦出现股票“长阴+长腿踩线”试盘,必是大牛股的征兆,坚定捂股,股价或将一飞冲天!

短线操作,是大多数散户交易者最为乐此不彼的操作,实际也是难度最高的股市操作。在我个人的字典里面,短线品种只是持仓组合中的一部分,从来没有作为主力仓位操作,因为相对中长线的较为粗枝大叶的持仓,短线的技巧性和对情绪的管理更为苛刻,失误率也是最高。



而任何操作必须配合大盘的背景,和相关技巧,才能在股市稳赚不赔。

短线操作原则:

1、大势下跌时不要追逐强势股。但投资者应该开始积极选股,为将来大盘企稳时能及时参与炒作打下基础这时要重点选择股价曾经大幅下跌,而又能领先于大盘止跌企稳的个股,将它们列为关注对象。

2、要在大势交投活跃的时候做短线。大势交投活跃,成交量较大,个股涨幅明显并出现较多的个股涨停时,往往容易做短线。特别是当一个热点板块出现龙头时,可抓住龙头做一把。

3、当大盘止跌企稳时,要对初选个股进行复眩选择能够在形态上成功构筑小型底部形态的个股。个股的企稳时间要明显长于大盘的企稳时间,而且在探底成功后,个股的走势要有一定的独立性。

4、短线操作是以快速盈利为目的,不能盈利和不能快速盈利,都是与目的相违背的,这就应尽快摆脱这笔交易。



今天给大家详细讲解一个能抓住涨停板的形态:长阴+长腿踩线。

长阴+长腿踩线战法特征原理:

(1)这里的大阴线最好是要缩量。缩量代表着这里卖股票的人已经比较少了,成交量已经萎缩,但是依然出一根大阴线,大家不妨想想,到底是为什么?老铁认为,这个地方主力“吓人”的成分偏多,很多小散是属于上涨不舍得卖,一跌赶紧跑的操作策略,如此大阴,是主力最好的洗筹工具。



(2)第一天大阴吓出不少散户,主力第二天再来低开低走,全天就在下面飘着,大多数散户即使第一天忍住了,这里第二天也会割肉吧?主力趁机在这里抢夺低价位筹码,最后吸不到筹码的时候大单快速拉升,在最后割肉的散户不是心在滴血吗,我们绝不允许这样的事情发生。因此这里的长腿形成,主要关键词就是“主力吸筹”。



(3)回踩支撑位,非常重要,因为下跌只有精准回踩这里的支撑位,才能确定这里是主力的行为,不然无底的下跌,谁能确定这里是不是下跌途中的一个小反弹呢?



最后提醒一下,一般在出现长阴+长腿踩线组合后,快则一两天,慢则五到八天才会出现涨停,这需要大家耐心的等待。



识别真假“长腿踩线”的分水岭就是黄金线:

“长腿踩线”小结:第一,长腿踩线的量柱,必须是缩量的。第二,长腿踩线的量线,必须是精准的。第三,长腿踩线的时机,必须是大盘大跌,才能看出他的价值和实力。第四,长腿踩线的基因,必须与其他基因组合,才有爆发力。第五,长腿踩线的伏击,必须在次日确认其合格,才是伏击圈。



如图所示,它的第一特征是“长阴短柱”,第二特征是“长腿踩线”,第三特征是“倍量伸缩”,依次是11月30日长腿点击9.95元精准线,第一日缩量一倍,第二日温和放量一倍(刚好一倍),第三日再放量一倍,涨停。



其特征也是“长阴短柱+长腿踩线”,涨停前奏是:11月30日长腿点击13.70元精准线,此后第一日温和缩量近一倍,第二日价升量平,第三日放量涨停。由此看来,长腿踩线后的“缩量一倍”非常重要。

图片

图中可见,其特征还是“长阴短柱+长腿踩线”,其涨停前奏依次是:长腿点击6.56元精准线,此后第一日缩量一倍,第二日价升量缩接近一倍,第三日倍量涨停。其中11月30日和12月1日是并肩精准线。

以上三例,都是“长阴短柱+长腿踩线+倍量收缩”,其“踩线”都是“精准线”,“缩量”都是“缩倍量”,结合起来看就是“倍量伸缩”。

下面我们来看几个案例

图片

这个图是万方发展000638,2015年11月底到12月上旬时候的一段K线截图。在红色方框内,出现了长阴+长腿形状,之后在出现该基因组和的第6天涨停。

图片

同样的,国创新高002377在2016年5月12日开始出现了长阴+长腿的组合,其后马上就出了一个涨停板。

种种案例说明,这里的涨停板并不是巧合,而是主力的谋合,这后面有主力的精心策划。

长阴+长腿踩线的形态特征:

1.这里的大阴线下的成交量最好是缩量的。

2.这个长腿形成的长下影线一般超过实体的一倍,是为“长腿”。

3.这里的长腿最低点最好是精准回踩前期的支撑位。

这种涨停基因,不仅适合个股,对大盘的判断同样起作用。

图片

这是2016年2月底大盘的一段走势,同样是长阴+长腿踩线的组合。大盘涨停老铁是很难看到了,但是后市这种放量大阳,大家喜闻乐见的,这里的意义,就不用再多说吧。

最后提醒一下,一般在出现长阴+长腿踩线组合后,快则一两天,慢则五到八天才会出现暗涨停,这需要大家耐心的等待。

短线买卖点实战技巧:

1、股价虽一时跌破平均线之下,但移动平均线仍在向右上方运行,且不久之后股价再次反身站在平均线之上,仍是买进信号。

图片

2、股价跌破移动平均线之下,突然连续暴跌,远离平均线负乖离过大时,股价有可能向平均线弹升,被套投资者可以暂时持股,待股价反弹时在考虑出句。或者称超跌买点,只是不能期待股价反弹过高。



3、股价连续上涨,远离平均线之上,随后股价突然下降,但没有跌破正在上升的移动平均线,股价再次上攻时,可以加码追进。



4、移动平均线从下降逐渐走平,股价从移动平均线的下方向上穿越移动平均线,并且20日移动平均线有向上翘头的行为,属于买入信号。

图片

5、股价下降趋势途中,有时股价反弹偶尔向上突破移动平均线,但移动平均线仍在向右下方运行,随后股价再次跌破移动平均线之下,应视为股价反弹结束,应当继续看空卖出股票。

图片

6、股价突破或站在移动平均线之上,突然连续大涨,股价远离移动平均线正乖离过大时,投资者追涨意愿就会下降,股价有可能短期见顶回落,属于卖出信号。

图片

牢记这9张思维导图,你就是赢家!

1、股市导图总纲

图片



2、k线基础

图片



3、均线基础

图片



4、切线基础

图片



5、指标分析

图片



6、选股方法

图片



7、板块轮动

图片



8、统计分析

图片



9、股市中的各色骗局

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

吕运承
Lv.3
发表于 2020-12-12 12:40 复制 查看全部楼层
下载学习,谢谢分享,希望能好用

举报

使用道具 扔鸡蛋(0) 回复

王光亮001
Lv.3
发表于 2020-12-12 12:33 复制 查看全部楼层
幅图源码有吗

举报

使用道具 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-12-12 01:41 复制 查看全部楼层
涨停回马枪战法指的是有了涨停后,我们抓回调后再次上涨的一段,股价已经上涨且以涨停明示(关注度直线上升),所以我们建议,使用涨停回马枪只做短线,可以长期做此股波段,尽量不要长期连续持有,此新版涨停回马枪特适合做超短线,快进快出,盈利为先。

“涨停回马枪”战法简述:

1、股价涨停板后,主力进行短线洗盘。

2、当股价跌到某条均线附近时,再度崛起!

涨停回马枪的技术要点:
1、成交量的是这一面的情况看,股价调整是越小越好。

2、从时间上面看的话,个股涨停后最高点调整下来的时间为2天最佳。

3、在均线系统的支撑上面来看,当股价调整至10日均线或13日均线附近得到有效支撑为最佳。

形态特征:
1、底部突破,出现放量的涨停板

2、封涨停板之后,股价出现回调,不跌破涨停板阳线实体的下沿。

如上图所示,涨停回马枪就是涨停牛回头的强化版。涨停之后,股价调整但是不跌破涨停板的实体下沿,最好就是有资金流入,并且回踩重要均线。

【涨停回马枪战操】

“涨停回马枪”就是在个股涨停后回调的机会低吸,然后坐等主力抬轿。当市场低迷时,一般有过涨停的股票回调到了支撑位的时候都会出现回档现象,出现二次上涨的行情,所以熊市的时候不要满仓,回马枪得操作买点就是反弹点!回马枪的操作风险还是比较小的。

涨停回马枪操作只选涨停的股票,涨停就是短线理想论坛,涨停是主力资金运作的结果,显示出主力的实力,说明庄家积极做多的意愿)不涨停的股票不关注。

技术要点:
1、时间周期:关注从涨停板后的最高点回调下来的第3天、第5天、第8天、第13天得关键时间周期买卖点,强势股一般回调到了第5天或者是第8天就会有买入机会,超过了13天行情就会开始走弱了。

2、黄金分割线:从涨停板之后的最高K线的最高价从上往下画到涨停板前的起点,也就是波段最低点。然后在支撑线38.2%、50%、61.8%附近买入。

A、超强势回调的股票会打到分割线的38.2%;

B、强势回调的股票会打到分割线的50%;

C、弱势回调的股票会打到分割线的61.8%;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-12-10 09:28 复制 查看全部楼层
C5周:CCI(25),COLORSTICK,COLORYELLOW;

生命CCI线:=CCI(84),COLORWHITE;

底部线:=-100.00,COLORYELLOW,NODRAW;

警戒线:=300.00,COLORWHITE,NODRAW;

生命线:=100.00,COLORYELLOW,NODRAW;

升浪区:CCI>-10,COLORYELLOW;

DRAWICON(CROSS(200,CCI),250,2);

DRAWICON(CROSS(CCI,-200),-250,1);

弱转强:=CROSS(CCI,-200) AND CCI>REF(CCI,1),NODRAW;

STICKLINE(CROSS(CCI,-200) AND CCI>REF(CCI,1),CCI,0,2,0),COLORF0FF00;

DRAWTEXT(CROSS(CCI,-200),底部线,'试压')COLORYELLOW;

强转弱:=CROSS(200,CCI) AND CCI<REF(CCI,1),NODRAW;

STICKLINE(CROSS(200,CCI) AND CCI<REF(CCI,1),0,CCI,2,0),COLORF0FF00;

DRAWTEXT(CROSS(200,CCI),底部线,'试压')COLORYELLOW;

DRAWTEXT(CROSS(生命CCI线,底部线),底部线,'上升浪')COLORRED;

DRAWTEXT(CROSS(生命CCI线,警戒线),警戒线,'警惕')COLORRED;

DRAWTEXT(CROSS(生命CCI线,生命线),生命线,'强')COLORRED;

N:=9;6;M1:=3;M2:=3;P:=9;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:=SMA(RSV,M1,1);

D:=SMA(K,M2,1);

JJ:=P*(3*D-2*K);

J:=((3 * K) - (2 * D));

MAIRU:= CROSS(K,D) AND K<20;

MAICHU:= CROSS(D,K) AND D>80;

VAR2:=REF(LOW,1);

VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;

VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);

VAR5:=LLV(LOW,13);

VAR6:=HHV(VAR4,13);

VAR7:=IF(MA(CLOSE,34),1,0);

VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;

VAR9:=IF(VAR8>100,100,VAR8);

大户日均吸筹:VAR9,LINETHICK2,COLORF00FF0;

STICKLINE(VAR9>-120*3,0,VAR9*3,8,1),COLORF00FF0;

快线:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,LINETHICK2,COLORYELLOW;

慢线:=SMA(快线,M1,1),COLORYELLOW;

空:=SMA(慢线,M2,1),COLORYELLOW;

BB:=IF(BARSLAST(CROSS(慢线,快线))>=3 AND CROSS(快线,慢线) AND 慢线<30,20,0);

{STICKLINE(BB,0,100,7,1),COLORYELLOW;DRAWICON(BB>0,10,7);}

AA:=IF(BARSLAST(CROSS(快线,慢线))>=4 AND CROSS(慢线,快线) AND 快线>50,20,0);

{STICKLINE(AA,80,100,7,1),COLOR00FF00;}

{DRAWICON(AA>0,90,8);};

BN:=5;

BVAR1:=4*SMA((CLOSE-LLV(LOW,BN))/(HHV(HIGH,BN)-LLV(LOW,BN))*100,5,1)-

3*SMA(SMA((CLOSE-LLV(LOW,BN))/(HHV(HIGH,BN)-LLV(LOW,BN))*100,5,1),3.2,1);

BVAR2:=8,COLORGREEN,LINETHICK0;

杀庄:=BVAR1<=8;


PDTC:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);

CCIDTC:=((PDTC - MA(PDTC,14))*(100))/((1.5)*(AVEDEV(PDTC,14)));

RSI1DTC:=((SMA(MAX(CLOSE - REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),6,1)))*(100);

黄底:=(CCIDTC < (-100));

蓝底:=(RSI1DTC < 25);

VAR1MMQZ:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;

红底:=VAR1MMQZ<-9 AND VAR1MMQZ> REF(VAR1MMQZ,1);

底:=黄底 OR 蓝底 OR 红底;

抄底:=200000000000*MAX (杀庄,底)*DMA(EMA(C,60),SUM(V,60)/CAPITAL)/EXP(2*HIGH-LOW/3),COLORYELLOW,LINETHICK2;

DRAWTEXT(CROSS(抄底,0.03),0.03,'盯')COLORYELLOW;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

基金量化
Lv.2
发表于 2020-12-8 12:30 复制 查看全部楼层
可惜没有币了

举报

使用道具 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-12-7 02:20 复制 查看全部楼层
DPZX:=EMA(C,1),NODRAW;
GGZX:=AMOUNT/V/100;
重心:=IF(C<300,GGZX,DPZX),NODRAW;
今重心:LLV(重心,2)COLORGREEN,NODRAW;
ZC1:=CONST(LLV(重心,2));
ZC2:=CONST(LLV(重心,4));
VAR1:=(C+H+O+L)/4;
MA5:=MA(C,5),COLOR000099;
MA10:=MA(C,10),COLOR006600;
MA20:=MA(C,20),COLOR005555;
ZB1:=EMA(C,34);
长期趋势:EMA(ZB1,13),COLORRED,LINETHICK3;
SQX:=(C-MA(CLOSE,13))*100;
DIFF:=EMA(MA(SQX,7),1),COLORWHITE;
DEA:=EMA(DIFF,7),COLORYELLOW;
MACD:=(DIFF-DEA)*2,COLORSTICK;
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA15);
上:=EMA(C,3),COLORBLUE,LINETHICK1;
中:=EMA(C,5),COLORWHITE,LINETHICK1;
下:=EMA(中,5),COLOR00FF00,LINETHICK1;
QQ:= C<中;
MM:=上>REF(上,1) AND REF(上,1)<REF(上,2) ;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1Q:=MEMA(CLOSE,5);
MA2Q:=ATAN((MA1Q/REF(MA1Q,1)-1)*100)*180/3.1416;
MA3Q:=IF(MA2Q>0,MA2Q,MA2Q);
MA5Q:=MA(CLOSE,5),COLOR888899;
MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
C<REF(C,1) AND C<REF(C,2);
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C<REF(C,1);
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
CROSS(MA(VAR09,2),VAR09))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSVQ:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSVQ,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR04;
买3:=(VAR14 OR VAR15) AND VAR02;
买4:=(VAR02 AND VAR11) OR (VAR04 AND VAR11);
买5:=(金叉 AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=买1 OR 买2 OR 买3 OR 买4 OR 买5 AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:=XG0 OR XG1;
XGQ:=XG11;
拐牛:XGQ,COLORRED,NODRAW;
DRAWTEXT(XGQ,L*0.99,'●拐牛'),COLORRED;
MA1:=MA(C,5);
MA2:=MA(C,10);
MA3:=MA(C,21);
破N:=REF(MA1,1)<REF(MA2,1)AND MA2>REF(MA2,1);
试摸N:=C>MA(C,10) OR H>=MA2;
再上N:=C>O AND REF(C,1)< MA(C,10) AND 试摸N AND 破N AND MA(C,21)<MA(C,10);
有行情:=再上N AND (CROSS(C,长期趋势) OR CROSS(L,长期趋势) OR CROSS(H,长期趋势));
DRAWTEXT(有行情,LOW*0.98,'●'),COLORGREEN;
VAR1MZ:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR2MZ:=((REF(VAR1MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR3MZ:=((REF(VAR2MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR4MZ:=((REF(VAR3MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR5MZ:=((REF(VAR4MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR6MZ:=((REF(VAR5MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR7MZ:=((REF(VAR6MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR8MZ:=((REF(VAR7MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR9MZ:=((REF(VAR8MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARAMZ:=((REF(VAR9MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARBMZ:=((REF(VARAMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARCMZ:=((REF(VARBMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
{红K}
{STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,3,0),COLOR000099;
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,2,0),COLOR0000BB;
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,1,0),COLOR0000DD};
VARDMZ:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VAREMZ:=((REF(VARDMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARFMZ:=((REF(VAREMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR10MZ:=((REF(VARFMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR11MZ:=((REF(VAR10MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR12MZ:=((REF(VAR11MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR13MZ:=((REF(VAR12MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR14MZ:=((REF(VAR13MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR15MZ:=((REF(VAR14MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR16MZ:=((REF(VAR15MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR17MZ:=((REF(VAR16MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR18MZ:=((REF(VAR17MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
{绿K}
{STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,3 ,0 ),COLOR00BB00;
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,2 ,0 ),COLOR00DD00;
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,1,0 ),COLOR00FF00};
VAR19MZ:=(REF((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),1) AND VAR1MZ);
VAR1AMZ:=(REF((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),1) AND VARDMZ);
{粉红}
CAX:=MAX(REF(CLOSE,2),REF(CLOSE,1));
{STICKLINE(VAR19MZ,CAX,O,3 ,0 ),COLORBB11BB;
STICKLINE(VAR19MZ,CAX,O,2 ,0 ),COLORDD44DD;
STICKLINE(VAR19MZ,CAX,O,1 ,0 ),COLORFF66FF};
{黄色}
CIN:=MIN(REF(CLOSE,2),REF(CLOSE,1));
{STICKLINE(VAR1AMZ,CIN,O,3,0),COLOR00AAFF;
STICKLINE(VAR1AMZ,CIN,O,2,0),COLOR00CCFF;
STICKLINE(VAR1AMZ,CIN,O,1,0),COLOR00EEFF};
牛节点:=CROSS(EMA(C,5),EMA(C,30))AND CROSS(EMA(C,10),EMA(C,20));
DRAWICON(牛节点,L*0.99,13);
CSAR:=SAR(10,2,20);
持股:=IF(CSAR<=L,CSAR,0),CIRCLEDOT,COLORRED{持股};
短期趋势:=EMA(SLOPE(C,21)*20+C,42),POINTDOT,LINETHICK1,COLORYELLOW;
STICKLINE(1,短期趋势,短期趋势,1,0),COLORYELLOW;
止损:=EMA(C,5),COLORYELLOW,LINETHICK1;
VVAR1D:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);
短底:=EMA(VVAR1D,5);
支撑:=HHV(短底,60);
MAN:=(SMA(HIGH,21,2) * 1.05);
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
中D:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
X1D:=EMA(中D,10);
RSVD:=SMA(下档线,3,1);
K大:=SMA(RSVD,3,1);
D大:=((3 * RSVD) - (2 * K大));
J12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(J12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力位:=IF(CROSS(D24,D大),HIGH,REF(HIGH,BARSLAST(CROSS(D24,D大)))),COLORFFFFFF;
牛浮面:=CROSS(CLOSE,MA20) AND HIGH < 压力位 AND OPEN < MA20
AND HIGH < 支撑 AND MAN - REF(MAN,1) > 0 AND X1D - REF(X1D,1)>0 AND
D大 < 63 AND MA20 - REF(MA20,1) > 0,COLORWHITE;
DRAWTEXT(牛浮面,L,'●牛浮面'),COLORWHITE;
{STICKLINE(ISLASTBAR,ZC1,ZC1,120,0),LINETHICK1,COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=15,ZC1*1.02,'关键价位'),COLORGREEN;
DRAWNUMBER(ISLASTBAR,ZC1*1.02,ZC1+000),COLORGREEN;
STICKLINE(ISLASTBAR,ZC2,ZC2,120,0),LINETHICK1,COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=15,ZC2*0.99,'支撑价位'),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,ZC2*0.99,ZC2+000),COLORYELLOW};
决策:=IF(ISLASTBAR,压力位,DRAWNULL),COLORMAGENTA;
{STICKLINE(ISLASTBAR ,决策,决策,60,1),LINETHICK3,COLORFFFFFF};
底部:=LLV(HIGH,30),COLOR00FF00;
超跌:=IF(ISLASTBAR,底部,DRAWNULL),COLORRED;
{STICKLINE(ISLASTBAR ,超跌,超跌,60,1),LINETHICK3,COLORRED;
STICKLINE(ISLASTBAR,REF(今重心,1),REF(今重心,1),10,0),COLORGREEN};
T1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),STRCAT('敢死队席位:',EXTERNSTR(0,13)),'');
T2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),STRCAT('智能诊断:',EXTERNSTR(0,12)),'');
T3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),STRCAT('年报业绩:',EXTERNSTR(0,8)),'');
T4:=IF(FINDSTR(EXTERNSTR(0,10),','),STRCAT('主题投资:',EXTERNSTR(0,10)),'');
T5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),STRCAT('解禁日期:',EXTERNSTR(0,15)),'');
T6:=IF(FINDSTR(EXTERNSTR(0,1),','),STRCAT('千股千评:',EXTERNSTR(0,1)),'');
T7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),STRCAT('业绩预报:',EXTERNSTR(0,14)),'');
T8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),STRCAT('机构评级:',EXTERNSTR(0,11)),'');
T9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),STRCAT('中报业绩:',EXTERNSTR(0,9)),'');
N:=IF(TOTALBARSCOUNT>=120,120,TOTALBARSCOUNT);
{本输出适用于锁定K线数为120,N可改为你习惯的K线数,见下图}
HH0:=HHV(H,N);
LL0:=LLV(L,N);
MM0:=CONST((HH0+LL0)*0.5);
S01:=CONST(IF(REF(C,N-15)>MM0,1.00,-0.08));
S02:=CONST(IF(REF(C,N-15)>MM0,-1,1));
S1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),S01+(0.08*S02),S01),NODRAW;
S2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),S1+(0.08*S02),S1),NODRAW;
S3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),S2+(0.08*S02),S2),NODRAW;
S4:=IF(FINDSTR(EXTERNSTR(0,10),','),S3+(0.08*S02),S3);
S5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),S4+(0.08*S02),S4);
S6:=IF(FINDSTR(EXTERNSTR(0,1),','),S5+(0.08*S02),S5);
S7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),S6+(0.08*S02),S6);
S8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),S7+(0.08*S02),S7);
S9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),S8+(0.08*S02),S8);
KK:=IF(S1<=0,0.05,IF(S1>=0,-0.05,0));
DRAWTEXT_FIX(1,0,S1+KK,0,T1)COLOR00FFFF;
DRAWTEXT_FIX(1,0,S2+KK,0,T2)COLORFFFFFF;
DRAWTEXT_FIX(1,0,S3+KK,0,T3)COLORFF00FF;
DRAWTEXT_FIX(1,0,S4+KK,0,T4)COLOR0088FF;
DRAWTEXT_FIX(1,0,S5+KK,0,T5)COLOR00FF00;
DRAWTEXT_FIX(1,0,S6+KK,0,T6)COLOR0000FF;
DRAWTEXT_FIX(1,0,S7+KK,0,T7)COLOR00CCFF;
DRAWTEXT_FIX(1,0,S8+KK,0,T8)COLORFF88FF;
DRAWTEXT_FIX(1,0,S9+KK,0,T9)COLORBBFFFF;
X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWICON(CROSS(X2,X3),L*0.99,7);
XG:CROSS(X2,X3),NODRAW;
DRAWICON(CROSS(X3,X2),H*1.01,8);
YY1:=C>MA(C,5) AND OPEN<MA(C,5);
YY3:=C>MA(C,10) AND OPEN<MA(C,10);
YY5:=C>MA(C,30) AND OPEN<MA(C,30);
DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.05,'↖神话'),COLOR00FFFF;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-12-6 19:58 复制 查看全部楼层
快线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;

慢线:EMA(REF(快线,1),2),LINETHICK1,COLOR00FFFF;

总趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,55),2),2),2),2),LINETHICK1,COLORFF00FF;

HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;

AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);

QY:=BACKSET(AA,HIGHN+1);

CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);

DRAWICON(CC,H*1.02,2);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

DINGBU1:=REF(DINGBU,DDD+1);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD+1);

GDCS2:=CONST(DINGBUTS1);

DINGBU2:=REF(DINGBU1,DDD+1);

MM:=IF(CURRBARSCOUNT>GDCS2,0,1);

高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;

DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;

DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;

AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);

QY1:=BACKSET(AA1,LOWN+1);

CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);

DRAWICON(CC1,L*0.98,1);

DD1:=BARSLAST(CC1);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

YDB:=IF(DD1,REF(L,DD1),L);

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

DDCS1:=CONST(DDTS1);

ZDB:=REF(YDB,DD1+1);

DDTS2:=REF(DDTS1,DD1+1);

DDCS2:=CONST(DDTS2);

低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;

ZGSTAR:=(高点压力+低点支撑)/2;

ZGEND:=CONST((高点压力+低点支撑)/2);

STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);

中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORWHITE,LINETHICK2;

DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;

DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;

DRAWTEXT_FIX(C>O,0.09,09.09,0,' '),COLORYELLOW;

STICKLINE(C/REF(C,1)>1.097 AND C=H,H,L,0,0),COLORYELLOW;

STICKLINE(C/REF(C,1)>1.097 AND C=H,C,O,3,0),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0,0,0,CODE),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,STKNAME),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,HYBLOCK),COLORCYAN;

DRAWTEXT_FIX(ISLASTBAR,0.3,0,0,DYBLOCK),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,GNBLOCK),COLORGREEN;

{DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,FGBLOCK),COLORWHITE;}

{DRAWTEXT_FIX(1,0.01,0,0,DYBLOCK),COLORYELLOW;

DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK),COLORYELLOW;


DRAWTEXT_FIX(1,0.13,0,0,'概念:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.16,0,0,GNBLOCK),COLORYELLOW;}

DRAWTEXT_FIX(1,0.01,0.05,0,'风格:'),COLORGREEN;

DRAWTEXT_FIX(1,0.04,0.05,0,FGBLOCK),COLORGREEN;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-12-5 09:37 复制 查看全部楼层
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=(MA((C-HY1)*28,2))*0.1;
操盘4:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),24,24+多空趋势,1.5,0),COLORRED;
减仓4:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),24,24+多空趋势,1.5,0), COLORYELLOW;
反弹4:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),24,22+多空趋势,1.5,0),COLORBLUE;
寻底4:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),24,24+多空趋势,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,22,22.3),’ 多空’),COLORWHITE;
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
成交量:V,COLORWHITE,NODRAW;
主力能量:(主力-均量)COLORMAGENTA,NODRAW;
大户能量:(大户-均量)COLORYELLOW,NODRAW;
中户能量:(中户-均量)COLORLIBLUE,NODRAW;
散户能量:(散户-均量)COLORBLUE,NODRAW;
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORRED;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORYELLOW;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORBLUE;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,14.4,14.6),’ 机构’),COLORMAGENTA;
操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORRED;
减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORYELLOW;
反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORBLUE;
寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,9.6,9.8),’ 大户’),COLORYELLOW;
JZ:=V/(ABS(主力能量)+ABS(大户能量)+ABS(中户能量)+ABS(散户能量));{4,9,17,34日换手偏离值均分成交量}
ZLCJ:=JZ*ABS(主力能量);{4日换手偏离均量值换算当日成交量}
DHCJ:=JZ*ABS(大户能量);{9日换手偏离均量值换算当日成交量}
ZHCJ:=JZ*ABS(中户能量);{17日换手偏离均量值换算当日成交量}
SHCJ:=JZ*ABS(散户能量);{34日换手偏离均量值换算当日成交量};
换手率:VOL/CAPITAL*100,LINETHICK0;
机构量:=ZLCJ,COLORMAGENTA,NODRAW;
大户量:=DHCJ,COLORYELLOW,NODRAW;
中户量:=ZHCJ,COLORLIBLUE,NODRAW;
散户量:=SHCJ,COLORBLUE,NODRAW;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-11-29 18:53 复制 查看全部楼层
找点能用的分享给大家
作手新一,起步10W,到19年职业炒股7年,职业前已经有稳定获利的能力。入市13年。

在大学刚知道股市时没什么钱做,但刚接触就知道如果这世界上还有一样东西我能做的比绝大多数人好的话那就是它了,本着悟道的心,在图书馆一边每天看盘一小时一边看七八个小时的经济金融股市的书,如此坚持了近两年。
一、资金线路
2012年5月开始10W起步,到年底半年,24W。(7个月140%收益)
2013年,创业板大牛市,到5月底时还没翻倍不到48W(半年不到100%)。到年底账户资金100W(7个月120%收益,13年416%倍收益)。
2014年2月半仓中线票是威华股份,拿了十个月,一分钱没赚,15年伊始我卖了威华,职业唯一一次中线以失败告终。
2014年10月份开通了融资融券。2014年11月之前的年收益就一年的开支。
2014年12月9号,我所有资金满仓加融资买入西部证券,当天账户全仓回撤20%多。
2014年底我账户资金200多万(14年100%多收益)。我几乎全款买路虎,又一个因为见识不足而做的脑残的决定。
2015年2月底到15年6月4号吊颈线,我账户资金翻了7倍,中间连一次2%以上的回撤都没有,进攻不谈,防守绝对顶级(4个月资金1400W,7倍收益)。
2015年6月15开始的股灾中我基本没再碰股票。
2015年6月10号转入股指期货账户200万,
7月8号一个月不到时间,200万的期指账户带来了近400万的收益,还是在我控制为5倍杠杆开仓的情况下。
7月8号跌停买的贵州百灵我第二天冲涨停卖了。因为一直做空,在接下来的救市中我看低了反弹高度。
7月9号第一波救市行情全面启动,我竟然只动用了800万仓,而且第二天冲高全卖。
后面两天看着救市行情全面引爆我的心态又一次乱了,我将自己股票账户上全部资金转入期指,准备迎接反弹后的第二波杀跌,
7月14小仓位做空,
7月15加仓扩大战果,
7月16号早盘高点再加,然后利润被吞掉,不甘心,再加,仓位彻底失控了,再后面几个交易日我在股指期货中最高持仓1亿多的空单,因为点位控制的还算好。
7月24日周五早盘浮亏只有4%,但已经是我全部的股指期货利润,中间我还错过了救市行情的一波和二波。
7月24号临近中午这波持仓一度亏损600万,我硬扛,期指回落,我在下午开盘后平掉所有期指空单,我在期指上所有正确交易因为这一次失败交易而全部抵消。虽然下午期指再次拉升,我多么强烈的感觉二次探底行情临近了,但实在没有力气再在这个还没能力驾驭的市场豪赌了。
8月份股灾2.0中我亏了近20%,股票账户一度只有1200多了。
10月启动的反弹行情,最终也只有50%的收益,这是我职业以来犯得最重大的战略失误(1800W,50%收益)。
2016年的熔断行情亏了15%。
2016年11月底资金不到3000W。
2017年06-03 11:23,16年到现在翻了一倍吧(6000W)。
06-28 20:31 离7000万左右这数字还差两截。
到19年根据龙虎榜分析,资金已经过亿。
二、下面整理的是作手新一的原话:
1,围着主线做,多研究龙头,研究涨停,不断积累,总结,反思等待进阶的到来。
2,炒股前期投入大,没有稳定盈利前尽量少投入资金多投入精力。刚入市不要想着赚钱要想着悟道。
3,悟道的理解因人而异吧,于初入市小散来说,对市场有很好的认知和理解,能持续从市场赚钱,虽有反复,但始终能及时控制。
4,做涨停更有效率更确定,能力不足时需要这些。
5,涨停开了就开了,标的选择符合自己模式就行了。
6,熊市比的不是快而是稳,你既然有在熊市超短的斗志,那你也要有在这种市场发现确定性机会的能力,这种确定性不光是概率,还有实效性和高盈亏比。满仓出击,要有确定性。
7,熊市比的是稳定性,不是牛市,多在选股和节奏上做文章。
3,我现在擅长和交易本能还是做涨停,低吸是应市场而生的策略,也是顺着市场节奏低吸绝对热门股。
9,小资金,我这种级别的资金,包括一亿内的资金都可以等盘面出现反转动作时再出手。
10,索罗斯所说的,判断对错不重要,关键是对的时候我能赚多少,亏的时候我亏多少!
11,我低吸盾安的时候做了当天大盘破位它跌停,周一重仓加的准备的。
12,小资金控制回撤难在控仓,不控仓回撤必然大,无论何种模式!所以小资金在行情好赚钱的时候要拼命赚,以功代守(但也不是说不控仓);
13,15年以前的以小做大阶段,我的操盘临盘选择的交易很多,强势股超预期,涨停板打开的票,分时穿云箭,超预期高开,盘中资金的板块切换这些强势买点都是盘中给你的,这些买点的选择都需要盘感和眼光。
14,技术分析我基本只看k线图形、均线、量能,其实人气逆转在标的的选择时还是很考究这些的。
15,游资重要的不是预判消息,而是消息出来后的应变。
16,有时候你选好股,觉得很有短线交易价值,可为什么不动呢,为什么没有大资金把它打上去呢,那是因为大资金买股票比你更讲究时机,也更讲究确定性。底下要不到筹码,封住涨停筹码要够了,还要顾及明天的承接,主线和分支的关系要照顾,既要围绕主流又要做好切换,要维护自己的江湖地位,也要局部战役全身而退...这些矛盾都是这个市场生态中不同的体量资金需要考虑的,而1000万以内的资金分仓做,根本不需要考虑这些,所以说为什么只有结构性大热点,牛市才能成就亿级资金,因为仓位。深刻理解仓位二字是理解大资金的行为逻辑的开始。
17,市场趋势向下时我的仓位控制,对杂毛机会的屏蔽做的的很好。
18,只有有外挂的股票打出空间打出赚钱效应才能由点带面。
19,我认识的几个做短线亏钱厉害的都是盘中管不住手,买了杂毛买点,真的机会来了没票子了,提高自己的判断和定力,别无他途,你就告诉自己,短线乱打是回归赤贫的捷径。
20,正确的决定永远不嫌迟。
21,妖股的逻辑其实无需多讲,就是人心思涨又找不到逻辑,唯有靠超跌妖股先打出赚钱效应,既然要打出赚钱效应空间就要拓开。
22,牛股更多是考量板块契机,和自身形态,位置,题材,分时让你决定上的其中一个因素。
23,股票不是从你争我夺的收割中获益的,利润来自对价值的发掘,对人性的纠错。
24,在这个市场你的核心竞争力是思维见识和执行力,自我成长也该是围着这两点进行。
25,个人攻击爆表的亏了,打回来。攻击不够(主要是牛股眼光和把握能力)就在利润出现回撤时谨慎起来,等待自己积累的确定模式或大盘有利时。
26,股市最好的地方就是不缺机会,再绝望时一根大阳线就改变三观了。
27,行情不好很少超过1/10仓位。
28,我的理解是理解投机的价值,你买了然后接你棒的人还会有念想!
29,好的超短选手复盘要选股,盘中更要选股
30,捕捉大资金承载票,这种票和龙头一样不会每天都有,讲究逻辑要绝对主流,成交要大,小票打的欢时大资金看的蛋疼需要这样的票作为火力输出的。
31,这个市场不在主线的追涨都是自己找难受,封住了第二天也没接力。
32,图形很重要,绝世美女肯定是各方面俱佳,看图形好比远观女人身段,查股本,题材,行业好比近观女人的容颜身材,炒作过程的内核节奏理解好比交往了解女人内涵!
33,逻辑内核是最强源动力。
34,培根大师的话,在这个市场,狡诈者轻鄙逻辑,愚鲁者羡慕逻辑,唯聪明者善于运用逻辑!而最后集大成者都是不断修行的聪明人。
35,小资金,有天赋最好是以攻代守,因为现实会给你压力;能力不够的就少投入资金,边学边练!
36,鉴别烂板价值,关键是理解逻辑,了解公司质地!这些是决定分歧后方向的内核,情绪博弈越来越需要结合股票内在价值了。纯粹操作情绪的分歧转一致当天板了,隔夜一冷静啥都明白了。
37,索罗斯说,世界经济史是一部基于假象和谎言的连续剧。要获得财富,做法就是认清其假象,投入其中,然后在假象被公众认知之前退出游戏。

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-11-29 17:58 复制 查看全部楼层
         解套王
回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);
经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;
MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))) /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}
回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));
上线:=SMA(C,6.5,1);
一号支撑线:SMA(C,14.5,1);
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
上线2:=SMA(C,3.5,1);
DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,55),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'减仓') ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),COLORBLUE,LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
DRAWTEXT( CROSS(上线1,上线) AND 上线1>操作,LOW *0.92,'买进' ),COLORYELLOW;
VAR1:LLV(A7,21);
VAR2:HHV(A7,30);
DRAWTEXT( CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 AND CLOSE>VAR1,LOW *0.98,'见底' ),COLORYELLOW;
YCX:=操作>=REF(操作,1);
H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORYELLOW;
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,COLORYELLOW;
D:=MA(CLOSE,89)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;
RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K:=SMA(RSV,3,1);
D1:=SMA(K,3,1);
J:=3*K-2*D1;
VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
F:=MA(E,3)+0.03;
G:=MA(E,1);

DRAWICON(CROSS(F,G) AND J>65,HIGH*1.02,15),COLORGREEN;
DRAWICON(CROSS(G,F),LOW *0.9,9),COLORYELLOW;
DRAWTEXT(CLOSE>OPEN AND H1<C AND O<L1 AND YCX AND CROSS(上线1,操作) AND LOW>VAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT( CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),COLORYELLOW;
DRAWTEXT(CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT(CLOSE>OPEN AND 操作>上线 AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
DRAWTEXT(CLOSE>OPEN AND CROSS(上线,一号支撑线) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,3.2,0),COLORBB00FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.7,0),COLORFF33FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.1,0), COLORFF66FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,1.5,0),COLORFF99FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;

网上找金子,看你能用不

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-11-29 07:58 复制 查看全部楼层
武汉111 发表于 2020-10-25 09:33
你说的几个选股公式在哪里.主题1-3在哪里

你看下我的所有主题就知道了

举报

使用道具 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-11-29 07:57 复制 查看全部楼层
公式好坏不重要,关键成语多,看着也是-种享受

举报

使用道具 点亮(1) 扔鸡蛋(0) 回复

快乐飞牛
Lv.3
发表于 2020-11-29 01:47 复制 查看全部楼层
EMA13:MA(C,13),COLORWHITE,LINETHICK2;
EMA34:MA(C,34),COLORYELLOW;
EMA55:MA(C,55),COLORFF00FF;
{红杏出墙}DRAWKLINE(H,O,L,C);
DRAWTEXT_FIX(1,0.02,0,0,'☆☆'),COLORRED;
HX1:=EMA13<EMA34 AND EMA34<EMA55;{股价长期下跌,并且远离长期均线}
HX2:=BARSLAST((C-EMA13)/EMA13*100<-6);{收盘价在13均线%6到现在的天数}
HX3:=ABS(1-EMA55/REF(C,1))>0.1;
HX6:=BARSLAST(CROSS(EMA55,EMA34))>=20;{13日均线下降趋于走平}
HX4:=ABS(1-REF(EMA13,1)/EMA13)<0.004 AND C<EMA34;
HX5:=REF(C,1)<EMA13 AND C>EMA13 AND C>O;
HX7:=HX1 {AND HX3} AND HX4 AND HX5 ;
HX8:=HX7 AND FILTER(HX7,10);{满足后10天内不标记}
DRAWTEXT(HX8,L-0.4L,'1红杏出墙'),COLORYELLOW;
{蚂蚁上树}
BR1:=COUNT(BETWEEN(((C-O)/O)*100,0,5) ,5)=5;{5日内收盘价都比前日收盘价高}
BR2:=(ABS(EMA13-EMA34)+ABS(EMA34-EMA55))/C<0.1;{主均线相距很近或基本持平}
BR3:=C>EMA55 AND COUNT(L<EMA55,5)>=1;{股价送上55日均线}
MYSS:=BR1 AND BR2 AND BR3;
DRAWTEXT(MYSS AND FILTER(MYSS,5), L-0.4L,'1蚂蚁上树'),COLORYELLOW;
{马失前蹄}
MSQT1:=EMA55/EMA13>1.04 AND EMA13/C>1.03;
MSQT2:=O<=REF(L,1) AND REF(O,1)/REF(C,1)>1.03;
MSQT:= MSQT1 AND MSQT2;
DRAWTEXT(MSQT, L-0.4L,'1马失前蹄'),COLORYELLOW;
{绝处逢生}
JCFS1:=EMA55>EMA13 AND EMA13>C;
JCFS2:=O<=REF(L,1) AND C/O>1.05;
JCFS:= JCFS1 AND JCFS2;
DRAWTEXT(JCFS, L-0.4L,'1绝处逢生'),COLORYELLOW;
{金屋藏娇}
JWCJ1:=C<O AND REF(C,1)<REF(O,1);
JWCJ2:=O<=REF(C,1) AND L>=REF(L,1);
JWCJ3:=REF(C,1)/REF(L,1)>1.02;
JWCJ4:=EMA13<EMA34 OR EMA13<EMA55;
JWCJ:=JWCJ1 AND JWCJ2 AND JWCJ3 AND JWCJ4;
DRAWTEXT(JWCJ, L-0.4L,'1金屋藏娇'),COLORYELLOW;
{日月合璧}
RYHB1:=REF(O,1)<=REF(C,2) AND REF(C,1)<REF(O,1) AND ABS(1-REF(C,1)/REF(L,1))<0.02;
RYHB2:=C>O AND ABS(1-C/REF(O,1))<0.025 AND ABS(1-O/REF(C,1))<0.025;
RYHB3:=EMA13<REF(EMA13,1) OR ABS(1-EMA13/REF(EMA13,1))<0.01 AND (EMA13<EMA34 OR EMA13<EMA55);
RYHB4:=REF(L,1)<=LLV(REF(L,1),10);
RYHB:=RYHB1 AND RYHB2 AND RYHB3 AND RYHB4;
DRAWTEXT(RYHB , L-0.4L,'1日月合璧'),COLORYELLOW;
{破镜重圆}
PJCY1:=REF(O,1)/REF(C,1)>1.02;
PJCY2:=O<=REF(C,1) AND C>=REF(O,1);
PJCY3:=(ABS(1-REF(C,1)/EMA55)<0.05 OR ABS(1-C/EMA55)<0.05 OR ABS(1-MA(C,2)/EMA55)<0.05);
PJCY4:=EMA13>EMA55 OR EMA13>MA(EMA13,5);
PJCY:=PJCY1 AND PJCY2 AND PJCY3 AND PJCY4;
DRAWTEXT(PJCY, L-0.4L,'1破镜重圆'),COLORYELLOW;
{步步高}
BBG1:=C>=REF(C,1) AND REF(C,1)>=REF(C,2);{3日内收盘价都比前日收盘价高}
BBG2:=V>=REF(V,1) AND REF(V,1)>=REF(V,2);{3日内量都比前日量高}
BBG3:=COUNT(C>=O,3)=3;
BBG:=BBG1 AND BBG2 AND BBG3;
DRAWTEXT(BBG AND FILTER(BBG,3), L-0.4L,'1步步高'),COLORYELLOW;
{黑客点击}
DJ1:=EMA13>EMA34 AND EMA34<EMA55;{13日均线大于34日均线,34日均线小于55日均线}
DJ2:=O>EMA55;{开盘价大于55日均线}
DJ3:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
DJ4:=O>C AND C<REF(C,1);
HKDJ:= DJ2 AND DJ3 AND DJ4;
DRAWTEXT(HKDJ AND FILTER(HKDJ,10),L,'2黑客点击'),COLORRED;
{红衣侠女}
XN1:=ABS(1-HHV(EMA55,5)/LLV(EMA55,5))<0.02;
XN2:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
XN3:=C>O AND V>REF(V,1) AND C>EMA55;
HYXN:=XN1 AND XN2 AND XN3;
DRAWTEXT(HYXN AND FILTER(HYXN,5),L,'2红衣侠女'),COLORRED;
{海底捞月}
LY1:=COUNT(ABS(1-EMA55/EMA34)<0.1,20)>=16;
LY2:=COUNT(CROSS(EMA34,EMA13),40)>=1 AND COUNT(CROSS(EMA55,EMA13),40)>=1;
LY3:=CROSS(EMA13,EMA55);
HDLY:=LY1 AND LY2 AND LY3;
DRAWTEXT(HDLY AND FILTER(HDLY,5),L-0.3L,'2海底捞月'),COLORRED;
{均线互换}
JXHH:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(JXHH,L-0.4L,'2均线互换'),COLORRED;
{梅开二度}
MKED1:=BARSLAST(REF(CROSS(EMA34,EMA13),1));
MKED2:=COUNT(H>=EMA55,MKED1)=MKED1;
MKED:=MKED2 AND CROSS(EMA13,EMA34);
DRAWTEXT(MKED,L-0.2L,'2梅开二度'),COLORRED;
{一阳三线}
YY1:=C>EMA13 AND O<EMA13;
YY2:=C>EMA34 AND O<EMA34;
YY3:=C>EMA55 AND O<EMA55;
YYSX:=YY1 AND YY2 AND YY3;
DRAWTEXT(YYSX,L-0.2L,'2一阳三线'),COLORRED;
{揭竿而起}
MAX3:=MAX(MAX(EMA13,EMA34),EMA55);
MIN3:=MIN(MIN(EMA13,EMA34),EMA55);
JG1:=ABS(EMA13-EMA34)<C*0.05;{13线34线55线接近}
JG2:=ABS(EMA34-EMA55)<C*0.05;
JG3:=C>=O*1.03 AND C>MAX3;{阳线3%}
JG4:=O>MIN3 AND O<MAX3;
JG5:=C>REF(H,5);
JG6:=(C-EMA34)/EMA34<=0.15;{控制价高}
JG7:=V>MA(V,5) AND MA(V,10);
JGEQ:=JG1 AND JG2 AND JG3 AND JG4 AND JG5 AND JG6 AND JG7;
DRAWTEXT(JGEQ,L-0.2L,'2揭竿而起'),COLORRED;
{三线推进}
MAX4:=MAX(MAX(MAX(EMA13,EMA34),EMA55),H);
MIN4:=MIN(MIN(MIN(EMA13,EMA34),EMA55),L);
SXTJ1:=HHV(MAX4,60);
SXTJ2:=LLV(MIN4,60);
SXTJ3:=EVERY(ABS(1-SXTJ1/SXTJ2)<0.3,20);
SXTJ:=SXTJ3 AND (YYSX OR JGEQ);
DRAWTEXT(SXTJ AND FILTER(SXTJ,10),L-0.2L,'2三线推进'),COLORRED;
{双蹄并进}
STBJ1:=CROSS(DMI.PDI,DMI.MDI);
STBJ2:=ABS(1-DMI.ADX/DMI.ADXR)<0.1;
STBJ:=STBJ1 AND STBJ2;
DRAWTEXT(STBJ,L-0.2L,'2双蹄并进'),COLORRED;
{投石问路}
TSWL1:=CROSS(EMA13,EMA34) AND EMA13<EMA55;
DRAWTEXT(TSWL1,L-0.2L,'2投石问路'),COLORRED;
{三军集结}
SJJJ3:=REF(EMA55,1)>REF(EMA13,1);
SJJJ4:=ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.005;
SJJJ:=SJJJ3 AND SJJJ4;
DRAWTEXT(SJJJ AND FILTER(SJJJ,5),L-0.2L,'2三军集结'),COLORRED;
三军集结:=SJJJ AND FILTER(SJJJ,5);
XG:三军集结,NODRAW;
{浪子回头}
LZ1:=REF(C,2)<REF(O,2) AND REF(C,1)<REF(O,1) AND C<O;
LZ2:=C<=REF(C,1) AND REF(C,1)<=REF(C,2);
LZ3:=MA(V,3)<REF(V,3);
LZ4:=REF(C,3)>EMA13 AND (C>EMA55 OR ABS(1-C/EMA55)<0.01);
LZHT:=LZ1 AND LZ2 AND LZ3 AND LZ4;
DRAWTEXT(LZHT AND FILTER(LZHT,5), H+0.2H,'3浪子回头'),COLORBLUE;
{走四方}
ZSF1:=REF(C,4)>REF(O,4) AND (REF(C,4)>EMA13 OR REF(C,4)>EMA34) AND (ABS(1-REF(EMA55,4)/EMA55)<0.01 OR MA(EMA55,4)>REF(EMA55,5));
ZSF2:=COUNT(ABS((1-REF(C,1)/C)*100)<3,4)=4 AND MA(V,4)<REF(V,4)*0.8;
ZSF:=ZSF1 AND ZSF2;
DRAWTEXT(ZSF AND FILTER(ZSF,4), H+0.2H,'3走四方'),COLORBLUE;
{暗度陈仓}
ADCC1:=O/C>1.05 AND EMA13/EMA55<1.1 AND EMA13>MA(EMA13,5);
ADCC2:=O/REF(C,1)<1.03;{V<HHV(REF(V,1),5) AND V/MA(REF(V,1),5)<2};
ADCC:=ADCC1 AND ADCC2;
DRAWTEXT(ADCC, H+0.2H,'3暗度陈仓'),COLORBLUE;
{一石二鸟}
YSEN1:=REF(C,2)>REF(O,2) AND REF(C,1)<REF(O,1) AND C<O;
YSEN2:=REF(C,2)>EMA55 AND EMA13>EMA55 AND EMA13>=MA(EMA13,5);
YSEN3:=REF(V,2)>REF(V,1) AND REF(V,2)>V;
YSEN:=YSEN1 AND YSEN2 AND YSEN3;
DRAWTEXT(YSEN, H+0.2H,'3一石二鸟'),COLORBLUE;
{双飞燕}
SFY1:=EMA13>EMA34 AND EMA34>EMA55;
SFY2:=REF(O,1)>=REF(C,2) AND O>=REF(C,1) AND REF(C,2)>=REF(O,2);
SFY3:=COUNT(C>O AND C/O<1.02,2)=2 OR COUNT(C<O AND O/C<1.02,2)=2;
SFY4:= V<REF(V,1);
SFY:=SFY1 AND SFY2 AND SFY3 AND SFY4;
DRAWTEXT(SFY AND FILTER(SFY,2), H+0.2H,'3双飞燕'),COLORBLUE;
{三剑客}
SJK1:=EMA13>EMA34 AND EMA34>EMA55;
SJK2:=COUNT(C<=O AND O/C<1.03,3)=3 AND COUNT(ABS(1-REF(C,1)/C)<1.03,2)=2;
SJK:=SJK1 AND SJK2;
DRAWTEXT(SJK AND FILTER(SJK,3), H+0.2H,'3三剑客'),COLORBLUE;
{四星望月}
SXWY1:=COUNT(C>=O AND C/O<1.03,4)=4;
SXWY2:=(ABS(EMA13-EMA34)+ABS(EMA34-EMA55))/C<0.1;{主均线相距很近或基本持平}
SXWY3:=EMA13<EMA55;
SXWY:=SXWY1 AND SXWY2 AND SXWY3;
DRAWTEXT(SXWY AND FILTER(SXWY,5), H+0.2H,'3四星望月'),COLORBLUE;
{星星点灯}
XXDD1:=ABS(1-C/O)*100<=2.5 AND H/MAX(C,O)>1.03 AND REF(C,1)/REF(O,1)>1.05;
XXDD2:=O>=REF(C,1) AND ABS(1-REF(EMA13,1)/EMA55)<0.1;
XXDD:=XXDD1 AND XXDD2;
DRAWTEXT(XXDD,H+0.2H,'3星星点灯'),COLORBLUE;
{小鸟依人}
XNYR1:=REF(C,1)/REF(O,1)>1.05;
XNYR2:=O<=REF(C,1) AND ABS(1-C/O)<0.02;
XNYR3:=COUNT(JGEQ OR YYSX OR HYXN,10)>=1 AND COUNT(JGEQ OR YYSX OR HYXN,2)=0;
XNYR:=XNYR1 AND XNYR2 AND XNYR3;
DRAWTEXT(XNYR, H+0.2H,'3小鸟依人'),COLORBLUE;
{立竿见影}
LGJY1:=O<=REF(C,1) AND V<REF(V,1) AND C<O;
LGJY2:=COUNT(JGEQ OR YYSX OR HYXN,2)=1;
LGJY:=LGJY1 AND LGJY2;
DRAWTEXT(LGJY, H+0.2H,'3立竿见影'),COLORBLUE;
{一阴三线}
YYSX1:=C<EMA13 AND O>EMA13;{一阴三线}
YYSX2:=C<EMA34 AND O>EMA34;
YYSX3:=C<EMA55 AND O>EMA55;
YYYSX:=YYSX1 AND YYSX2 AND YYSX3;
DRAWTEXT(YYYSX,H+0.4H,'4一阴三线'),COLORGREEN;
{落井下石}
LJXS1:=O<REF(L,1) AND EMA13/EMA55>1.05 AND C<O;
DRAWTEXT(LJXS1,H+0.4H,'4落井下石'),COLORGREEN;
{晨钟暮鼓}
CZMG1:=REF(C,1)/REF(O,1)>1.05 AND REF(V,1)/REF(V,2)>2 AND HSL>3;
CZMG2:=C>O AND V<REF(V,1);
CZMG:=CZMG1 AND CZMG2;
DRAWTEXT(CZMG,H+0.4H,'4晨钟暮鼓'),COLORGREEN;
{见好就收}
Y:=(EMA13-EMA55)/EMA13*100;
JHJX:=REF(Y,1)<=10 AND Y>10;
{DRAWICON(JHJX,H,1);}
DRAWTEXT(JHJX,H+0.4H,'4见好就收'),COLORGREEN;
{一枝独秀}
YZ1:=C/O>1.01 AND H/C>1.025 ;{收阳有上影}
YZ2:=EMA13>MAX(EMA34,EMA55) AND C>1.05*EMA13 AND O>MA(C,11);{昨收阳 今大于均线}
YZDX:=YZ1 AND YZ2;
DRAWTEXT(YZDX,H+0.4H,'4一枝独秀'),COLORGREEN;
{独上高楼}
DSGL1:=REF(C,1)>=REF(O,1);
DSGL2:=O/REF(C,1)>1.029 AND O/C>1.03 AND O/MAX(EMA13,EMA55)>1.03;
DSGL:=DSGL1 AND DSGL2;
DRAWTEXT(DSGL,H+0.4H,'4独上高楼'),COLORGREEN;
{分道扬镳}
FDYB:=CROSS(EMA34,EMA13) AND EMA34>EMA55;
DRAWTEXT(FDYB,H+0.4H,'4分道扬镳'),COLORGREEN;
{突出重围}
TCCW1:=REF(EMA55,1)<REF(EMA13,1);
TCCW2:=EMA13<LLV(REF(EMA13,1),5) AND ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.008;
TCCW:=TCCW1 AND TCCW2;
DRAWTEXT(TCCW AND FILTER(TCCW,5),H+0.4H,'4突出重围'),COLORGREEN;
{明修栈道}
MXZD1:=C/O>1.07;
MXZD2:=EMA13>HHV(REF(EMA13,1),5) AND V>HHV(REF(V,1),10) AND V/MA(REF(V,1),5)>2;
MXZD:=MXZD1 AND MXZD2;
DRAWTEXT(MXZD,H+0.4H,'4明修栈道'),COLORGREEN;
{拖泥带水}
TNDS1:=O/REF(C,1)>1.05 AND MIN(C,O)/L>1.03;
TNDS2:=C/MAX(EMA13,EMA55)>1.03 AND C>REF(C,1);
TNDS:=TNDS1 AND TNDS2;
DRAWTEXT(TNDS,H+0.4H,'4拖泥带水'),COLORGREEN;
{金蝉脱壳}
JCTQ1:=C<O AND (EMA13/EMA55>1.1 OR (C/MIN(EMA13,EMA55)>1.1)) AND EMA13>MA(EMA13,5);
JCTQ2:=REF(O,1)>=REF(C,2) AND REF(C,1)>REF(O,1) AND O<=REF(C,1) AND C>REF(O,1);
JCTQ:=JCTQ1 AND JCTQ2;
DRAWTEXT(JCTQ,H+0.4H,'4金蝉脱壳'),COLORGREEN;
{一箭穿心}
YJCX:=CROSS(EMA55,EMA13);
DRAWTEXT(YJCX,H+0.4H,'4一箭穿心'),COLORGREEN;
{过河拆桥}
GHCQ1:=C<O AND O/C>=1.04;
GHCQ2:=O>EMA13 AND C<EMA13;
GHCQ3:=EMA13/EMA55>1.1 AND ABS(1-EMA13/MA(EMA13,3))<0.02;
GHCQ:=GHCQ1 AND GHCQ2 AND GHCQ3;
DRAWTEXT(GHCQ,H+0.4H,'4过河拆桥'),COLORGREEN;
{狗急跳墙}
GJTQ1:=O/REF(C,1)>1.02 AND L>REF(C,1);
GJTQ2:=V>MA(V,5);
GJTQ3:=EMA13/EMA55>1.1;
GJTQ:=GJTQ1 AND GJTQ2 AND GJTQ3;
DRAWTEXT(GJTQ,H+0.4H,'4狗急跳墙'),COLORGREEN;
{一剑封喉}
YJFH1:=REF(C,1)>=REF(O,1);
YJFH2:=H/MAX(C,O)>=1.035 ;
YJFH3:=V/MA(REF(V,1),11)>3 AND EMA13/EMA55>1.05;
YJFH:=YJFH1 AND YJFH2 AND YJFH3;
DRAWTEXT(YJFH,H+0.4H,'4一剑封喉'),COLORGREEN;
{节外生枝}
JWSZ1:=EMA13>MAX(EMA34,EMA55) AND EMA13/EMA55>1.1 AND REF(C,1)>1.04*EMA13 AND REF(C,1)/REF(O,1)>1.04;
JWSZ2:=ABS(1-C/O)<0.015 AND ABS(1-REF(C,1)/C)<0.02;
JWSZ:=JWSZ1 AND JWSZ2;
DRAWTEXT(JWSZ,H+0.4H,'4节外生枝'),COLORGREEN;
{笑里藏刀}
XLCD1:=REF(H,1)/MAX(REF(C,1),REF(O,1))>1.04;
XLCD2:=H<REF(H,1) AND O>=REF(C,1);
XLCD3:=EMA13/EMA55>1.05 AND C/EMA13>1.03;
XLCD:=XLCD1 AND XLCD2 AND XLCD3;
DRAWTEXT(XLCD,H+0.4H,'4笑里藏刀'),COLORGREEN;

公式挺好,就是要修改

举报

使用道具 点亮(1) 扔鸡蛋(0) 回复

我儿子是富翁
Lv.1
发表于 2020-11-4 00:03 复制 查看全部楼层
在哪里下载

举报

使用道具 扔鸡蛋(0) 回复

一杯清茶666
Lv.2
发表于 2020-11-3 04:44 复制 查看全部楼层
快乐飞牛 发表于 2020-10-24 22:30
**** 作者被禁止或删除 内容自动屏蔽 ****

楼主,能否分享一下指标,无法下载呀。

举报

使用道具 扔鸡蛋(0) 回复

ckh
Lv.3
发表于 2020-11-1 10:12 复制 查看全部楼层
感谢老师指标。

举报

使用道具 扔鸡蛋(0) 回复

王洪存509
Lv.5
发表于 2020-10-30 22:12 复制 查看全部楼层
谢谢分享,学习收藏了

举报

使用道具 扔鸡蛋(0) 回复

股海多金
Lv.2
发表于 2020-10-30 09:21 复制 查看全部楼层
看不到是怎么回事呀

举报

使用道具 扔鸡蛋(0) 回复

历红
Lv.2
发表于 2020-10-30 07:59 复制 查看全部楼层
下载学习,谢谢分享

举报

使用道具 扔鸡蛋(0) 回复

玉华生
Lv.3
发表于 2020-10-30 00:05 复制 查看全部楼层
感谢老师的无私

举报

使用道具 扔鸡蛋(0) 回复

杨陶得
Lv.1
发表于 2020-10-29 23:53 复制 查看全部楼层
哪位大哥告诉我指标在哪里啊,看不到呢

举报

使用道具 扔鸡蛋(0) 回复

蒋国文
Lv.2
发表于 2020-10-29 16:09 复制 查看全部楼层
谢谢分享,学习收藏了!

举报

使用道具 扔鸡蛋(0) 回复

老鼠KK
Lv.4
发表于 2020-10-29 06:56 复制 查看全部楼层
蓟2010 发表于 2020-10-18 16:12
谢谢分享,学习收藏了!

指标被屏蔽了。

能否分享一下?多谢

举报

使用道具 扔鸡蛋(0) 回复

老鼠KK
Lv.4
发表于 2020-10-29 06:34 复制 查看全部楼层
没看到文件呀?

举报

使用道具 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表