手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把公式里面黑马作为选股公式

[通达信]
设置
1121 3 电工程师 Lv.3 发表于 · 2020-10-18 20:24 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VARF:=TROUGHBARS(3,15,1)<4;

多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW) /4,30)*100,3),COLORWHITE;

STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,5,0),COLORF00FF0;

STICKLINE(FILTER(VARF=1,5),50,0,2,0),COLORYELLOW;

DRAWTEXT(FILTER(VARF=1,3),50,'--黑马'),COLORRED ;

{STICKLINE(多空<-10,0,多空,0.85,0),COLORYELLOW;}

A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

FY:=EMA(A51,5);

趋势线:FY,LINETHICK1,COLORRED;

R1:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*200;

R2:=EMA((CLOSE-(LLV(LOW,5)))/((HHV(HIGH,5))-(LLV(LOW,5)))*100,4)*2;

R3:=EMA(0.618*REF(R2,1)+0.382*R2,2);

R4:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);

R5:=POW(MA(LOW,5),2)+MA(LOW,5);

R6:=POW(MA(HIGH,5),2)+MA(HIGH,5);

R7:=(R4-LLV(R5,64))/(HHV(R6,64)-LLV(R5,64))*150+65-10;

R8:=SMA((SMA(R7,3,1)*1.5-100),3,1);

R9:=3*(SMA(R7,3,1)*1.5-100)-2*R8;

R10:=(HIGH+LOW+CLOSE*2)/4;

R11:=(R10-(EMA(R10,13)))*100/(STD(R10,13));

R12:=EMA((EMA(R11,5)),13)+200-100;

R13:=(SMA(R1,3,1))+R2+(SMA(R7,3,1)*1.5-100)+R12;

R14:=(SMA((SMA(R1,3,1)),3,1))+R3+R8+(EMA(R12,10));

R15:=(3*(SMA(R1,3,1))-2*(SMA((SMA(R1,3,1)),3,1)))+(3*R12-2*(EMA(R12,10)))+

R9+(3*R12-2*(EMA(R12,10)));

R16:=(HIGH+LOW+CLOSE)/3;

R17:=(R16-MA(R16,34))/(0.015*AVEDEV(R16,34));

R18:=(HIGH+LOW+CLOSE+R16)/4;

R19:=(R18-(EMA(R18,24)))/(STD(R18,24))*100;

R20:=(R16-MA(R16,24))/(0.015*AVEDEV(R16,24));

R21:=(((EMA(R19,5))+R20+R17)/3+165)/4;

R22:=(R13+R14+R15*30)/32/5-15;

短期线: EMA(((R21+R22)/2/1.3),1),COLORMAGENTA,LINETHICK2;

长期线:MA(短期线,3),COLORYELLOW,LINETHICK2;

A1:=EMA(EMA(CLOSE,13),13);

A2:=(A1-REF(A1,1))/REF(A1,1)*6400;

A3:=100*WINNER(CLOSE*0.95);

AR1:=EMA(OPEN,7);

AR2:=EMA(AR1,21);

AR3:=CROSS(AR1,AR2);

AR5:=EMA(SMA((CLOSE-LLV(LOW,20))/(HHV(HIGH,16)-LLV(LOW,20))*100,8,1),3);

短线买:IF(TROUGHBARS(1,6,1)=0 AND HIGH>LOW+0,40,20),COLORLIBLUE;

DRAWTEXT(短线买=40,40,'--短线买'),COLORLIBLUE;

短线卖:IF(PEAKBARS(2,9,1)=1,60,80),COLORMAGENTA;

DRAWTEXT(短线卖=60,60,'--短线卖'),COLORMAGENTA;

中线买 : IF(TROUGHBARS(3,18,1)=0 AND HIGH>LOW+0.1,15,0),COLORLIMAGENTA,LINETHICK2;

DRAWTEXT(中线买=15,15,'--中线买'),COLORLIMAGENTA;

中线卖: IF(PEAKBARS(2,15,1)=0,85,100),COLORGREEN;

DRAWTEXT(中线卖=85,90,'--中线卖'),COLORGREEN;

中线:50,COLORWHITE;

全线买: (ZIG(3,35)>REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)<REF(ZIG(3,35),2))*100,STICK,COLORRED,LINETHICK6;

DRAWTEXT(全线买=100,90,'--全线买'),COLORRED;

全线卖: (ZIG(3,35)<REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)>REF(ZIG(3,35),2))*100,STICK,COLORGREEN,LINETHICK6;

DRAWTEXT(全线卖=100,15,'--全线卖'),COLORGREEN;

举报

扔鸡蛋(0) 回复

电工程师
Lv.3
发表于 2020-10-18 20:39 复制 查看全部楼层
谢谢老师辛苦

举报

扔鸡蛋(0) 回复

兴科
Lv.5
发表于 2020-10-18 20:38 复制 查看全部楼层
VARF:=TROUGHBARS(3,15,1)<4;
黑马:FILTER(VARF=1,3);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-18 20:35 复制 查看全部楼层
未来信号 ,谨慎使用


VARF:=TROUGHBARS(3,15,1)<4;

黑马:FILTER(VARF=1,3);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表