手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把公式合并下

[通达信]
设置
809 3 赛文sex Lv.2 发表于 · 2020-10-18 22:29 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
第一个:
VAR15:=MA(CLOSE,5);
VAR16:=MA(CLOSE,13);
VAR17:=MA(CLOSE,21);
VAR18:=MA(CLOSE,34);
VAR19:=MA(CLOSE,55);
VAR20:=MA(CLOSE,144);
VAR21:=MA(CLOSE,233);

WW5:=RANGE(VAR15 ,O,C);
QQ13:=RANGE(VAR16 ,O,C);
GG21:=RANGE(VAR17 ,O,C);
DD34:=RANGE(VAR18 ,O,C);
WW55:=RANGE(VAR19 ,O,C);
TT144:=RANGE(VAR20 ,O,C);
GG233:=RANGE(VAR21 ,O,C);
JJBB:=WW5+QQ13+GG21+DD34+WW55+TT144+GG233;

VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,34);
MAVOL3:=MA(VOLUME,144);

V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);

选股:JJBB>=3 AND V2>=1;

第二个:
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

辰星线:=(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211;
CROSS(C,辰星线) AND VAR19;
本主题由 任务系统 于 2020-10-19 00:10 审核通过

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-10-19 07:49 复制 查看全部楼层

VAR115:=MA(CLOSE,5);
VAR116:=MA(CLOSE,13);
VAR117:=MA(CLOSE,21);
VAR118:=MA(CLOSE,34);
VAR119:=MA(CLOSE,55);
VAR20:=MA(CLOSE,144);
VAR21:=MA(CLOSE,233);

WW5:=RANGE(VAR115 ,O,C);
QQ13:=RANGE(VAR116 ,O,C);
GG21:=RANGE(VAR117 ,O,C);
DD34:=RANGE(VAR118 ,O,C);
WW55:=RANGE(VAR119 ,O,C);
TT144:=RANGE(VAR20 ,O,C);
GG233:=RANGE(VAR21 ,O,C);
JJBB:=WW5+QQ13+GG21+DD34+WW55+TT144+GG233;

VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,34);
MAVOL3:=MA(VOLUME,144);

V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);

选股:=JJBB>=3 AND V2>=1;

YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

辰星线:=(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211;
CROSS(C,辰星线) AND VAR19 AND 选股;
查看全部打赏
  • 赛文sex+1理想币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(0) 扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-19 05:16 复制 查看全部楼层
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) && CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) && CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) && VAR1);
VAR25:=MA(CLOSE,5);
VAR26:=MA(CLOSE,13);
VAR27:=MA(CLOSE,21);
VAR28:=MA(CLOSE,34);
VAR29:=MA(CLOSE,55);
VAR30:=MA(CLOSE,144);
VAR31:=MA(CLOSE,233);
WW5:=RANGE(VAR25 ,O,C);
QQ13:=RANGE(VAR26 ,O,C);
GG21:=RANGE(VAR27 ,O,C);
DD34:=RANGE(VAR28 ,O,C);
WW55:=RANGE(VAR29 ,O,C);
TT144:=RANGE(VAR30 ,O,C);
GG233:=RANGE(VAR31 ,O,C);
JJBB:=WW5+QQ13+GG21+DD34+WW55+TT144+GG233;
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,34);
MAVOL3:=MA(VOLUME,144);
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
辰星线: (20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211;
XG: JJBB>=3 && V2>=1 && CROSS(C,辰星线) && VAR19;
查看全部打赏
  • 赛文sex+1理想币 : 很给力,投资愉快,理想因你而精彩;

举报

扔鸡蛋(0) 回复

勤学务实
Lv.2
发表于 2020-10-19 05:16 复制 查看全部楼层
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) && CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) && CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) && CLOSE<=REF(CLOSE,1) && CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) && CLOSE>=REF(CLOSE,1) && CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) && VAR1);
VAR25:=MA(CLOSE,5);
VAR26:=MA(CLOSE,13);
VAR27:=MA(CLOSE,21);
VAR28:=MA(CLOSE,34);
VAR29:=MA(CLOSE,55);
VAR30:=MA(CLOSE,144);
VAR31:=MA(CLOSE,233);
WW5:=RANGE(VAR25 ,O,C);
QQ13:=RANGE(VAR26 ,O,C);
GG21:=RANGE(VAR27 ,O,C);
DD34:=RANGE(VAR28 ,O,C);
WW55:=RANGE(VAR29 ,O,C);
TT144:=RANGE(VAR30 ,O,C);
GG233:=RANGE(VAR31 ,O,C);
JJBB:=WW5+QQ13+GG21+DD34+WW55+TT144+GG233;
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,34);
MAVOL3:=MA(VOLUME,144);
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
辰星线: (20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211;
XG: JJBB>=3 && V2>=1 && CROSS(C,辰星线) && VAR19;
查看全部打赏
  • 赛文sex+1理想币 : 感谢交流,感恩分享,收获正能量。
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表