手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将副图指标改写成二个选股指标

[通达信]
设置
1287 2 想好再说 Lv.3 发表于 · 2020-10-20 11:32 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师将副图指标改写成二个选股指标,要求各选出当天出现红柱和粉柱的选股指标,谢谢!

DRAWGBK(C>O,RGB(10,0,0),RGB(0,0,0),1,2,1);
{主图买入}
A10:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A11:=SMA(A10,3,1);
A12:=SMA(A11,3,1);
A13:=3*A11-2*A12;
A14:=C-REF(C,1);
A15:=100*EMA(EMA(A14,6),6)/EMA(EMA(ABS(A14),6),6);
买入:=LLV(A15,2)=LLV(A15,7) AND COUNT(A15<0,2) AND CROSS(A15,MA(A15,2));

MA5:=MA(C,5);
MA20:=MA(C,20);
角度5:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
角度60:=ATAN((MA(C,60)/REF(MA(C,60),1)-1)*100)*57.3;
A51:= REF(MA5,1)*0.98;
A52:= REF(MA5,2)*0.98;
B52:= BARSLAST(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))+2;
B51:= BARSLAST(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))+1;
DZ:=IF((REF(C,2)>=REF(MA5,2)) AND (REF(C,1)<REF(MA5,1)),IF(REF(MA5,2)<REF(MA5,1),A51,A52),IF(BARSSINCE(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))>0,IF(REF(MA5, B52)< REF(MA5, B51),REF(MA5,B51)*0.98, REF(MA5,B52)*0.98), REF(MA5,1)));
A201:= REF(MA20,1)*0.98;
A202:= REF(MA20,2)*0.98;
B202:= BARSLAST(REF(C,2)>=REF(MA20,2) AND REF(C,1)<REF(MA20,1))+2;
B201:= BARSLAST(REF(C,2)>=REF(MA20,2) AND REF(C,1)<REF(MA20,1))+1;
ZZ:=IF((REF(C,2)>=REF(MA20,2)) AND (REF(C,1)<REF(MA20,1)),IF(REF(MA20,2)<REF(MA20,1),A201,A202),IF(BARSSINCE(REF(C,2)>=REF(MA20,2) AND REF(C,1)<REF(MA20,1))>0,IF(REF(MA20, B202)< REF(MA20, B201),REF(MA20,B201)*0.98, REF(MA20,B202)*0.98), REF(MA20,1)));
短止:=DZ,COLORWHITE,LINETHICK2;
紫线:=ZZ,COLORMAGENTA;
绿线:=LLV(REF(LOW,1),2)+(HHV(REF(HIGH,1),2)-LLV(REF(LOW,1),2))/2,COLORGREEN;
黄线:=MA(CLOSE,25)+MA(CLOSE,25)*6/100,COLORYELLOW,LINETHICK2;
白轨:=MA(CLOSE,25)+MA(CLOSE,25)*20/100,COLORWHITE;
影子线:=MA(CLOSE,25)+MA(CLOSE,25)*13/100,COLORGRAY;
AZZ:=LLV(REF(LOW,1),2)+(HHV(REF(HIGH,1),2)-LLV(REF(LOW,1),2))/2,COLORGREEN;
AXX:=((((MA(C,10) > MA(C,25)) && CROSS(C,MA(C,5))) && (V > MA(V,10))) && (MA(C,10) > REF(MA(C,10),1)));
ASS:=C>=黄线 AND AXX ;
角度黄线:=ATAN((黄线/REF(黄线,1)-1)*100)*180/3.1416;
XG6:=ASS AND 买入 AND 角度黄线>0;
XG7:=C/REF(C,1)>1.08 AND C>O AND 买入;
XG8:=买入 AND 角度黄线>0;
XG9:= C>=黄线 AND (CROSS(ZIG(3,10),REF(ZIG(3,10),1))) AND 角度黄线>0;
涨停:=(C-REF(C,1))/REF(C,1)*100>9.85 AND C=H;
T:=BARSLAST(涨停);
XG1:=COUNT(C/REF(C,1)>1.09,15)>1;
XG2:= XG6 OR XG7 OR XG8 OR XG9 ;
龙回头:XG1 AND XG2,NODRAW,COLORMAGENTA;
STICKLINE(龙回头,0,3,2,0),COLORMAGENTA;
S:=BARSLAST(龙回头);
放心买: S>=1 AND S<=3 AND C/REF(C,1)>1.02 ,NODRAW,COLORGREEN;
STICKLINE(放心买,6,9,2,0),COLORGREEN;
XG10:=CROSS(C,影子线) AND C/REF(C,1)>1.03 ;
XG11:=CROSS(C,黄线) AND C/REF(C,1)>1.05 AND 角度黄线>0 ;
XG12:=CROSS(C,白轨);
突破牛:XG10 OR XG12 ,NODRAW,COLORRED;
STICKLINE(突破牛,3,6,2,0),COLORRED;
                                          【本文完】

举报

扔鸡蛋(0) 回复

想好再说
Lv.3
发表于 2020-10-20 18:48 复制 查看全部楼层
勤学务实老师好!改写的非常棒!我因有事出去回复迟了。谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-10-20 12:02 复制 查看全部楼层
{突破牛 选股}

黄线:=MA(CLOSE,25)+MA(CLOSE,25)*6/100,COLORYELLOW,LINETHICK2;
白轨:=MA(CLOSE,25)+MA(CLOSE,25)*20/100,COLORWHITE;
影子线:=MA(CLOSE,25)+MA(CLOSE,25)*13/100,COLORGRAY;
角度黄线:=ATAN((黄线/REF(黄线,1)-1)*100)*180/3.1416;
XG10:=CROSS(C,影子线) AND C/REF(C,1)>1.03 ;
XG11:=CROSS(C,黄线) AND C/REF(C,1)>1.05 AND 角度黄线>0 ;
XG12:=CROSS(C,白轨);
XG: XG10 OR XG12;


{龙回头 选股}

A14:=C-REF(C,1);
A15:=100*EMA(EMA(A14,6),6)/EMA(EMA(ABS(A14),6),6);
买入:=LLV(A15,2)=LLV(A15,7) AND COUNT(A15<0,2) AND CROSS(A15,MA(A15,2));
黄线:=MA(CLOSE,25)+MA(CLOSE,25)*6/100,COLORYELLOW,LINETHICK2;
AXX:=((((MA(C,10) > MA(C,25)) && CROSS(C,MA(C,5))) && (V > MA(V,10))) && (MA(C,10) > REF(MA(C,10),1)));
ASS:=C>=黄线 AND AXX ;
角度黄线:=ATAN((黄线/REF(黄线,1)-1)*100)*180/3.1416;
XG6:=ASS AND 买入 AND 角度黄线>0;
XG7:=C/REF(C,1)>1.08 AND C>O AND 买入;
XG8:=买入 AND 角度黄线>0;
XG9:= C>=黄线 AND (CROSS(ZIG(3,10),REF(ZIG(3,10),1))) AND 角度黄线>0;
XG1:=COUNT(C/REF(C,1)>1.09,15)>1;
XG2:= XG6 OR XG7 OR XG8 OR XG9 ;
XG:XG1 AND XG2;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表