手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股公式

[通达信]
设置
1030 1 刘写乐乐 Lv.3 发表于 · 2020-10-23 20:52 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮写个主图中出现“老鸭头”字样的时候的选股预警公式和附图公式,以下是源码,谢谢

MA5:MA(CLOSE,5),COLOR00FFFF;
MA10:MA(CLOSE,10),COLORFF00FF;
MA60:MA(CLOSE,60),COLOR00FF00;
PDAY1:=BARSLAST(CROSS(MA5,MA60));{5日均线上穿60日均线}
PDAY2:=BARSLAST(CROSS(MA10,MA60));{10日均线上穿60日均线}
PDAY3:=BARSLAST((HIGH=HHV(HIGH,PDAY2)));{形成头部要下跌}
PDAY4:=BARSLAST(CROSS(MA10,MA5));{下跌后,5日均线与10日均线形成死叉}
PDAY5:=BARSLAST(CROSS(MA5,MA10));{回落不久后,5日均线与10日均线形成金叉}
A1:=(PDAY1>PDAY2) AND (PDAY2>PDAY3) AND (PDAY3>PDAY4) AND (PDAY4>PDAY5) AND (PDAY5<5);
A2:=(COUNT(CROSS(MA10,MA5),PDAY2)=1);
AA:=IF(A1 AND A2 AND (MA(CLOSE,5)>=MA(CLOSE,10)) AND (MA(CLOSE,10)>MA(CLOSE,60)),10,0);
BB:=FILTER(A1 AND A2 AND (MA(CLOSE,5)>=MA(CLOSE,10)) AND (MA(CLOSE,10)>MA(CLOSE,60)),5);
老鸭头:IF(AA AND BB,1,0),COLOR00FF00;
DRAWICON(AA AND BB,LOW,1),COLORFFFF00;
DRAWTEXT(AA AND BB,(LOW)*(0.98),'老鸭头'),COLOR00FFFF;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-10-23 21:13 复制 查看全部楼层
MA5:=MA(CLOSE,5),COLOR00FFFF;
MA10:=MA(CLOSE,10),COLORFF00FF;
MA60:=MA(CLOSE,60),COLOR00FF00;
PDAY1:=BARSLAST(CROSS(MA5,MA60));{5日均线上穿60日均线}
PDAY2:=BARSLAST(CROSS(MA10,MA60));{10日均线上穿60日均线}
PDAY3:=BARSLAST((HIGH=HHV(HIGH,PDAY2)));{形成头部要下跌}
PDAY4:=BARSLAST(CROSS(MA10,MA5));{下跌后,5日均线与10日均线形成死叉}
PDAY5:=BARSLAST(CROSS(MA5,MA10));{回落不久后,5日均线与10日均线形成金叉}
A1:=(PDAY1>PDAY2) AND (PDAY2>PDAY3) AND (PDAY3>PDAY4) AND (PDAY4>PDAY5) AND (PDAY5<5);
A2:=(COUNT(CROSS(MA10,MA5),PDAY2)=1);
AA:=IF(A1 AND A2 AND (MA(CLOSE,5)>=MA(CLOSE,10)) AND (MA(CLOSE,10)>MA(CLOSE,60)),10,0);
BB:=FILTER(A1 AND A2 AND (MA(CLOSE,5)>=MA(CLOSE,10)) AND (MA(CLOSE,10)>MA(CLOSE,60)),5);

老鸭头XG:AA AND BB;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表