手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股公式,后一根大于前一根长度的选股公式

[通达信]
设置
936 1 一路丶向北 Lv.3 发表于 · 2020-10-24 22:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
出现红色实体柱时,后一根柱子长度大于前一根实体长度,这时出现信号,求选股公式!
长度大于前一根实体红柱!


限时日:=20210625;
限时:=IF(DATE+1900000<限时日,1,DRAWNULL);


AA1:=FORCAST(EMA(CLOSE,5),9)*限时;
AA2:=FORCAST(EMA(CLOSE,8),9)*限时;
AA3:=FORCAST(EMA(CLOSE,11),9)*限时;
AA4:=FORCAST(EMA(CLOSE,14),9)*限时;
AA5:=FORCAST(EMA(CLOSE,17),9)*限时;
B:=AA1+AA2+AA3+AA4-4*AA5;
TOWERC1:EMA(B,1), NODRAW;

VARR1:=ABS(TOWERC1)+ABS(REF(TOWERC1,1))*限时;
VARR2:=(3*CLOSE+2*OPEN+HIGH+LOW)/7;
AA6:FORCAST(EMA(VARR2,16),8), NODRAW ;

HSX:=TOWERC1>=REF(TOWERC1,1)*限时 AND AA6>=REF(AA6,1);
HKX:=TOWERC1< REF(TOWERC1,1)*限时 AND AA6>=REF(AA6,1);
LSX:=TOWERC1< REF(TOWERC1,1)*限时 AND AA6<=REF(AA6,1);
LKX:=TOWERC1>=REF(TOWERC1,1)*限时 AND AA6<REF(AA6,1);

红实芯:STICKLINE(HSX,0,VARR1,2,0)*限时, COLOR0000F0;
红空芯:STICKLINE(HKX,0,VARR1,2,1)*限时, COLOR0000F0;
蓝实芯:STICKLINE(LSX,0,VARR1,2,0)*限时,COLORFFFF12;
蓝空芯:STICKLINE(LKX,0,VARR1,2,1)*限时,COLORFFFF12;


AA7:=C>REF(O,1)*限时 AND HKX AND REF(C,1)<REF(O,1)  || C>REF(O,1) AND HSX AND REF(C,1)<REF(O,1) ;
{DRAWICON(AA7,VARR1*1.05,5);};

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-10-25 09:18 复制 查看全部楼层
限时日:=20210625;
限时:=IF(DATE+1900000<限时日,1,DRAWNULL);
AA1:=FORCAST(EMA(CLOSE,5),9)*限时;
AA2:=FORCAST(EMA(CLOSE,8),9)*限时;
AA3:=FORCAST(EMA(CLOSE,11),9)*限时;
AA4:=FORCAST(EMA(CLOSE,14),9)*限时;
AA5:=FORCAST(EMA(CLOSE,17),9)*限时;
B:=AA1+AA2+AA3+AA4-4*AA5;
TOWERC1:=EMA(B,1);
VARR1:=ABS(TOWERC1)+ABS(REF(TOWERC1,1))*限时;
VARR2:=(3*CLOSE+2*OPEN+HIGH+LOW)/7;
AA6:=FORCAST(EMA(VARR2,16),8);
红实芯:=TOWERC1>=REF(TOWERC1,1)*限时 AND AA6>=REF(AA6,1);

XG:REF(CROSS(红实芯,0.5),1) AND 红实芯 AND VARR1>REF(VARR1,1);

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表